Bug 99163 - Radeon HDMI audio lost after resuming from suspend on kernel >4.2
Summary: Radeon HDMI audio lost after resuming from suspend on kernel >4.2
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
Keywords: bisected, regression
Depends on:
Reported: 2016-12-20 19:40 UTC by Timo Valtoaho
Modified: 2019-11-20 08:00 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:

Output of scripts/ver_linux (1.19 KB, text/plain)
2016-12-21 17:16 UTC, Timo Valtoaho
no flags Details
Output of lspci -vvv (16.04 KB, text/plain)
2016-12-21 17:16 UTC, Timo Valtoaho
no flags Details
Current kernel config (77.83 KB, text/x-mpsub)
2016-12-21 17:17 UTC, Timo Valtoaho
no flags Details

Description Timo Valtoaho 2016-12-20 19:40:04 UTC

I run in to a unexpected behavior resuming from system suspend with 4.2.0 kernel, losing HDMI audio. Filed a bug at bugzilla.kernel.org over a year ago, also providing bisect data to the commit introducing the bug. Came here to file it again since that bug report was getting zero attention. Anyone interested, take a look at here:



Comment 1 Dieter Nützel 2016-12-21 16:54:56 UTC
Hello Timo,

would you be so kind to copy all your findings from bugzilla over, here?
This is _the right_ place for drm/radeon/amdgpu driver bugs.

I think Alex would have a look, then (his commit).
Linux Kernel commit : d57c0edfe00d3274b50f91ce3076ed0e82d28782

Comment 2 Timo Valtoaho 2016-12-21 17:15:30 UTC
Ok, here is the original bug report:

After switching to 4.2 series, I noticed that audio through HDMI was gone after first suspend/resume cycle (systemctl suspend). I can get audio back with some simple operations, like executing xrand, lanching gnome-control-center or swithcing to a virtual terminal (ctrl+alt+F1). All of these operations will restore audio.

I have tested this out, and it was 4.2-rc2 that introduced this issue, and is still present in 4.3-rc7. Also, it doesn't matter whether radeon driver is a module or compiled in with required firmware.

System is Debian Jessie (8.2), Gnome

Attached files:

output of scripts/ver_linux
output of lspci -vvv


Now, as time has gone by, Debian Jessie is v8.6 and due to my upgraded yet still old hardware, lspci output differs. Regardless of those, problem still persists. Radeon HW is still the same though.
Comment 3 Timo Valtoaho 2016-12-21 17:16:14 UTC
Created attachment 128613 [details]
Output of scripts/ver_linux
Comment 4 Timo Valtoaho 2016-12-21 17:16:45 UTC
Created attachment 128614 [details]
Output of lspci -vvv
Comment 5 Timo Valtoaho 2016-12-21 17:17:28 UTC
Created attachment 128615 [details]
Current kernel config
Comment 6 Timo Valtoaho 2016-12-22 18:42:38 UTC
git bisected this to d57c0edfe00d3274b50f91ce3076ed0e82d28782.

Reverting this solves the problem on all kernels including latest 4.9.0.
Comment 7 Felix Schwarz 2016-12-22 21:45:00 UTC
(In reply to Timo Valtoaho from comment #6)
> git bisected this to d57c0edfe00d3274b50f91ce3076ed0e82d28782.

commit d57c0edfe00d3274b50f91ce3076ed0e82d28782
Author: Alex Deucher <alexander.deucher@amd.com>
Date:   Wed Jul 8 14:08:12 2015 -0400

    Revert "Revert "drm/radeon: dont switch vt on suspend""
    This reverts commit ac9134906b3f5c2b45dc80dab0fee792bd516d52.
    We've fixed the underlying problem with cursors, so re-enable

That is interesting as I have a Radeon 6450 which displayed "strange" colors after suspend (often but not always) and the problem was caused exactly by the same commit. However with my card I never had problems with HDMI audio after suspend.

I never filed a bug report as I could work around the issue by switching the VT manually (e.g. Ctrl+Alt+F2 / Ctrl+Alt+F1). Even better: After moving to Wayland (F25) I did not notice the bug anymore.
Comment 8 Felix Schwarz 2016-12-22 21:52:25 UTC
Btw: bug 98832 is about a different issue but also fixed by reverting the commit in question.
Comment 9 Felix Schwarz 2016-12-29 11:31:41 UTC
Maybe a different bug but since I switched to Wayland (F25) I noticed that HDMI audio (Radeon HD6450) is also gone for me after suspend/resume. Never noticed that with X though. Switching VTs does not change anything for me but that might be due to using Wayland.
Comment 10 Martin Peres 2019-11-20 08:00:54 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/drm/amd/issues/765.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.