Bug 9892 - git snapshot of radeon driver crashes x.org
Summary: git snapshot of radeon driver crashes x.org
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: 7.2 (2007.02)
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: xf86-video-ati maintainers
QA Contact: Xorg Project Team
Keywords: regression
Depends on:
Reported: 2007-02-06 06:06 UTC by kowalski marcin
Modified: 2007-08-05 04:16 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Description kowalski marcin 2007-02-06 06:06:31 UTC
i'm using RV370 card (gigabyte x300se) for testing. i also have an rv515 around.

when using rv370 with git version of radeon driver x.org locks up. my lcd says "no signal". the desktop loads however and everything else works (mpd, apache etc). it's possible to shutdown the system with ctrl+alt+del. 

switching to other terminals is impossible (= no visible reaction), but _sometimes_ i can kill the xserver and display is restored.

the 6.6.3 version of the driver works perfectly, though.

the only relevant thing i found in xorg logfile is this :
0: X(xf86SigHandler+0x6d) [0x4822bd]
1: /lib/libc.so.6 [0x2b780e7c7640]
2: /usr/lib64/xorg/modules/drivers//radeon_drv.so [0x2b780f5acfe1]
3: [0x6d4360]

Fatal server error:
Caught signal 11.  Server aborting
how can i further help with this issue? 

i am using gentoo on my amd64 system, the unstable ~amd64 profile. i also have a 32bit getnoo installation on a second partition. i'll try there as well soon.
additional files http://yoshi314.ms-net.pl/logs.tar.bz2

radeon-log-663.log - normal log from 6.6.3 driver (working, with no crashes)
radeon-log-git.log - crash log with git driver (current git, just built)
xorg.conf - config file used with both drivers.

i'm unsure about my xorg version. xorg-server is at 1.2.0 so i guess i'm using 7.2.
Comment 1 Michel Dänzer 2007-02-06 07:19:29 UTC
(In reply to comment #0)
> > how can i further help with this issue? 

It would be best if you could start the X server from gdb and get a full backtrace from the crash. Note that you can only do this from a remote login.

Other than that, it might also be useful if you could isolate the change that caused this with git-bisect.
Comment 2 kowalski marcin 2007-02-08 12:41:37 UTC
additional log from 32bit installation 
(i cut the boring stuff out)

(**) RADEON(0): RADEONSaveScreen(2)
(**) RADEON(0): RADEONCloseScreen
(**) RADEON(0): EngineRestore (32/32)
(**) RADEON(0): RADEONDisplayPowerManagementSet(0,0x0)

0: X(xf86SigHandler+0x81) [0x80c56b1]
1: [0xa7f78420]
2: /usr/lib/xorg/modules/drivers//radeon_drv.so(RADEONDisplayPowerManagementSet+0x122) [0xa7bb0af2]
3: /usr/lib/xorg/modules/drivers//radeon_drv.so [0xa7b9f0c9]
4: X [0x81526d6]
5: X [0x80db91c]
6: X [0x80d7b97]
7: X [0x812b488]
8: X [0x814f555]
9: X(main+0x502) [0x806e632]
10: /lib/libc.so.6(__libc_start_main+0xef) [0xa7cdd87f]

right now i'm trying to figure out the git-bisect thing you mentioned.
Comment 3 kowalski marcin 2007-02-08 13:09:41 UTC
okay i think i got it.

i started with 
git-bisect start
git-bisect good ati_6_6_3
git-bisect bad

after each git-bisect good/bad i did
./configure --prefix=/usr
make install 

and tested.

218cb7f8db35d0ce8f9fc4ece72bd5ec3f52106f is first bad commit
commit 218cb7f8db35d0ce8f9fc4ece72bd5ec3f52106f
Author: Dave Airlie <airlied@linux.ie>
Date:   Sun Dec 3 09:53:35 2006 +1100

    radeon: dynamically allocate connectors

:040000 040000 b4ce69d956bf595903d2ef3a6113ad2207e6f810 1159ce3a6908370f70bf66260704eb9deb60000a M      src
Comment 4 Daniel Stone 2007-02-27 01:36:13 UTC
Sorry about the phenomenal bug spam, guys.  Adding xorg-team@ to the QA contact so bugs don't get lost in future.
Comment 5 kowalski marcin 2007-07-21 03:12:44 UTC
i tried recently with new snapshot (just built, a couple of minutes ago).

i used drm modules from kernel with gentoo-patches. 

i'm using xorg-server-, and mesa 6.5.3 (but that doesn't matter much, does it?).

after modprobing drm modules : (dmesg)
[  773.704733] [drm] Initialized drm 1.1.0 20060810
[  773.706819] [drm] Initialized radeon 1.27.0 20060524 on minor 0

symptoms, as before - my lcd goes into powersaving mode with "No Signal" message. when launching X.

0: X(xf86SigHandler+0x81) [0x80c7141]
1: [0xb7f7c420]
2: /usr/lib/xorg/modules/drivers//radeon_drv.so(RADEONDisplayPowerManagementSet+0x122) [0xb7b9ec22]
3: /usr/lib/xorg/modules/drivers//radeon_drv.so [0xb7b8cce8]
4: X [0x8160ad0]
5: X [0x80dd3cc]
6: X [0x80d9627]
7: X [0x813a878]
8: X [0x815e405]
9: X(main+0x503) [0x8070303]
10: /lib/libc.so.6(__libc_start_main+0xef) [0xb7d5e9ff]

[pressed ctrl+atl+bksp]

Fatal server error:
Caught signal 11.  Server aborting

(II) RADEON(0): RADEONRestoreMemMapRegisters() :
(II) RADEON(0):   MC_FB_LOCATION   : 0x1fff0000
(II) RADEON(0):   MC_AGP_LOCATION  : 0x27ff2000

and i was lucky enough to return to the console.

do i need to upgrade additional x.org components to git snapshots as well?

using gcc-4.1.2 if that matters (seems that 4.2 caused a lot of kernel breakage recently).
Comment 6 Alex Deucher 2007-07-21 07:30:08 UTC

*** This bug has been marked as a duplicate of bug 10772 ***
Comment 7 kowalski marcin 2007-08-04 03:04:34 UTC
6.6.193 fixed segfaults and crashes, but i'm still not getting anything on screen.

how do i investigate further? unfortunately i only have one pc, so i can't use remote debugging, as suggested previously :/
Comment 8 kowalski marcin 2007-08-05 04:16:16 UTC
i think i got the problem. 

i'll open a new bug and close this one, because it's quite a different problem.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.