Bug 88843 - [BDW-Y Regression] S3 will call trace for the third or more time and can't do S3 any more
Summary: [BDW-Y Regression] S3 will call trace for the third or more time and can't do...
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
Keywords: bisect_pending
Depends on:
Reported: 2015-01-28 08:17 UTC by Li Xu
Modified: 2015-02-28 01:17 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:

call trace (219.23 KB, image/jpeg)
2015-01-28 08:17 UTC, Li Xu
no flags Details
Works with 10 S3 (122.39 KB, text/plain)
2015-02-27 05:39 UTC, Jeff Zheng
no flags Details

Description Li Xu 2015-01-28 08:17:49 UTC
Created attachment 112902 [details]
call trace

System Environment:

good commit:   

Platform: BDW-Y


-nightly latest 9438dec1c7538fdd3b356a59ca929632fcb57132

Bug detailed description:
I have tried S3 on BDW-Y with the night-latest kernel. And the first S3 can work normally.The second and third times, it has write error: Resource temporarily unavailable. 
If any more ,it will call trace and can’t S3 any more.
Since the machine doesn't have any serial port or built-in network card, we can't catch the dmesg. And the call trace message seen as the attached picture.

echo mem>/sys/power/state for several times.
Comment 1 liulei 2015-02-04 06:26:18 UTC
Without i915 module, blank screen problem occurs after s3 resume , but the system is alive.
If I load i915 module, the system will hang after second s3 operation.
Comment 2 Jeff Zheng 2015-02-05 02:26:03 UTC
This issue also exists on BSW with BIOS V55 and -testing 2015_01_30 commit 4d3645e40c7039f60b6db0ce9c2251ac34faef81 : System will hang after S3 several times.
Comment 3 Jeff Zheng 2015-02-06 08:36:02 UTC
I reported BSW system hang issue as a new bug 89005.
Comment 4 Imre Deak 2015-02-06 09:56:29 UTC
(In reply to Jeff Zheng from comment #3)
> I reported BSW system hang issue as a new bug 89005.

Looks like an SCSI issue. Could you still try if you can reproduce the issue booting with the i915.modeset=0 kernel parameter?
Comment 5 Jeff Zheng 2015-02-27 05:39:28 UTC
Created attachment 113851 [details]
Works with 10 S3

I tried S3 10 times on 2015_02_27 drm-intel-nightly commit 376ebc108c774b357e211b5fc0aab558fc89ede9, and didn't reproduce this issue. Attached is the dmesg log.
Comment 6 Gordon Jin 2015-02-28 01:16:56 UTC
let's close it as we can't reproduce it.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.