Some functions for removing items from a container use the word "remove", and some functions use the word "steal". Let's try to be consistent, and only use "remove" when the function also frees the removed item (if the free callback is set). So, pa_hashmap_remove() should be renamed to pa_hashmap_steal().
-- GitLab Migration Automatic Message --
This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.
You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/pulseaudio/pulseaudio/issues/355.