Bug 6668 - Black Screen on Xorg 7.1RC1 and Via K8M800 with DRI enabled
Summary: Black Screen on Xorg 7.1RC1 and Via K8M800 with DRI enabled
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Via (show other bugs)
Version: (7.1RC1)
Hardware: Other Linux (All)
: high major
Assignee: Xorg Project Team
QA Contact:
Keywords: patch
: 7010 (view as bug list)
Depends on:
Reported: 2006-04-20 05:31 UTC by Kurt
Modified: 2006-07-21 07:22 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:

Xorg log file with dri enabled (34.15 KB, text/x-log)
2006-04-20 05:33 UTC, Kurt
no flags Details
Xorg log file without dri enabled (34.66 KB, application/x-trash)
2006-04-20 05:34 UTC, Kurt
no flags Details
Xorg config file (3.72 KB, text/plain)
2006-04-20 05:38 UTC, Kurt
no flags Details
Kernel Log file up to the point of rebooting (21.42 KB, text/x-log)
2006-04-20 05:56 UTC, Kurt
no flags Details
Add missing assert.h file (334 bytes, patch)
2006-05-03 03:19 UTC, Marcin Kurek
no flags Details | Splinter Review

Description Kurt 2006-04-20 05:31:56 UTC
I am able to launch into my ICEWM desktop but only with DRI disabled 
in /etc/X11/xorg.conf. If dri is enabled then I get a black screen. The system 
is still responsive but only a Crtl-Alt-Del and the subsequent reboot that 
follows, will recover the screen.

Looking at /var/log/Xorg.0.log indicates that server startup hangs during dri 

Xorg 7.0 works ok on this machine with dri enabled.
Kernel version is
libdrm version is 2.0.1
Comment 1 Kurt 2006-04-20 05:33:16 UTC
Created attachment 5385 [details]
Xorg log file with dri enabled
Comment 2 Kurt 2006-04-20 05:34:22 UTC
Created attachment 5386 [details]
Xorg log file without dri enabled
Comment 3 Kurt 2006-04-20 05:38:31 UTC
Created attachment 5387 [details]
Xorg config file

This is the xorg config file without DRI commented out.
Comment 4 Kurt 2006-04-20 05:56:26 UTC
Created attachment 5389 [details]
Kernel Log file up to the point of rebooting
Comment 5 Erik Andren 2006-04-20 16:11:50 UTC
I had a similar problem and were able to resolve it by updating to current mesa
Also try to see if disabling AIGLX helps. 
Comment 6 Kurt 2006-04-22 03:51:25 UTC
I tried to compile with --disable-aiglx as well as compile with the server and
the via driver against cvs mesa.

I still get the same problem:

Just a black screen.

Of course commenting "Load dri" out of the modules section of xorg.conf solves
the black screen problem but obviously X is unaccelerated.

Using strace, it appears that the via driver spews errors about

"undefined symbol assert" 

then exits, leaving the screen black.

I am currently recompiling the server with debugging enabled.

Comment 7 Marcin Kurek 2006-05-03 03:17:58 UTC
This problem is caused by xf86_ansic.h removal. In the via_dri.c there is
assert() call but there is no assert.h included and this cause driver to fail if
dri is enabled.

The fix is realy trivial.
Comment 8 Marcin Kurek 2006-05-03 03:19:03 UTC
Created attachment 5549 [details] [review]
Add missing assert.h file
Comment 9 Kurt 2006-05-03 20:02:59 UTC
That patch fixed it. I had no idea it was so simple. Thanks
Comment 10 Joshua Baergen 2006-05-16 12:46:27 UTC
It doesn't look like this has hit CVS yet, so it's not technically fixed.  If it
is in CVS, it's a different patch from the one suggested here.
Comment 11 Kurt 2006-05-16 13:08:49 UTC
I wondered about that. I even came back to this page to reopen the bug. 

I take that you are also having issue with the same driver?
Comment 12 Joshua Baergen 2006-05-17 00:51:56 UTC
I'm not using it, but some Gentoo users are reporting the issue ( http://bugs.
gentoo.org/show_bug.cgi?id=130320 ).
Comment 13 Thomas Hellström 2006-05-23 09:08:11 UTC
Commited now.
I removed the assert().

Comment 14 Thomas Hellström 2006-07-21 07:22:42 UTC
*** Bug 7010 has been marked as a duplicate of this bug. ***

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.