Bug 4999 - Freeze while on MacMini, possible related to sound usage.
Summary: Freeze while on MacMini, possible related to sound usage.
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: 6.8.2
Hardware: PowerPC Linux (All)
: high normal
Assignee: Xorg Project Team
QA Contact:
Keywords: patch
Depends on:
Reported: 2005-11-09 14:27 UTC by John Eckerdal
Modified: 2007-02-22 14:28 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

The configuration file used (3.14 KB, text/plain)
2005-11-09 14:28 UTC, John Eckerdal
no flags Details
lspci -v list of the MacMini (3.01 KB, text/plain)
2005-11-09 14:29 UTC, John Eckerdal
no flags Details
Linux CPU info for the MacMini (308 bytes, text/plain)
2005-11-09 14:30 UTC, John Eckerdal
no flags Details
The patch that is applied to the freezing version. (1.47 KB, text/plain)
2005-11-10 13:32 UTC, John Eckerdal
no flags Details
Patch applied to the working version (1.57 KB, text/plain)
2005-11-10 13:33 UTC, John Eckerdal
no flags Details

Description John Eckerdal 2005-11-09 14:27:33 UTC
(Note: This was reported to RH bugzilla. I was asked to report it here also. 
The xorg version provided by Red Hat is 6.8.2 based but I am not sure exactly
what has been patched.)

If I install any version (tried previous versions of xorg-x11 from the
development version) of xorg-x11 from FC-devel then I experience random
freezes/crashes on my MacMini.
Since I am in X I do not know what happened. There is nothing in the logs after
the freeze has happened.

I am not entirely sure which version the Fedora Core-devel version matches in
the plain xorg-x11.

It seems slightly related to the sound system but not entirely sure.

I use XFCE 4 (development version) and XFmedia.

I can use the new development version of as long as I do not try to listen to
music, or sometimes even start the xfmedia application. Either I can listen to
music for a while (in X) and then a freeze occurs or the freeze happens as soon
as I open the xfmedia application.

I do not use the stock Red Hat kernel since this does not include power
management to control the fan (atleast it did not in earlier versions making the
fan run at full speed all times). I have experience these issues with kernels, and 2.6.14.

Also if I enable DRI in the xorg-x11 config file I can not use X at all. The
graphics do not seem so sync with the monitor correctly (the graphics is
severely corrupted - it looks like one single pixel line is compressed into only
a few pixels).

As included in the xorg-x11 config file below I also had to enable UseFBDev to
get any useful graphical output (atleast with the standard FC4 xorg-x11 releases).

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Start X
2. Start xfmedia
3. Use computer in X and after a non-deterministic time a freeze will happen.

Actual Results:  The following operation causes freezes at random times.

Expected Results:  No freeze.

Additional info:

Every version I tried in the development version of X11 causes freezes.
Comment 1 John Eckerdal 2005-11-09 14:28:16 UTC
Created attachment 3759 [details]
The configuration file used
Comment 2 John Eckerdal 2005-11-09 14:29:55 UTC
Created attachment 3760 [details]
lspci -v list of the MacMini
Comment 3 John Eckerdal 2005-11-09 14:30:36 UTC
Created attachment 3761 [details]
Linux CPU info for the MacMini
Comment 4 John Eckerdal 2005-11-09 14:33:35 UTC
I do not have the Xorg log file for the problematic installation I notice.
If needed I can try to recreate it.

Also, this is the RH bugzilla id is: 172537

Comment 5 John Eckerdal 2005-11-09 14:37:19 UTC
Also it should be noted:

The FC version xorg-x11-6.8.2-37.FC4.49.2 works fine, xorg-x11-6.8.2-58 (for
example) does not.
Comment 6 Michel Dänzer 2005-11-09 23:08:13 UTC
(In reply to comment #5)
> The FC version xorg-x11-6.8.2-37.FC4.49.2 works fine, xorg-x11-6.8.2-58 (for
> example) does not.

Please try to track down which change between these two versions causes the
problem then.
Comment 7 John Eckerdal 2005-11-10 13:31:37 UTC
The following has changed between the working and the non-working version:

1. The most likely candidate: Modifications on how "Dynamic Clocks" are handeled
has been modified. My current configuration runs with default setting for
"DynamicClocks". According to the log file this defaults to off:

(II) RADEON(0): Dynamic Clock Scaling Disabled

Atleast if it is disabled then I get no freeze. I will try to install the newer
version again and disable dynamic clocks and see if I get the freeze.

The exact modifications performed between the two version is attached to this

2. A patch to workaround volatile problems in gcc has been dropped since it
should be fixed in gcc-4.0.1-4 (RH build) which should have been used to compile
the package.

3. A modification enabling DRI for Radeon RV100 has been modified. This radeon
is an RV280.

4. The patch for CAN-2005-2495 (allocating too large pixmaps) is not included in
the version that freezes

5. Support i945 is not included in the version that freezes (should not be
related since that is an Intel chip and this is not an Intel platform).

6. A leak in the shadow framebuffer is fixed in the non-freezing version.

7. A patch to remove ProPolice stuff is removed in the freezing version.
Comment 8 John Eckerdal 2005-11-10 13:32:34 UTC
Created attachment 3769 [details]
The patch that is applied to the freezing version.

This is the patch that is applied to the freezing version.
Comment 9 John Eckerdal 2005-11-10 13:33:06 UTC
Created attachment 3770 [details]
Patch applied to the working version

This is the patch applied to the working version.
Comment 10 Erik Andren 2006-04-20 06:05:37 UTC
Are you still experiencing this problem with feodora core 5?
Comment 11 Erik Andren 2006-05-21 18:58:48 UTC
Comment 12 John Eckerdal 2006-05-22 03:53:31 UTC
No, I have not upgraded to Fedora Core 5 so I can not give input if this has
fixed the problem or not.

Before FC5 was released I tried installing some of the Rawhide versions to see
if it fixed the problem but all those version refused to set the screens native
resolution (which is 1680x1050).
Comment 13 Timo Jyrinki 2007-02-22 14:28:36 UTC
Marking broken (status null/blank) bugs in xorg with no activity in a long time as fixed. Please reopen if you think it's necessary, but first do a search if a similar bug report is already filed and in a NEW/ASSIGNED state. These bugs do not currently show in most search results as they do not have any status.

Sorry for this janitorial spam, you know where to send hate mails to when your inbox gets full of bugs you're subscribed to.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.