Bug 4590 - SegFault with glxinfo in savage_xmesa.c
Summary: SegFault with glxinfo in savage_xmesa.c
Alias: None
Product: DRI
Classification: Unclassified
Component: libGL (show other bugs)
Version: XOrg git
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Default DRI bug account
QA Contact:
Keywords: have-backtrace
Depends on:
Reported: 2005-09-25 15:32 UTC by David
Modified: 2005-09-27 15:25 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Description David 2005-09-25 15:32:55 UTC
I compiled and installed Xorg, Mesa and DRM from CVS today, following the
directions in the DRI wiki. I also copied libraries on Mesa/lib/ into
/usr/X11R6/lib/ and symlinked in /usr/lib, so the programs use mesa cvs libraries.
Xorg says that DRI is enabled. No problems, no errors. All seem ok.
But when I run glxinfo I get a segmentation fault in savage_xmesa.c, line 834,
where it reads: "assert(backRb->Base.Data);"
I also get the same segfault in other programs, like the winpos demo.
Kernel from SUSE.

Here is the backtrace:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1076967104 (LWP 14034)]
0x4036d3f4 in savageMakeCurrent (driContextPriv=0x805b528,
driDrawPriv=0x82dbb38, driReadPriv=0x82dbb38)
    at savage_xmesa.c:834
834           assert(backRb->Base.Data);
(gdb) bt
#0  0x4036d3f4 in savageMakeCurrent (driContextPriv=0x805b528,
    driReadPriv=0x82dbb38) at savage_xmesa.c:834
#1  0x40367ec8 in DoBindContext (dpy=0x804d008, draw=58720258, read=58720258,
    modes=0x8056c90, psp=0x8057768) at dri_util.c:344
#2  0x40367f61 in driBindContext (dpy=0x804d008, scrn=0, draw=58720258,
read=58720258, ctx=0x80583b8)
    at dri_util.c:377
#3  0x4005bc29 in BindContextWrapper (dpy=0x804d008, gc=0x8058308,
draw=58720258, read=58720258)
    at glxext.c:1522
#4  0x4005be4b in MakeContextCurrent (dpy=0x804d008, draw=58720258,
read=58720258, gc=0x8058308)
    at glxext.c:1610
#5  0x4005c18f in glXMakeCurrent (dpy=0x804d008, draw=58720258, gc=0x8058308) at
#6  0x08049ab7 in main (argc=1, argv=0xbffff144) at glxinfo.c:266
Comment 1 Brian Paul 2005-09-28 07:20:32 UTC
I've updated the assertions a bit.  Do a check-out and try again.
Comment 2 David 2005-09-28 08:25:54 UTC
Now it works.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.