Bug 3806 - after xstart pressing any key changing the video mode only
Summary: after xstart pressing any key changing the video mode only
Alias: None
Product: xorg
Classification: Unclassified
Component: App/xkbcomp (show other bugs)
Version: 6.8.2
Hardware: x86 (IA32) Linux (All)
: lowest critical
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
Keywords: l10n
Depends on:
Reported: 2005-07-18 07:50 UTC by Tamas SZERB
Modified: 2011-09-24 22:32 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Description Tamas SZERB 2005-07-18 07:50:23 UTC

I have no ide what to do to fix this annoying feature, by default when I start
the X the only effect what I get is to changing the video mode (resolution) when
I press any key.

Renaming the /etc/X11/xkb directory causes that the X server starts up correctly
but of course I have no XKB:

toma@inky:~$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "base", "pc101", "us", "", ""

because it is only a falled back config:

(II) XINPUT: Adding extended input device "Configured Mouse" (type: MOUSE)
(II) XINPUT: Adding extended input device "Generic Keyboard" (type: KEYBOARD)
(EE) Couldn't load XKB keymap, falling back to pre-XKB keymap
(II) Configured Mouse: ps2EnableDataReporting: succeeded

my related config:

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "keyboard"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc104"
        Option          "XkbLayout"     "us"

which is pretty "default".

The most interesting part of it: the same happens when I try to use xfree86. And
I tried to purge everything in /etc/X11 and /usr/lib/X11, after reinstalling
everything I got the same. And, I tried to used Ps2 keyboard instead of my USB
MS one, same effect.

And it's a bit surprising, I remember, there was a time, with my old config,
when it worked. But something changed, honestly, I don't know what, I hope you
can give me some hints. I tried strace xorg at the startup, but I haven't seen
any further reading of xkb config. Can you tell me something positive? :)

I can't use any non-US keyboard layout...

I'm using x86 debian unstable.

You're my last hope,

Comment 1 Daniel Stone 2007-02-27 01:27:22 UTC
Sorry about the phenomenal bug spam, guys.  Adding xorg-team@ to the QA contact so bugs don't get lost in future.
Comment 2 Jeremy Huddleston Sequoia 2011-09-24 22:32:42 UTC
Old bug with no other reports.  Please reopen if you are still experiencing problems.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.