Bug 36005 - Screen flicker approx. every 30 seconds
Summary: Screen flicker approx. every 30 seconds
Alias: None
Product: upower
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: high normal
Assignee: Richard Hughes
QA Contact:
Keywords: regression
: 33437 (view as bug list)
Depends on:
Reported: 2011-04-05 14:56 UTC by Bryce Harrington
Modified: 2011-04-13 23:58 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:

BootDmesg.txt (56.63 KB, text/plain)
2011-04-05 14:56 UTC, Bryce Harrington
CurrentDmesg.txt (2.45 KB, text/plain)
2011-04-05 14:57 UTC, Bryce Harrington
XorgLog.txt (49.31 KB, text/plain)
2011-04-05 14:57 UTC, Bryce Harrington

Description Bryce Harrington 2011-04-05 14:56:18 UTC
Forwarding this bug from Ubuntu reporter Lucas Reece:

Screen flicker approx. every 30 seconds after updating to Natty.

The system itself is 4 years old and has booted previous Linux distros and versions without seeing this flicker before.

[Original Description]
Booting from the live CD and subsequently after installing, the screen flickers to black and back every 30 seconds or so.

Using daily build of Natty (2011-03-02).

DistroRelease: Ubuntu 11.04
Package: xorg 1:7.6~3ubuntu9
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic i686
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
 status: connected
 enabled: enabled
 dpms: On
 modes: 1280x1024 1280x1024 1152x864 1024x768 1024x768 800x600 800x600 640x480 640x480 720x400
Date: Wed Mar  2 19:11:15 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
 ATI Technologies Inc RV516 [Radeon X1300/X1550 Series] [1002:7183] (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:0302]
   Subsystem: Dell Device [1028:0303]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110302)
MachineType: Dell Inc. Dell DM061
 LANG=en_GB.UTF-8ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-5-generic root=UUID=14233ea6-5c49-447c-b3a6-2b9c132deb9b ro quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/24/2007
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 2.4.0
dmi.board.name: 0WG864
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 6
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr2.4.0:bd05/24/2007:svnDellInc.:pnDellDM061:pvr:rvnDellInc.:rn0WG864:rvr:cvnDellInc.:ct6:cvr:
dmi.product.name: Dell DM061
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.4-0ubuntu3
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1~git20110215.cc1636b6-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu9
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu5
Comment 1 Bryce Harrington 2011-04-05 14:56:59 UTC
Created attachment 45320 [details]
Comment 2 Bryce Harrington 2011-04-05 14:57:20 UTC
Created attachment 45321 [details]
Comment 3 Bryce Harrington 2011-04-05 14:57:42 UTC
Created attachment 45322 [details]
Comment 4 Bryce Harrington 2011-04-05 15:02:22 UTC
Several other people claim to have the same issue.  All remark that they did not have the issue on maverick but have on natty.  Of those, several have tested with turning KMS off via radeon.modeset=0 and found that made the flickering go away, but led to some other issues.

One of these other people adds these test findings:

Silvio-frishi on 3/26:
I have the same problem on natty64 with VGA video projectors.

I tested it with two computers with two different drivers (xf86-video-ati, xf86-video-nouveau).
I tested it with three different video projector.
I tested it with three different VGA cables.
I tested it with kernels 2.6.35, 2.6.37, 2.6.38
I tested it with libdrm(i.e. libkms) 2.4.21, 2.4.23 (remark here i didn't reboot)

And it always flickered (with exception 3. projector see below).

Remark with two of three projectors I used addmode since the drivers didn't recognize the native resolution of the beamer.

Everything always worked well if I used my old Gentoo (2.6.33 - but with KMS,ati and with addmode)

With the 3. projector in natty it worked properly because it recognized the native resolution. But if I
added an other resolution to it and changed to that it flickered again.

so it's possible It has some thing to do with --addmode

I think this worked on Maverik but I'm not sure since I didn't use --addmode much
Comment 5 Alex Deucher 2011-04-05 15:03:35 UTC
Most likely this is upowerd or keventd polling the outputs using randr at 30 second intervals looking for a monitor.  If nothing is connected, load detection will be attempted which on analog outputs which can cause a flicker.  They shouldn't be doing that as the kms drm will automatically generate events when outputs are connected.
Comment 6 Tobias Droste 2011-04-07 18:00:01 UTC
*** Bug 33437 has been marked as a duplicate of this bug. ***
Comment 7 Priit Tamboom 2011-04-07 22:21:42 UTC
I have same regression with Debian Sid[1].At the moment I'm using quick and ugly workaround and kill upowerd[2] in order to make external monitor usable without going blank/reseting settings after every ~30 seconds. 

Anyhow, if you need any output, I'm glad to provide.

[1] Linux  2.6.38-2-686 #1 SMP Tue Mar 29 17:27:45 UTC 2011 i686 GNU/Linux
[2] pkill -9 upowerd
Comment 8 Tobias Droste 2011-04-11 06:51:16 UTC
It is "fixed" for me in version 0.9.9 because of this commit:


with PollDockDevices=false in UPower.conf it's only relying on uevents and stops polling sysfs.
Comment 9 Martin Pitt 2011-04-13 23:58:56 UTC
So marking this as fixed then, thanks for checking!

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.