Bug 35909 - [SNB] Screen freezes a few seconds after login and renders the system unusable.
Summary: [SNB] Screen freezes a few seconds after login and renders the system unusable.
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium blocker
Assignee: Chris Wilson
QA Contact:
Keywords: NEEDINFO
Depends on:
Reported: 2011-04-02 10:05 UTC by debianuser2011
Modified: 2017-07-24 23:05 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:

dmesg (59.33 KB, text/plain)
2011-04-05 20:00 UTC, debianuser2011
no flags Details
Xorg.log (29.75 KB, text/plain)
2011-04-05 20:01 UTC, debianuser2011
no flags Details
netconsole.log (with 2.6.32 kernel) (2.57 KB, text/plain)
2011-04-14 12:21 UTC, debianuser2011
no flags Details

Description debianuser2011 2011-04-02 10:05:29 UTC
After installing Debian Sid on a brand new computer with a GA-H67A-UD3H motherboard and an Intel Core i5-2400 CPU @ 3.10GHz, the screen freezes within a few seconds after loggin in to any graphical desktop enviroment, or when trying to use a virtual console.A hard boot is then neccessary for recovery. No artifacts appear on the screen but I can't move the mouse pointer or use the keyboard, the only way to recover is a hard boot. The computer works fine with an older 2.6.32 kernel but then I can't use the newer intel graphics drivers which of course means no native resolution and no graphics acceleration. I tried using the xorg intel drivers from experimental and compiling mesa 7.11 from git but there was no improvement. Below follows a summary of my system.

Motherboard:  GIGABYTE GA-H67A-UD3H
Proccessor:   Intel Core i5-2400 @ 3.10GHz
OS:           Debian Unstable (Sid) x86-64
Kernel:       2.6.38-2-amd64
xorg version: 1:7.6+5
xserver-xorg-video-intel version: 2:2.14.0-4 (also tried 2:2.14.902-1+exp1 from experimental)
mesa version: 7.10-4 (also tried 7.11 from git)
Comment 1 Gordon Jin 2011-04-05 06:12:24 UTC
So it sounds like a kernel regression
Comment 2 Chris Wilson 2011-04-05 06:21:24 UTC
Grodon, you mean a regression from a kernel without a driver to one with? ;-)

There's no clear information here yet. Most likely it is a GPU hang with a hard hang during i915_reset(). But it could be another example of Jesse's favourite: borked hardware...

To test my theory: add i915.reset=0 to your grub kernel parameters (or echo 0 > /sys/module/i915/parameters/reset) and provoke the crash. Hopefully it won't hang and you can then attach the dmesg (preferably with drm.debug=0xe), Xorg.log and /sys/kernel/debug/dri/0/i915_error_state.
Comment 3 debianuser2011 2011-04-05 19:59:20 UTC
Thanks for responding Chris. Unfortunately your suggestion of setting i915.reset=0 didn't help. The computer works when booting in recovery mode so I added dmesg with drm.debug=0xe as you instructed. The contents of i915_error_state again in recovery mode are simply "no error collected" and luckily I can send you an Xorg.log too since the OS manages to create one before it crashes.

I did some further testing and using a 2.6.32 kernel is not without its problems either. The computer will hang with a blank screen when attempting to use a virtual console or log out/shutdown (at first I mistook the crash for a normal shutdown). It seems that when using 2.6.32 all goes well only as long as you stay logged in to the desktop enviroment.
Comment 4 debianuser2011 2011-04-05 20:00:36 UTC
Created attachment 45331 [details]
Comment 5 debianuser2011 2011-04-05 20:01:33 UTC
Created attachment 45332 [details]
Comment 6 Chris Wilson 2011-04-12 12:08:32 UTC
I wonder if it is possible for you to setup a netconsole in order to capture any death throes from the kernel? If it is not a i915_reset() error, it is likely that something interesting will be emitted just before it hangs.
Comment 7 debianuser2011 2011-04-14 12:19:06 UTC
I got mixed results. No extra messages appear when using the 2.6.38 kernel, the machine just hangs silently. When using 2.6.32, the machine hangs whenever I try to use a virtual console, change the screen resolution or logout but this time running netcat displays some extra messages. I attach the extra error messages I get when I'm trying to logout. Other cases are identical minus the last three lines above the 'rebooting' message.
Comment 8 debianuser2011 2011-04-14 12:21:27 UTC
Created attachment 45622 [details]
netconsole.log (with 2.6.32 kernel)
Comment 9 Jesse Barnes 2011-06-16 10:49:54 UTC

Does the above patch help at all for your bug?
Comment 10 debianuser2011 2011-06-19 02:30:57 UTC
I finally nailed down the problem to the motherboard. A few days ago I purchased a new Z68 motherboard and replacing the motherboard leaving all other hardware the same solves the bug. The driver now works well both with 3D and compositing, my only complaint currently being that the frame rate drops to 30fps when vsync is on in compiz.

Unfortunately I can not help with further testing as I sold the old motherboard to someone who is building a Windows machine. This also means I have no way of telling whether the aforementioned patch is of any help or not.

At any rate, thank you all for your help and suggestions.
Comment 11 Jesse Barnes 2011-06-20 10:42:38 UTC
Ok, thanks for the update.  I guess we have to mark this as "invalid" then since we won't be able to narrow it down further.  Sounds like it may be fixed though, which is good news.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.