Bug 34714 - Occasional screen corruption after upgrading intel driver from 2.13.901 to 2.14
Summary: Occasional screen corruption after upgrading intel driver from 2.13.901 to 2.14
Status: RESOLVED DUPLICATE of bug 34584
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.6 (2010.12)
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Chris Wilson
QA Contact: Xorg Project Team
Depends on:
Reported: 2011-02-25 04:26 UTC by Simon Strandman
Modified: 2011-03-03 13:40 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

Example (449.15 KB, image/png)
2011-02-25 04:26 UTC, Simon Strandman
no flags Details
Xorg.0.log (29.71 KB, text/plain)
2011-02-25 04:27 UTC, Simon Strandman
no flags Details
Better example (292.03 KB, image/png)
2011-02-25 05:00 UTC, Simon Strandman
no flags Details

Description Simon Strandman 2011-02-25 04:26:17 UTC
Created attachment 43793 [details]

I recently updates my intel driver from 2.13.901 to 2.14 on my Acer Aspire One D150 netbook, and now I'v been having some screen corruption issues. It happens rarely and there are no errors in Xorg.0.log nor dmesg. Despite this the system is perfectly stable. I can't remember having any issues like this with 2.13.901 nor 2.12.

I'm using ubuntu 10.10 32bit with the latest updates, the graphics card is an Intel Mobile 945GME, the kernel is at version 2.6.38-rc4 and xserver is at 1.9.0, compiz is enabled. I compiled the intel driver from sources with no build options other than setting the prefix.
Comment 1 Simon Strandman 2011-02-25 04:27:23 UTC
Created attachment 43794 [details]
Comment 2 Simon Strandman 2011-02-25 05:00:32 UTC
Created attachment 43797 [details]
Better example

A better example, it's 100% reproducible by opening a picture in EOG and zooming in and out.

Also I just reverted to 2.13.901 and I can confirm that it doesn't happen with that version.
Comment 3 Simon Strandman 2011-02-28 02:16:18 UTC
I tried some various versions and the regressions seems to have happened between 2.13.901 and 2.13.902.

I also tried a git-snapshot from yesterday and it improved the situation a lot, I can't reproduce the bug with EOG anymore, but corruption still happens when for example scrolling up and down in a transparent gnome-terminal and in sometimes in chrome.
Comment 4 Simon Strandman 2011-03-03 13:40:30 UTC

*** This bug has been marked as a duplicate of bug 34584 ***

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.