Would be good to have tp_capabilities_supports_{stream,dbus}_tube (TpCapabilities *self, TpHandleType handle_type, const gchar *service);
http://git.Collabora.co.uk/?p=user/cassidy/telepathy-glib;a=shortlog;h=refs/heads/tube-cap-30204
> +tp_capabilities_supports_stream_tube To be consistent (and grammatically correct), this should be "supports_stream_tubes". I'd prefer it if you added supports_dbus_tubes at the same time: static gboolean tp_capabilities_supports_tubes_common (TpCapabilities *self, const gchar *expected_channel_type, TpHandleType expected_handle_type, const gchar *expected_service_prop, const gchar *expected_service) { ... the same thing you already implemented, but with expected_channel_type and expected_service_prop instead of constants ... } gboolean tp_capabilities_supports_stream_tubes (TpCapabilities *self, TpHandleType handle_type, const gchar *service) { return tp_capabilities_supports_tubes_common (self, TP_IFACE_CHANNEL_TYPE_STREAM_TUBE, handle_type, TP_PROP_CHANNEL_TYPE_STREAM_TUBE_SERVICE, service); } gboolean tp_capabilities_supports_dbus_tubes (TpCapabilities *self, TpHandleType handle_type, const gchar *service) { return tp_capabilities_supports_tubes_common (self, TP_IFACE_CHANNEL_TYPE_DBUS_TUBE, handle_type, TP_PROP_CHANNEL_TYPE_DBUS_TUBE_SERVICE, service); }
Fixed, squashed and rebased http://git.Collabora.co.uk/?p=user/cassidy/telepathy-glib;a=shortlog;h=refs/heads/tube-cap-30204 I also changed the "Since:" as it's for 0.13 now.
Congratulations, you've implemented the first feature in 0.13.x. review+
(In reply to comment #4) > Congratulations, you've implemented the first feature in 0.13.x. review+ \o/ Merged. Will be in 0.13.1
Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.