Bug 30084 - [965] GPU hangs when trying to use program "MOE" [gl]
Summary: [965] GPU hangs when trying to use program "MOE" [gl]
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.4 (2008.09)
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Carl Worth
QA Contact: Xorg Project Team
Keywords: NEEDINFO
Depends on:
Reported: 2010-09-08 02:43 UTC by Mathias
Modified: 2010-10-18 02:07 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

Xorg.0.log (115.86 KB, text/plain)
2010-09-08 02:43 UTC, Mathias
no flags Details
dmesg output after the hang (30.80 KB, text/plain)
2010-09-08 02:44 UTC, Mathias
no flags Details
xorg.conf - Nothing unusual (2.35 KB, text/plain)
2010-09-08 02:44 UTC, Mathias
no flags Details
last batch buffer (771.05 KB, text/plain)
2010-09-08 02:46 UTC, Mathias
no flags Details

Description Mathias 2010-09-08 02:43:31 UTC
Created attachment 38543 [details]

This happens on every System with intel graphics chip and intel graphics driver (tried different versions on different distributions - currently GENTOO):
When I start the (proprietary) program MOE (Molecular Operating Environment) and try to do something with it (e.g. build/sketch a molecule) the Xserver hangs.

Sample system: 
ASUSTeK Computer INC. P5Q-EM DO (Q45 Chipset)
 system architecture: x86_64
 xf86-video-intel :   2.12.0
 xserver:             1.8.2
 mesa:                7.8.2
 libdrm:              2.4.21
 kernel version:      2.6.35-gentoo-r5
 Linux distribution:  Gentoo
 Display connector:   VGA

Reproducing steps: 
start X11
start MOE
try to sketch molecule

Unfortunately I didn't find any other (opensource) program to reproduce this issue and this program works when an nvidia card and driver is used. But I have more than 30 PCs in a teaching room where this program is needed to run. And I can't buy them all nvidia cards.  I also tried older version of the xserver/driver a.s.o but the problem is not new.
Comment 1 Mathias 2010-09-08 02:44:19 UTC
Created attachment 38544 [details]
dmesg output after the hang
Comment 2 Mathias 2010-09-08 02:44:56 UTC
Created attachment 38545 [details]
xorg.conf - Nothing unusual
Comment 3 Mathias 2010-09-08 02:46:25 UTC
Created attachment 38546 [details]
last batch buffer
Comment 4 Chris Wilson 2010-09-08 07:18:26 UTC
This will require further error state capture in the kernel. In the meantime, all I can advise is to track changes in mesa and if at all possible create a minimal test case.
Comment 5 Mathias 2010-09-13 02:42:52 UTC
At least on a Dell Inspiron 1525 Notebook this crash does not happen when using "reduced" Quality settings for the display.
The Tip came from the support of the MOE program:

"The problem is that the graphics driver is reporting
that it supports Open GLSL version 1.2, when the
hardware does not.  This means that you will get a
crash when you display molecules in the main MOE
window with the real time ray tracing turned on and
the  anti-aliasing in the "High Quality"  mode."

Maybe this could be an additional hint...

When I have a little bit more time I could setup a PC using the latest drivers, xorg and mesa from git to test the newest code.
Comment 6 Chris Wilson 2010-09-13 03:20:50 UTC
The Inspiron 1525 has a 965GM, right? If so that is only slightly less capable than q45 and has hardware support for OpenGL2.1.

This is just your typical driver bug, just that the current error capturing is inadequate for us to be able to fix bugs solely on the error state for this generation of chipsets.

So please do continue to find what the triggering factors are and please do check with the unstable drivers. Thanks.
Comment 7 Eric Anholt 2010-10-14 17:10:50 UTC
There are fixes in Mesa master now for several things that could hang the GPU in 7.9, so definitely test current Mesa.
Comment 8 Mathias 2010-10-18 02:07:32 UTC
(In reply to comment #7)
> There are fixes in Mesa master now for several things that could hang the GPU
> in 7.9, so definitely test current Mesa.

Last Friday I updated Xorg, intel driver and mesa to the last GIT versions and today I found some time to test on a Q45 PC:
I assume it will work on the other intel graphics platforms as well (although I can only further test Q57 and an old centrino (1) notebook).

It works!!! No crashes anymore. (At least the usual actions which led to the crash don't work now :-)

Thanks to all of you. I close this bug now.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.