Bug 29964 - EuroSign should not affect fourth level
Summary: EuroSign should not affect fourth level
Alias: None
Product: xkeyboard-config
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: xkb
QA Contact:
Keywords: NEEDINFO
Depends on: 29950
  Show dependency treegraph
Reported: 2010-09-02 02:05 UTC by Rimas Kudelis
Modified: 2018-12-28 00:33 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

out.xkb (56.83 KB, text/plain)
2010-09-03 23:43 UTC, Rimas Kudelis

Description Rimas Kudelis 2010-09-02 02:05:29 UTC
Currently, enabling EuroSign option (e.g. eurosign(e)) not only adds € symbol to the third level of E key, but also totally drops the fourth level function of that key. This shouldn't be like that.

I tried editing the definitions in eurosign file like this:

xkb_symbols "e" {
    key <AD03>  { [  NoSymbol,   NoSymbol,   EuroSign,   NoSymbol ] };

but it had absolutely no effect. The fourth level of E key still remains empty for me, so I suppose it's a bug somewhere deeper.

I guess it's probably the best to fix this bug as part of bug 29950, thus I'm marking this bug as depending on it.
Comment 1 Sergey V. Udaltsov 2010-09-02 14:29:15 UTC
Could you please provide the output of

xkbcomp :0 -xkb out.xkb

when you have that XKB option enabled?
Comment 2 Rimas Kudelis 2010-09-03 23:43:39 UTC
Created attachment 38419 [details]

This is what I get regardless of whether or not I add NoSymbol to Level 4 in eurosign definition.
Comment 3 Sergey V. Udaltsov 2010-11-15 14:32:03 UTC
I just tried your version:

xkb_symbols "e" {
    key <AD03>  { [  NoSymbol,   NoSymbol,   EuroSign,   NoSymbol ] };

On output, I see:

    key <AD03> {
        symbols[Group1]= [ e, E, EuroSign, E ]

I am running Ubuntu 10.10, latest xkeyboard-config from git.

Could you please check again? What's your software?
Comment 4 Sergey V. Udaltsov 2010-11-15 14:34:47 UTC
Anyway, committed NoSymbol on 4th level in all eurosign:* options
Comment 5 GitLab Migration User 2018-12-28 00:33:52 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config/issues/18.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.