Bug 2743 - sig11 during startup with glint driver
Summary: sig11 during startup with glint driver
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/glint (show other bugs)
Version: 6.8.2
Hardware: x86 (IA32) Linux (All)
: high major
Assignee: Xorg Project Team
QA Contact:
Keywords: want-backtrace
Depends on:
Reported: 2005-03-15 13:47 UTC by Bruce H. McIntosh
Modified: 2006-12-01 06:10 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:

xorg logfile from failed startup (44.73 KB, text/plain)
2005-03-15 13:48 UTC, Bruce H. McIntosh
no flags Details
xorg config file from failed startup - xinerama, nv, glint, tdfx (5.04 KB, text/plain)
2005-03-15 13:49 UTC, Bruce H. McIntosh
no flags Details

Description Bruce H. McIntosh 2005-03-15 13:47:33 UTC
System is Slackware10 with Dropline Gnome.  After upgrading to Dropline Gnome
2.8.2, with Xorg 6.8.2, the glint driver no longer loads.  Pertinent excerpt
from Xorg.0.log:

(WW) ****INVALID MEM ALLOCATION**** b: 0x20000000 e: 0x21ffffff correcting
(WW) ****INVALID MEM ALLOCATION**** b: 0x22000000 e: 0x23ffffff correcting
(WW) ****INVALID IO ALLOCATION**** b: 0xffffff00 e: 0xffffffff correcting
Symbol fbdevHWAdjustFrame from module
/usr/X11R6/lib/modules/drivers/glint_drv.o is unresolved!
Comment 1 Bruce H. McIntosh 2005-03-15 13:48:19 UTC
Created attachment 2122 [details]
xorg logfile from failed startup
Comment 2 Bruce H. McIntosh 2005-03-15 13:49:49 UTC
Created attachment 2123 [details]
xorg config file from failed startup - xinerama, nv, glint, tdfx
Comment 3 Adam Jackson 2005-03-16 13:10:19 UTC
interesting.  you should be able to work around this by saying Load "fbdevhw" in
the Module section of xorg.conf, for now.  but that still shouldn't happen.
Comment 4 Bruce H. McIntosh 2005-03-18 23:05:57 UTC
I tried the "fbdevhw" suggestion.  No go.  glint_drv still won't load.  Of
course, the unresovled symbol error did go away, so it suggests to me there's
something deeper going on here.  I still get the Invalid mem allocation errors.

Comment 5 Bruce H. McIntosh 2005-05-19 08:15:33 UTC
Latest update... Just upgraded to Slack 10.1 with Dropline Gnome 10.1.  X server
is now Xorg 6.8.2.  With fbdevhw enabled, I no longer get the unresolved symbol
error.  Now, however, the X server crashes with a Sig 11 error:

---------- tail end of Xorg.0.log ------------
(==) GLINT(1): Write-combining range (0xde800000,0x800000)
(II) GLINT(1): I2C device "DDC:ddc2" registered at address 0xA0.

   *** If unresolved symbols were reported above, they might not
   *** be the reason for the server aborting.

Fatal server error:
Caught signal 11.  Server aborting

Please consult the The X.Org Foundation support
         at http://wiki.X.Org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional

(II) Screen 0 shares mem & io resources
(II) Screen 1 shares mem & io resources
(II) Screen 2 shares mem & io resources

Comment 6 Bruce H. McIntosh 2005-06-30 08:55:25 UTC
Further data point:  Starting X with just the glint driver configured still
throws a sig 11 error.
Comment 7 Adam Jackson 2005-07-03 12:58:41 UTC
please test with one of the upcoming release candidates, or with the
snapshot (as soon as it exists), as those will be able to give more information
on the segfault.
Comment 8 Adam Jackson 2005-07-03 14:48:15 UTC
starting with the snapshot, on linux systems, the X server can print
its own backtrace when it crashes.  please confirm that these bugs are still
valid with or later, and if they are please attach a the server log
from the crash.
Comment 9 Alan Hourihane 2006-12-01 06:10:16 UTC
Closing as INVALID now. Re-test with Xorg 7.1 and reopen if the problem persists.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.