Bug 24200 - xserver 1.6.4 crash with radeon driver
Summary: xserver 1.6.4 crash with radeon driver
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/DDX/Xorg (show other bugs)
Version: unspecified
Hardware: Other All
: high major
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
Keywords: regression
: 24199 (view as bug list)
Depends on:
Blocks: xserver-1.7
  Show dependency treegraph
Reported: 2009-09-28 13:11 UTC by Jean Philippe EIMER
Modified: 2009-10-01 22:44 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:

Xserver log file with backtrace (33.87 KB, text/plain)
2009-09-28 13:11 UTC, Jean Philippe EIMER
no flags Details
Xorg.0.log of the failed startx (47.97 KB, application/octet-stream)
2009-09-28 13:37 UTC, Konstantin
no flags Details
And the dmesg of the same startxfce4 (56.08 KB, application/octet-stream)
2009-09-28 13:38 UTC, Konstantin
no flags Details

Description Jean Philippe EIMER 2009-09-28 13:11:45 UTC
Created attachment 29923 [details]
Xserver log file with backtrace

xorg-server 1.6.4 crashes at launch.
Video driver is xf86-video-ati-6.12.4, with a radeon RV620 hardware.

The same configuration worked perfectly with xorg-server 1.6.3 just before upgrading.
Comment 1 Konstantin 2009-09-28 13:37:56 UTC
Created attachment 29926 [details]
Xorg.0.log of the failed startx

Same here, Screen stays black after startxfce4. and current git both work.
Maybe I should mention that there are two Radeon RV770 in my box.

This is Xorg.0.log
Comment 2 Konstantin 2009-09-28 13:38:48 UTC
Created attachment 29927 [details]
And the dmesg of the same startxfce4
Comment 3 Julien Cristau 2009-09-28 14:21:31 UTC
http://lists.x.org/pipermail/xorg/2009-September/047428.html has a proposed patch.
Comment 4 Julien Cristau 2009-09-28 14:34:42 UTC
*** Bug 24199 has been marked as a duplicate of this bug. ***
Comment 5 Peter Hutterer 2009-09-30 20:53:42 UTC
Should be fixed with:
commit db98b26ee145f70e732e2cf4a6ac3de77fdf4adc
Author: Keith Packard <keithp@keithp.com>
Date:   Wed Sep 30 11:40:19 2009 -0700

    Re-fix DGA removal.
    Removing DGA ended up breaking any drivers calling into the old
    xf86DiDGAInit function as it tried to see if DGA was already enabled
    and ended up crashing if the VT wasn't completely initialized. Oops.
    Also, if the driver initializes DGA itself, have the DiDGA
    initialization overwrite that information as the DiDGA code will call
    ReInit on mode detect.
Comment 6 Peter Hutterer 2009-10-01 22:44:49 UTC
Pushed to 1.6 and 1.7, marking as closed. Please reopen if the problem occurs again.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.