Bug 23997 - [855GM UXA] Black Screen on Sony Vaio VGN-T2XP with Intel 2.8.1-1
Summary: [855GM UXA] Black Screen on Sony Vaio VGN-T2XP with Intel 2.8.1-1
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: Other All
: medium major
Assignee: Wang Zhenyu
QA Contact:
URL: http://cefn.com
Keywords: NEEDINFO
Depends on:
Reported: 2009-09-17 08:19 UTC by Cefn Hoile
Modified: 2017-07-24 23:09 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:

Apt Preferences file with modified pinning to carry out a rollback to repository version (359 bytes, application/octet-stream)
2009-09-17 08:19 UTC, Cefn Hoile
no flags Details
Simplest Xorg.conf which creates the black screen problem (1.13 KB, application/octet-stream)
2009-09-19 03:25 UTC, Cefn Hoile
no flags Details

Description Cefn Hoile 2009-09-17 08:19:39 UTC
Created attachment 29638 [details]
Apt Preferences file with modified pinning to carry out a rollback to repository version

Following Gordon's advice for my last bug, I upgraded to 2.8.1-1 and experienced a new bug.


Initially X seems to be loading, with the login screen appearing, but after entering a username and password and logging in, the only thing visible is the cursor. X seems to have loaded, (no failure is reported), but no colors are being written to the video buffer. The cursor changes as it rolls over invisible windows from the desktop which appears to have loaded successfully, although invisibly. 

A hard shutdown with CTRL-ALT-BACKSPACE reveals the whole desktop for a fraction of a second before shutdown.


I manually downloaded the intel driver from Debian's Squeeze testing repository...

...and all required dependencies from the same repository, leading to an install command like...
dpkg -i libaudit0_1.7.13-1_i386.deb libdrm-intel1_2.4.13-1_i386.deb libgcrypt11_1.4.4-4_i386.deb libgpg-error0_1.6-1_i386.deb xserver-xorg-core_1.6.3.901-1_i386.deb xserver-xorg-video-intel_2.8.1-1_i386.deb


To get my desktop back I needed to boot into recovery mode, then choose root shell with networking. After finding a local wireless network D-Link and connecting to it with...

iwlist eth1 scanning
iwconfig eth1 essid D-Link
dhclient eth1

...I had to change my apt preferences to increase the pinning number for all the repositories to 1000 or more to make my repositories force an install to a former version. I attach the file to show how this is done.

Subsequently I ran...

apt-get update
apt-get -d upgrade

...to check what would be changed and download while I still had a network.


apt-get -f upgrade

...rolled me back to the previous version in the repository.
Comment 1 Cefn Hoile 2009-09-17 08:22:23 UTC
Forgot to reference the previous bug. 


The previous bug has a link to an ubuntu launchpad bug with the relevant hardware profile uploaded.

This black screen bug was experienced both with and without UXA selected as an Option in xorg.conf.
Comment 2 Gordon Jin 2009-09-17 19:02:31 UTC
Which kernel are you using? 

Please provide detailed info (including logs) referring to http://www.intellinuxgraphics.org/how_to_report_bug.html.
Comment 3 Cefn Hoile 2009-09-19 03:20:52 UTC
Sorry Gordon,

Completed this bug report and then X froze again, (on UXA), so I ended up having to rewrite it and I think I left some things out.Linux cefn-mint-vaio 

$ uname -a 
2.6.30-020630-generic #020630 SMP Wed Jun 10 09:45:40 UTC 2009 i686 GNU/Linux

$ uname -m

Comment 4 Cefn Hoile 2009-09-19 03:25:44 UTC
Created attachment 29696 [details]
Simplest Xorg.conf which creates the black screen problem

This is the xorg.conf which created the problem. Nothing out of the ordinary here.
Comment 5 Cefn Hoile 2009-09-19 03:33:43 UTC
Let me know if I have to retest this configuration to create Xorg.0.log with the proper debug information. 

Ideally I'd avoid doing this as it hoses my system each time and takes some recovering from. 

My understanding is that the log won't report anything since X is properly loaded and seems to be providing a windowing session, with no obvious failures apart from the fact it's not painting visible pixels to the buffer.

Comment 6 Cefn Hoile 2009-09-19 03:36:32 UTC
Comprehensive information on my hardware is available in the downstream bug tracker at launchpad for the original freeze bug I experienced with UXA and the ubuntu Jaunty main X11 components...

Comment 7 Gordon Jin 2009-09-20 03:08:23 UTC
Can you try the kernel patch mentioned in http://bugs.freedesktop.org/show_bug.cgi?id=22904#c26?

If that still doesn't work, can you try the patch in http://bugs.freedesktop.org/show_bug.cgi?id=22947#c14?

(and remember to remove NEEDINFO in Keywords after you provide the info)
Comment 8 Wang Zhenyu 2009-10-19 23:37:30 UTC
Please try with new linus kernel, we've fixed 8xx hang issue there.
Comment 9 Wang Zhenyu 2009-12-21 21:39:37 UTC
lower severity. Any test news?
Comment 10 Chris Wilson 2010-03-02 08:23:25 UTC
I am currently tracking recent i8xx coherency issues in bug 26345. There is insufficient information here to determine whether this bug matches those. Please try to reproduce the issue with a recent kernel that includes "Record batch buffer at time of error" and upload the resulting i915_error_state.
Comment 11 Gordon Jin 2010-04-12 01:14:35 UTC
closing as lacking of response

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.