Bug 23353 - Xserver unusable when using konqueror (Qt) with opengl rendering
Summary: Xserver unusable when using konqueror (Qt) with opengl rendering
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.3 (2007.09)
Hardware: Other All
: medium normal
Assignee: Eric Anholt
QA Contact: Xorg Project Team
Keywords: NEEDINFO
Depends on:
Reported: 2009-08-16 12:49 UTC by Raúl
Modified: 2009-11-01 16:16 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

Dmesg excerpt. (28.88 KB, text/plain)
2009-08-16 12:49 UTC, Raúl
no flags Details
Xorg log. (380.21 KB, text/x-log)
2009-08-16 12:50 UTC, Raúl
no flags Details

Description Raúl 2009-08-16 12:49:42 UTC
Created attachment 28677 [details]
Dmesg excerpt.


I've tried running konqueror with Qt opengl graphic acceleration, like this: konqueror -graphicssystem=opengl

I'm on Debian sid with self build Linux UMS, KDE 4.3, Qt4.5.2, intel driver 2.8.0, drm 2.4.12, mesa 7.5, xserver 1.6.3

$ lspci -vnn -s 2.0
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a02] (rev 03) (prog-if 00 [VGA controller])
        Subsystem: Toshiba America Info Systems Device [1179:ff50]
        Flags: bus master, fast devsel, latency 0, IRQ 28
        Memory at f0000000 (64-bit, non-prefetchable) [size=1M]
        Memory at d0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at 1800 [size=8]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: <access denied>

After loading konqueror I noticed the application behaved slightly different with appearing white boxes on the rendering area when I tried to load this url: http://www.publico.es it loaded. When it was about to end it was when Xorg was unusable, yet the mouse pointed moved.

Doing ssh from another machine I got the attached dmesg excerpt. Xorg log showed nothing interesting. 

Xorg trace was normal:
#0  0x00007faea7b204a7 in ioctl () from /lib/libc.so.6
#1  0x00007faea6714673 in drmIoctl (fd=8, request=25688, arg=0x0) at ../../libdrm/xf86drm.c:188
#2  0x00007faea6714976 in drmCommandNone (fd=8, drmCommandIndex=<value optimized out>) at ../../libdrm/xf86drm.c:2344
#3  0x00007faea628f440 in I830BlockHandler (i=<value optimized out>, blockData=0x0, pTimeout=0x7fffe744b1d8, pReadmask=0x7d67a0)
    at ../../src/i830_driver.c:2228
#4  0x0000000000531248 in AnimCurScreenBlockHandler (screenNum=0, blockData=0x0, pTimeout=0x7fffe744b1d8, pReadmask=0x7d67a0)
    at ../../render/animcur.c:222
#5  0x00000000004fd4ce in compBlockHandler (i=0, blockData=0x0, pTimeout=0x7fffe744b1d8, pReadmask=0x7d67a0)
    at ../../composite/compinit.c:158
#6  0x0000000000450cd0 in BlockHandler (pTimeout=0x7fffe744b1d8, pReadmask=0x7d67a0) at ../../dix/dixutils.c:384
#7  0x00000000004ebb51 in WaitForSomething (pClientsReady=0x4a2e760) at ../../os/WaitFor.c:215
#8  0x000000000044d060 in Dispatch () at ../../dix/dispatch.c:367
#9  0x000000000043329a in main (argc=8, argv=0x7fffe744b3b8, envp=<value optimized out>) at ../../dix/main.c:397

intel_gpu_dump was way short:
ACTHD: 0x093fd2c0
EIR: 0x00000000
EMR: 0xffffffdf
ESR: 0x00000011
IPEHR: 0x60020100
Ringbuffer: Reminder: head pointer is GPU read, tail pointer is CPU write

Closedly related bugs I've seen are http://bugs.freedesktop.org/show_bug.cgi?id=23032 (for different HW) and http://bugs.freedesktop.org/show_bug.cgi?id=22336 (not sure wether the exact same problem).
Comment 1 Raúl 2009-08-16 12:50:37 UTC
Created attachment 28678 [details]
Xorg log.
Comment 2 Eric Anholt 2009-10-23 14:52:18 UTC
Could you retest with a current stack?  We've fixed a bunch of hangs since then.  If the problem still exists, though, we'll probably need a minimal testcase to make progress on the bug.
Comment 3 Raúl 2009-11-01 16:09:26 UTC
Thanks answer Eric. I've retried as you suggested and indeed the crash has gone. It's not certainly the best rendering I've seen, but that's another discussion.
Marking as fixed.
Comment 4 Raúl 2009-11-01 16:16:32 UTC
Forgot to mention my stack right now: linux, intel xorg driver 2.9.0, mesa 7.6, xserver 1.6.5, libdrm 2.4.14

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.