Bug 22760 - [UXA G33] crashes upon X initialization
Summary: [UXA G33] crashes upon X initialization
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: Other All
: highest blocker
Assignee: Keith Packard
QA Contact: Xorg Project Team
Keywords: regression
Depends on:
Reported: 2009-07-13 18:56 UTC by Emilio Pozuelo Monfort
Modified: 2009-07-15 09:53 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:

xorg.log (17.79 KB, text/plain)
2009-07-13 18:59 UTC, Emilio Pozuelo Monfort
no flags Details
xorg.conf (1.05 KB, text/plain)
2009-07-13 19:00 UTC, Emilio Pozuelo Monfort
no flags Details
dmesg (39.87 KB, text/plain)
2009-07-13 19:02 UTC, Emilio Pozuelo Monfort
no flags Details
glxinfo (11.66 KB, text/plain)
2009-07-13 19:03 UTC, Emilio Pozuelo Monfort
no flags Details
Potential fix to address overzealous pruning during the removal of NoAccel (2.14 KB, text/plain)
2009-07-14 03:17 UTC, Colin Guthrie
no flags Details

Description Emilio Pozuelo Monfort 2009-07-13 18:56:37 UTC
Bug description:

Just upgraded to packages from Debian on my Dell Vostro 200 desktop, and X crashes before starting. Downgrading the driver to solves it.

The crash is 100% reproducible.

I've tried both with a 2.6.31rc2 and with 2.6.30.

emilio@saturno:~$ uname -a
Linux saturno 2.6.31-rc2-686 #1 SMP Tue Jul 7 18:09:29 UTC 2009 i686 GNU/Linux

emilio@saturno:~$ pkg-config --modversion libdrm

The xserver is 1.6.2, libdrm-intel 2.4.11+git+20090630+de1ed01-1, mesa 7.4.4

System environment:
-- chipset:

00:02.0 VGA compatible controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])
	Subsystem: Dell Device 0238
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin A routed to IRQ 27
	Region 0: Memory at fdf00000 (32-bit, non-prefetchable) [size=512K]
	Region 1: I/O ports at ff00 [size=8]
	Region 2: Memory at d0000000 (32-bit, prefetchable) [size=256M]
	Region 3: Memory at fdc00000 (32-bit, non-prefetchable) [size=1M]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: <access denied>

-- system architecture: 32-bit
-- xf86-video-intel:
-- xserver: 1.6.2
-- mesa: 7.4.4
-- libdrm: 2.4.11+git+20090630+de1ed01-1
-- kernel: 2.6.31rc2 and 2.6.30
-- Linux distribution: Debian unstable
-- Machine or mobo model: Dell Vostro 200 slim, ..CN736047BO0434.
-- Display connector: VGA

Reproducing steps:

Start the X server (e.g. via gdm). 100% reproducible

Additional info:

Doesn't happen downgrading the driver to
Comment 1 Emilio Pozuelo Monfort 2009-07-13 18:59:28 UTC
Created attachment 27660 [details]
Comment 2 Emilio Pozuelo Monfort 2009-07-13 19:00:02 UTC
Created attachment 27661 [details]
Comment 3 Emilio Pozuelo Monfort 2009-07-13 19:02:38 UTC
Created attachment 27662 [details]
Comment 4 Emilio Pozuelo Monfort 2009-07-13 19:03:05 UTC
Created attachment 27663 [details]
Comment 5 Gordon Jin 2009-07-13 20:41:12 UTC
I can't reproduce it. Is it possible for you to use git-bisect to find which git commit between .901 and .902 breaks?
Comment 6 Colin Guthrie 2009-07-14 03:17:24 UTC
Created attachment 27675 [details]
Potential fix to address overzealous pruning during the removal of NoAccel


Not sure if it's the same issue but I found an initialisation bug too and bisected. The patch that worked for me is attached.

I've also submitted this to the intel-gfx mailinglist.
Comment 7 Emilio Pozuelo Monfort 2009-07-14 07:10:55 UTC
Conlin's patch fixes the crash for me too.
Comment 8 Gordon Jin 2009-07-14 18:58:08 UTC
keithp, I assume this bug blocks our rc3 build and 2.8.0 release. Let me know if you don't thinks so.
Comment 9 Keith Packard 2009-07-14 19:39:20 UTC
Does this patch fix the problem?

diff --git a/src/i830_memory.c b/src/i830_memory.c
index f2f3966..cc9d376 100644
--- a/src/i830_memory.c
+++ b/src/i830_memory.c
@@ -1581,6 +1581,9 @@ i830_bind_all_memory(ScrnInfoPtr pScrn)
+    if (pI830->front_buffer)
+	pScrn->fbOffset = pI830->front_buffer->offset;
     return TRUE;
Comment 10 Colin Guthrie 2009-07-14 23:58:05 UTC
Hi Keith,

I just tried your patch in place of mine just now and everything seems to work fine (945GM + UMS)

Thanks for that.

(I wont bother replying on the mailing list).
Comment 11 Keith Packard 2009-07-15 09:53:16 UTC
Thanks, I've pushed that fix.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.