Bug 22570 - Account request for xf86-video-intel
Summary: Account request for xf86-video-intel
Alias: None
Product: freedesktop.org
Classification: Unclassified
Component: New Accounts (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: fd.o Admin Massive
QA Contact:
Keywords: NEEDINFO
Depends on:
Reported: 2009-06-30 22:52 UTC by ykzhao
Modified: 2010-03-31 00:22 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:

the ssh RSA public key (408 bytes, text/plain)
2009-06-30 22:59 UTC, ykzhao
the gpg public key (967 bytes, text/plain)
2009-06-30 22:59 UTC, ykzhao
the gpg public key containing subkey (2.07 KB, text/plain)
2009-07-02 17:56 UTC, ykzhao

Description ykzhao 2009-06-30 22:52:31 UTC
real name: Yakui Zhao
email address: yakui.zhao@intel.com
account name: yakui_zhao
Comment 1 ykzhao 2009-06-30 22:59:21 UTC
Created attachment 27282 [details]
the ssh RSA public key
Comment 2 ykzhao 2009-06-30 22:59:52 UTC
Created attachment 27283 [details]
the gpg public key
Comment 3 Carl Worth 2009-07-02 13:30:45 UTC

Thanks for requesting this account. I tried creating the account today, but I found that the gpg key you submitted is invalid. I'm not sure exactly how you created it or what you need to do differently, but I can show a way to test the key.

This is what I see for your key:

$ gpg --list-keys yakui.zhao
pub   2048R/1CC24B58 2009-07-01
uid                  Yakui Zhao (ykzhao) <yakui.zhao@intel.com>

Compare that to the output for my key (where I've only edited out some irrelevant uid fields):

$ gpg --list-keys cworth
pub   1024D/AF2A4968 2001-12-11
uid                  Carl Worth <cworth@cworth.org>
sub   1024g/8E3CD8D6 2001-12-11

The line showing "sub" is missing from your key. So the key as sent is incomplete and I can't yet create an account. If you can generate a new key and send it then I will create the account.


Comment 4 ykzhao 2009-07-02 17:56:11 UTC
Created attachment 27351 [details]
the gpg public key containing subkey
Comment 5 ykzhao 2009-07-02 17:58:44 UTC
Hi, Carl
    Thanks for your help. 
    There is no subkey in the file of comment #2.
    Will you please check whether the gpg key in comment #4 is valid?

Thanks again.
Comment 6 Tollef Fog Heen 2010-02-28 00:09:38 UTC

I'm sorry, but your key is still not correct:

$ gpg --edit-key 1CC24B58
gpg (GnuPG) 1.4.9; Copyright (C) 2008 Free Software Foundation, Inc.
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

pub  2048R/1CC24B58  created: 2009-07-01  expires: never       usage: SC  
                     trust: unknown       validity: unknown
sub  2048R/FD32DAFA  created: 2009-07-03  expires: never       usage: S   
[ unknown] (1). Yakui Zhao (ykzhao) <yakui.zhao@intel.com>

As you can see, you have two signing subkeys.  We need an encryption subkey, so if you could please add an encryption subkey to your key (and attach the updated key here), I'll get your account created.

Please remove the NEEDINFO keyword when you have provided the requested information.

Tollef Fog Heen
Comment 7 Tollef Fog Heen 2010-03-31 00:22:09 UTC
No response from submitter, closing as invalid.

Please reopen the bug if you can provide the requested information.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.