Bug 22072 - Compiz no longer loads with
Summary: Compiz no longer loads with
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.4 (2008.09)
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Eric Anholt
QA Contact: Xorg Project Team
Keywords: regression
Depends on:
Reported: 2009-06-03 14:54 UTC by Juan Sebastián Marulanda Pulido
Modified: 2011-01-25 08:04 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:

Xorg log attached as requested. (128.76 KB, text/plain)
2009-06-03 15:35 UTC, Juan Sebastián Marulanda Pulido
no flags Details

Description Juan Sebastián Marulanda Pulido 2009-06-03 14:54:28 UTC
Running Ubuntu 9.10 "Karmic Koala"

After updating the Intel driver to version, I restarted my system, and after login, Compiz wasn't activated. When I try to activate compiz via fusion-icon, the screen goes blank and I have to kill compiz in order to make my system usable.

If I run compiz --replace in a console, I get the following output:

Checking for Xgl: not present.
xset q doesn't reveal the location of the log file. Using fallback /var/log/Xorg.0.log
Detected PCI ID for VGA:
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Checking screen 1Comparing resolution (1440x900) to maximum 3D texture size (2048): Passed.
Checking for Software Rasterizer: present.
Software rasterizer detected, abortingaborting and using fallback: /usr/bin/metacity

Another issue after updating the driver is that playing video closes my X session.
Comment 1 Gordon Jin 2009-06-03 15:15:28 UTC
"playing video closes my X session" issue even happens without compiz, right? It will be good to track that as a separate bug, so let's focus on compiz issue here.

What's the kernel version?
Please attach Xorg.0.log according to http://intellinuxgraphics.org/how_to_report_bug.html.

Is there an older version driver getting your compiz working?
Comment 2 Juan Sebastián Marulanda Pulido 2009-06-03 15:35:16 UTC
Created attachment 26410 [details]
Xorg log attached as requested.

Kernel version: 2.6.30-7-server

Compiz worked as of driver version 2.7.1
Comment 3 Juan Sebastián Marulanda Pulido 2009-06-03 15:45:41 UTC
Other system information:

Chipset: Intel G35
System architecture: i686
X server version:
Mesa version: 7.4.1
Motherboard model: Intel DG35EC
Display connector: VGA
Comment 4 Julien Cristau 2009-06-04 00:57:50 UTC
Looks like NOTABUG to me:
(EE) intel(0): [drm] Failed to detect GEM.  Kernel 2.6.28 required.

Comment 5 Eric Anholt 2009-07-01 14:12:04 UTC
Your distribution kernel appears to have GEM disabled for some reason.  If it's PAE, there are fixes upstream to enable GEM on PAE now.  But 2.7.99.* does not provide 3D support without GEM.
Comment 6 Juan Sebastián Marulanda Pulido 2011-01-25 08:04:38 UTC
Fixed in newer versions of the Intel driver and the Linux kernel.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.