Bug 22043 - [GM965 KMS] x crash with quake 3 demo
Summary: [GM965 KMS] x crash with quake 3 demo
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: high normal
Assignee: Eric Anholt
QA Contact:
Keywords: regression
Depends on:
Reported: 2009-06-02 15:18 UTC by Hanno Böck
Modified: 2016-11-03 08:12 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:

photo of screen corruption (6.31 KB, image/jpeg)
2009-06-02 15:18 UTC, Hanno Böck
no flags Details
xorg log (16.53 KB, text/plain)
2009-06-02 15:19 UTC, Hanno Böck
no flags Details
Xorg.0.log (27.15 KB, text/plain)
2009-07-01 20:23 UTC, Yifei Chen
no flags Details
xorg log (20.93 KB, text/plain)
2010-07-26 00:43 UTC, fangxun
no flags Details

Description Hanno Böck 2009-06-02 15:18:25 UTC
Running q3demo I get rendering only on a quarter of the screen (will attach photo). When ending the game, X crashes.

I'm using latest git of libdrm, mesa and xf86-video-intel. Rest is pretty much latest releases. Doesn't matter if I use kernel 2.6.29 or 2.6.30-rc. Also tried 2.6.30-rc7-git5 with latest drm-intel merge.

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)

(Lenovo T61 notebook)

0: /usr/bin/X(xorg_backtrace+0x26) [0x4e9d56]
1: /usr/bin/X(xf86SigHandler+0x39) [0x474469]
2: /lib/libc.so.6 [0x7f0dcd2566a0]
3: /usr/bin/X(IgnoreClient+0x4) [0x4e9f14]
4: /usr/lib64/xorg/modules/extensions//libglx.so(glxSuspendClients+0x53) [0x7f0dcc93ff03]
5: /usr/lib64/xorg/modules/extensions//libglx.so [0x7f0dcc949f28]
6: /usr/bin/X(AbortDDX+0x89) [0x4668a9]
7: /usr/bin/X(AbortServer+0x1d) [0x4f31cd]
8: /usr/bin/X(LogVMessageVerb+0) [0x4f3890]
9: /usr/bin/X(xf86SigHandler+0x49) [0x474479]
10: /lib/libc.so.6 [0x7f0dcd2566a0]
11: /usr/lib64/dri/i965_dri.so(intelDestroyContext+0xdd) [0x7f0dcb547c5d]
12: /usr/lib64/dri/i965_dri.so [0x7f0dcb53d960]
13: /usr/lib64/xorg/modules/extensions//libglx.so [0x7f0dcc94a189]
14: /usr/lib64/xorg/modules/extensions//libglx.so(__glXFreeContext+0x6c) [0x7f0dcc93fd3c]
15: /usr/lib64/xorg/modules/extensions//libglx.so [0x7f0dcc9400ca]
16: /usr/bin/X(CallCallbacks+0x44) [0x44b654]
17: /usr/bin/X(CloseDownClient+0x58) [0x441f48]
18: /usr/bin/X(Dispatch+0x1f0) [0x447750]
19: /usr/bin/X(main+0x3ad) [0x42d8ad]
20: /lib/libc.so.6(__libc_start_main+0xe6) [0x7f0dcd2429f6]
21: /usr/bin/X [0x42cd49]
Comment 1 Hanno Böck 2009-06-02 15:18:46 UTC
Created attachment 26364 [details]
photo of screen corruption
Comment 2 Hanno Böck 2009-06-02 15:19:08 UTC
Created attachment 26365 [details]
xorg log
Comment 3 Gordon Jin 2009-06-02 17:12:27 UTC
Yifei, can you try the master (unstable) code on GM965?
Comment 4 Hanno Böck 2009-06-15 02:52:00 UTC
Just tried without KMS, the screen corruption is gone, but the crash stays. So at least partly a regression to pre-KMS.
Comment 5 Hanno Böck 2009-06-23 07:37:49 UTC
With latest git versions, screen just turns black. I can switch to console and kill x.
(and, I'm a bit disappointed with the pure non-reaction to my report here...)
Comment 6 Yifei Chen 2009-07-01 20:23:01 UTC
sorry, we have some problems with the installation of quake3-demo thus tested it untill now. As Hanno said, when run quake3-demo, we just get black screen, but we cannot switch to console, and kill X does not bring the console back. It's kinda wired, because quake3 works just fine. Our test machine is T61 too.
Comment 7 Yifei Chen 2009-07-01 20:23:44 UTC
Created attachment 27310 [details]
Comment 8 Gordon Jin 2009-09-06 19:45:07 UTC
Does this still exist with the latest code?
Comment 9 fangxun 2009-09-06 20:40:21 UTC
This issue still exists with the latest code. Sometimes when starting the game, screen turns black and X crashes. Sometimes when ending the game, screen are black and X crashes. When X crashes, we cannot switch to console. Killing X will bring the console back. We also find openarena and ut2004 has Similar problem. When starting or ending openarena or ut2004, screen turns black but X does not crash. If we press "ctrl+alt+enter", screen will back to normal. 
Comment 10 Gordon Jin 2009-09-14 20:30:12 UTC
unblocking Q3 release, but still a high priority bug.
Comment 11 Chris Wilson 2010-07-24 03:51:16 UTC
Can recheck this bug? Does X still crash? Is the backtrace still from within i965_dri.so? Does the modesetting issue still occur?
Comment 12 fangxun 2010-07-26 00:43:54 UTC
Created attachment 37395 [details]
xorg log

I recheck the bug on gm965. X don't crash now. Game works well execept Modesetting issue. Changing the video mode on system setup will cause game exit. The problem also happens on calpella. It doesn't happen on piketon.
Comment 13 Hanno Böck 2010-07-26 06:13:42 UTC
I get no corruption and no black screen any more. But I get just 58 fps, which is I think rather slow (I think I had more than 100 on my old r200 laptop), so there probably is something wrong with my 3d acceleration.
Comment 14 Gordon Jin 2010-07-26 17:46:55 UTC
Let's close this one as the original reported issue has gone.

Please file new bugs for the rest issues.
Comment 15 Jari Tahvanainen 2016-11-03 08:12:07 UTC
Closing resolved+fixed, no activity on more than 6 years.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.