Bug 21919 - [GM45] GPU hang with googleearth on specific location
Summary: [GM45] GPU hang with googleearth on specific location
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: Other All
: medium critical
Assignee: Eric Anholt
QA Contact: Xorg Project Team
Keywords: NEEDINFO
Depends on:
Reported: 2009-05-24 21:38 UTC by jeromepoulin@gmail.com
Modified: 2009-07-26 23:21 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

dmesg-display-frozen-in-google-earth.log (83.48 KB, text/plain)
2009-05-24 21:38 UTC, jeromepoulin@gmail.com
no flags Details
xorg.conf (2.47 KB, text/plain)
2009-05-25 04:55 UTC, jeromepoulin@gmail.com
no flags Details
Xorg.0.log (14.82 KB, text/plain)
2009-05-25 05:04 UTC, jeromepoulin@gmail.com
no flags Details
intel_gpu_dump.txt (149.23 KB, application/x-bzip)
2009-05-27 09:23 UTC, jeromepoulin@gmail.com
no flags Details

Description jeromepoulin@gmail.com 2009-05-24 21:38:20 UTC
Created attachment 26189 [details]

While looking on Google Earth at some very specific Island, the system lock ups, however the mouse still moves... I can access it from the network, I get a backtrace of the locked task which tells i915 is the culpit.
Killing X freezes the system completely, and even funnier, I get stuck on a blank console (I guess the vt where X started) with only an underscore _not_ flashing in the corner and a cursor, yes, my X cursor frozen where it was when X is killed. At this point, even SysRq+B does not work.
For Google Earth, it does this even with Atmosphere, Water and all the effects turned off, and I can repeat the lock up by looking at Tristan da Cunha, an island near south africa in the middle of the ocean. I don't know if it's specific to this island of because I'm in the middle of the sea, but I can repeat it.
Comment 1 Gordon Jin 2009-05-24 22:47:34 UTC
What's the driver version? Please provide the detailed info including Xorg.0.log referring to http://www.intellinuxgraphics.org/how_to_report_bug.html
Comment 2 jeromepoulin@gmail.com 2009-05-25 04:55:19 UTC
Sorry did this in a hurry before going to sleep.
Chipset: GM45
Architecture: i686.
Kernel: 2.6.30-r7
xf86-video-intel: 2.7.1
libdrm: 2.4.11
Xorg-server: (second release from Gentoo)
Machine is a laptop, HP 6530b it happened on the LVDS panel.

Xorg.log will follow, I'll reproduce the bug in a moment and reboot.
Comment 3 jeromepoulin@gmail.com 2009-05-25 04:55:43 UTC
Created attachment 26200 [details]
Comment 4 jeromepoulin@gmail.com 2009-05-25 05:04:46 UTC
Created attachment 26201 [details]

While crashed, however I don't think there is more information about the crash.
Comment 5 jeromepoulin@gmail.com 2009-05-25 05:13:20 UTC
I just want to add that I can effectively repeat the problem by looking at the exact same spot, angle, panning and zoom. Here are picture I took of the frozen X with Google Earth showing the spot plus another picture of the killed X and cursor on the frozen computer.

The place name for Google Earth to find it is:
Tristan da Cunha, St Helena

Comment 6 Gordon Jin 2009-05-26 22:41:52 UTC
Could you provide gpu dump according to http://intellinuxgraphics.org/intel-gpu-dump.html?
Comment 7 jeromepoulin@gmail.com 2009-05-27 09:23:56 UTC
Created attachment 26253 [details]

2333kb uncompressed
Taken at the same place, I tried intel_gpu_top, that's nice too, shows ring idle: 100% ring space: 0%
Pressing standby enters the computer standby and resuming crashes X, then restarting X I only see a cursor even if all my program are started.
Comment 8 jeromepoulin@gmail.com 2009-06-17 11:52:36 UTC
I just want to confirm that I tried exactly 2 hours ago, the bug still exists on 2.6.30, same thing same place.
Comment 9 Eric Anholt 2009-06-22 18:48:01 UTC
The dump doesn't show anything in particular.  What version of Mesa are you using?  Does it still occur on Mesa master?

I tried with Mesa master on my system, and zooming to that location worked, as well as moving the camera around that location and re-zooming to it.
Comment 10 Gordon Jin 2009-07-26 23:21:36 UTC
please reopen if you can reproduce this on mesa master

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.