Bug 21647 - [945GME, UMS] X fails to redraw after vtswitch, requiring X restart
Summary: [945GME, UMS] X fails to redraw after vtswitch, requiring X restart
Status: RESOLVED DUPLICATE of bug 19578
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.4 (2008.09)
Hardware: x86 (IA32) Linux (All)
: medium critical
Assignee: Jesse Barnes
QA Contact: Xorg Project Team
Keywords: NEEDINFO
Depends on:
Reported: 2009-05-09 09:01 UTC by JR
Modified: 2009-06-23 19:20 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:

Xorg.0.log after having vtswitched out of X, and then tried to switch back in (91.30 KB, text/plain)
2009-05-09 09:01 UTC, JR
no flags Details
New Xorg.0.log, driver git20090617.b5cd2130 (86.90 KB, text/plain)
2009-06-18 06:58 UTC, JR
no flags Details

Description JR 2009-05-09 09:01:16 UTC
Created attachment 25672 [details]
Xorg.0.log after having vtswitched out of X, and then tried to switch back in

I'm running Kubuntu 9.04 on my Advent 4211 netbook, with intel drivers from the xorg-edgers ppa.

Problem: Switching to a terminal works, but when I switch back the mode changes (screen blanks), but I'm met with only a black screen. I can still switch back to the terminal - it draws properly - and from there I have to manually restart kdm. Basically, X can start up but can't recover from a vtswitch. This is without using KMS.

* Distribution: Kubuntu 9.04 x86
* Computer make and model: Advent 4211 (rebranded MSI Wind)
* Monitor display connection: LVDS (I think; internal LCD screen)
* "uname -r": 2.6.30-020630rc4-generic (i686, package from http://kernel.ubuntu.com/~kernel-ppa/mainline)
* "lspci -v | grep VGA": 00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)
* xf86-video-intel: git upto commit a8a771a853478e5f45f71d0eff3c4d55bf24d0ad at 20090505 (xorg-edgers, 2:
* libdrm2/libdrm-intel1/... (drm-snapshot): git upto commit 68103b2758029b3c1fbfcf995baa758bfd2676de at 20090502 (xorg-edgers, 2.4.9+git20090502.r1.68103b27-0ubuntu0sarvatt)
* xserver-xorg: Ubuntu repository package, 7.4~5ubuntu18

This bug crept in somewhat recently, I need to read up on how to try individual git commits to find out exactly when.

Attaching a copy of Xorg.0.log after having tried to vtswitch out and back in. I'm not sure what to make of the dumpregs spam, but hopefully it makes more sense to someone.
Comment 1 JR 2009-06-18 06:50:23 UTC
Bug persists as of driver git20090617.b5cd2130 (xorg-edgers).

Some more findings, though.

* If I use KMS, X can redraw properly as it doesn't need to modeswitch. This seems to be the plausible workaround.
* If I "switch user" and login as another user, X properly handles *starting* a new session. However, I can't *switch* to an already existing one. Essentially, the only thing I can do is start new sessions, but this leaves existing ones lost to me (since I can't switch back to them). vt switching still breaks everything instantly, except for other vts.

As a small note, the same system experiences bug#20867 when using KMS.

Adjusting severity, since I imagine "loss of X control" would equal in severity to a crash or a hang.
Comment 2 JR 2009-06-18 06:58:45 UTC
Created attachment 26921 [details]
New Xorg.0.log, driver git20090617.b5cd2130

Xorg.0.log running the above-mentioned driver (xorg-edgers git20090617.b5cd2130).

Again, this is after having vtswitched out, then tried to switch back in. (Then out again to make a copy of the log itself.)

The kernel running was the Ubuntu jaunty repository 2.6.28-13-generic one, but if of relevance, the behavior is the same when running 2.6.30.
Comment 3 JR 2009-06-22 12:04:58 UTC
X failing to redraw *upon logout* is caused by bug#20867, so irrelevant to this one. (Trying to change the summary to reflect this.)

Issue still persists as of git20090619.534e73ad.
Comment 4 Jesse Barnes 2009-06-23 17:03:06 UTC
So VT switch is just broken on your machine then, right (leaving aside the server regen issue)?  You boot up, things are fine, then you VT switch to a text console and back to X and it hangs?  It would be interesting to know where, can you get a backtrace from X with an ssh session or something (just gdb -p `pidof X` and do a 'bt').
Comment 5 Gordon Jin 2009-06-23 19:20:29 UTC
looks like dup with #19578

*** This bug has been marked as a duplicate of bug 19578 ***

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.