Bug 21328 - [855GM] GL rendering incorrect w/DRI2
Summary: [855GM] GL rendering incorrect w/DRI2
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.4 (2008.09)
Hardware: x86 (IA32) Linux (All)
: medium critical
Assignee: Jesse Barnes
QA Contact: Xorg Project Team
URL: http://bbs.archlinux.org/viewtopic.ph...
Keywords: NEEDINFO
Depends on:
Reported: 2009-04-21 17:03 UTC by Thomas
Modified: 2009-06-22 18:51 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

Xorg logs - only the part when I experience the bug (21.78 KB, text/plain)
2009-04-21 17:03 UTC, Thomas
no flags Details
8xx tiling fix (4.31 KB, patch)
2009-04-24 15:01 UTC, Jesse Barnes
no flags Details | Splinter Review
xorg logs with UXA enabled (19.29 KB, text/plain)
2009-05-13 13:56 UTC, Thomas
no flags Details
just in case, my xorg.conf (11.82 KB, text/plain)
2009-05-13 13:57 UTC, Thomas
no flags Details
3D display : glxgears (362.32 KB, image/png)
2009-05-13 14:01 UTC, Thomas
no flags Details
display bug with the flash plugin (306.65 KB, image/png)
2009-05-13 14:03 UTC, Thomas
no flags Details

Description Thomas 2009-04-21 17:03:03 UTC
Created attachment 25016 [details]
Xorg logs - only the part when I experience the bug

Hi. I run archlinux on a IBM Thinkpad X40

I recently did the following update :
[2009-04-15 19:38] upgraded xf86-video-intel (2.4.3-1 -> 2.6.3-3)

Now my display is scrambled, except the mouse pointer. Appart from that, everything works : I can blindly use the computer and quit X properly.

I tried to get a screenshot, but scrot and import gave me a picture of how my desktop should look like. Basically, it looks like the lines are not properly aligned :


turns to something like :


I tried to start X with and without my xorg.conf file. Same result.

Thanks taking care of this soft.
Comment 1 Jesse Barnes 2009-04-24 15:01:55 UTC
Created attachment 25122 [details] [review]
8xx tiling fix

This patch is already upstream, but I don't think it made it into 2.6.29.  Can you confirm that either a more recent kernel or this patch applied to your current kernel work ok?  Things look good on my 855 with the 2.6.3 driver and 2.6.30-rc2 kernel, so I'm hopeful that this will work for you.
Comment 2 Jesse Barnes 2009-05-04 09:59:06 UTC
Thomas, any update here?  My 855 is working fine with the fix attached to this bug and with current upstream bits (which include this fix).
Comment 3 Thomas 2009-05-04 13:23:14 UTC
Sorry I still have to find how to add patches to a custom kernel on archlinux - I'm not very experimented with such things, I must admit. I'll keep you informed.
Comment 4 Jesse Barnes 2009-05-04 13:51:45 UTC
Another option is to just upgrade to 2.6.30-rc4 or so; that has the fix.
Comment 5 Thomas 2009-05-05 09:17:06 UTC
I patched and ran my kernel. It didn't solve the problem. I'm double checking everything now, just in case.
Comment 6 Jesse Barnes 2009-05-11 11:27:23 UTC
Any update here Thomas?  Still see this with the latest bits?
Comment 7 Jesse Barnes 2009-05-11 11:41:07 UTC
Also, can you reproduce this with UXA?  Please attach your latest log if you're still seeing the failure.
Comment 8 Thomas 2009-05-13 13:55:50 UTC
Hi there.

Running with UXA solved the problem, but raised another one.

I'm running the patched kernel (sorry I couldn't try the 2.6.30-rc)

$ uname -a
Linux aleph 2.6.29-custom #1 SMP PREEMPT Wed May 13 21:56:59 CEST 2009 i686 Intel(R) Pentium(R) M processor 1200MHz GenuineIntel GNU/Linux

I activated UXA by adding 
> Option  "AccelMethod"   "UXA"
to xorg.conf

No mistake, the 2D display feels really faster than with the legacy driver.

But now, openGL displays are completely broken. Obviously the problem comes from somewhere else because I can do a screenshot of the bug.
Comment 9 Thomas 2009-05-13 13:56:41 UTC
Created attachment 25834 [details]
xorg logs with UXA enabled
Comment 10 Thomas 2009-05-13 13:57:32 UTC
Created attachment 25835 [details]
just in case, my xorg.conf
Comment 11 Thomas 2009-05-13 14:01:37 UTC
Created attachment 25836 [details]
3D display : glxgears
Comment 12 Thomas 2009-05-13 14:03:22 UTC
Created attachment 25837 [details]
display bug with the flash plugin
Comment 13 Jesse Barnes 2009-05-13 14:09:52 UTC
Your config looks good, though really all those mode lines shouldn't be necessary.

Can you try the latest libdrm from git and see if you can build Eric's drm-intel-next branch from git://git.kernel.org/pub/scm/linux/kernel/git/anholt/drm-intel.git?

It definitely looks like GL rendering is busted, though maybe due to something other than a tiling bug (maybe the stride is wrong?).
Comment 14 Jesse Barnes 2009-06-22 18:51:23 UTC
Pretty sure 855GM is solid with the latest kernel bits.  Please open a new bug if you run into trouble.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.