Bug 21183 - [945 MacMini] Crashes at server start
Summary: [945 MacMini] Crashes at server start
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Gordon Jin
QA Contact: Xorg Project Team
Keywords: NEEDINFO
Depends on:
Reported: 2009-04-14 13:35 UTC by Tino Keitel
Modified: 2009-07-18 20:09 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:

xorg config (252 bytes, text/plain)
2009-04-14 13:35 UTC, Tino Keitel
no flags Details
Xorg log (19.75 KB, text/plain)
2009-04-15 01:22 UTC, Tino Keitel
no flags Details
kernel log (53.75 KB, text/plain)
2009-04-15 01:22 UTC, Tino Keitel
no flags Details

Description Tino Keitel 2009-04-14 13:35:26 UTC
Created attachment 24799 [details]
xorg config

I tested driver version with Xserver 1.6.0 from Debian unstable, libdrm 2.4.9, Mesa 7.4 and kernel 2.6.30-rc1-00457-gb21597d.

When the Xserver starts, the computer crashes. I tried to start the server via SSH and watched the kernel log using inotail -f to gather some information, without luck. No messages in stdout/stderr or in the kernel log.

The computer is a Mac mini Core2 Duo with i945 graphics, 2 GB RAM on 2 modules. This is a 64 bit system.
Comment 1 Tino Keitel 2009-04-14 13:37:43 UTC
Forgot to mention: the kernel has KMS enabled.

I tested with a kernel without KMS enabled, and it worked.
Comment 2 Gordon Jin 2009-04-14 18:34:47 UTC
Please attach Xorg log, according to http://intellinuxgraphics.org/how_to_report_bug.html.
Comment 3 Tino Keitel 2009-04-15 01:22:31 UTC
Created attachment 24814 [details]
Xorg log
Comment 4 Tino Keitel 2009-04-15 01:22:46 UTC
Created attachment 24815 [details]
kernel log
Comment 5 Carl Worth 2009-04-15 11:45:46 UTC
There have been some problems with PAT code in recent kernels that cause recent versions of our driver to crash. I know that 2.6.29 was definitely affected, but I was hoping that the 2.6.30 rc series would have the fixes.

I do see from your kernel log that PAT is enabled:

2009-04-15_08:14:02.83379 kern.info: x86 PAT enabled: cpu 0, old 0x7040600070406, new 0x7010600070106

Could you try adding "nopat" to your kernel boot command-line, (such as in grub's menu.lst or else by manually editing the kernel command-line at the grub interface).

And please let us know if that fixes this crash for you.

Comment 6 Tino Keitel 2009-04-16 01:36:31 UTC
I tried 2.6.30-rc2-00076-g3ee8da8 with CONFIG_X86_PAT disabled, the computer still crashes when I start the X server.
Comment 7 Michal Suchanek 2009-05-04 07:00:49 UTC
For me X locks up graphics and input but does not crash the machine.

I do not see anything interesting in the kernel log except complaints about X 1.4 doing the wrong thing when the kernel is in GEM mode.

For X logssee http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=526317
Comment 8 Michal Suchanek 2009-05-04 07:30:15 UTC
note that I boot the machine using EFI since the BIOS emulation fails to locate my system after some experiments with GRUB.

None of the kernel framebuffers work well, the best one is efifb which displays correct geometry but wrong colours (probably wrong pixel format).

Using vesafb or intelfb on some kernel like 2.6.26 resulted in distorted pictute.
Comment 9 Randall Leeds 2009-05-08 00:45:24 UTC
I experience a similar crash with my GM915
64bit system running Ubuntu 9.04 and latest git (yesterday)

Whenever X loads the system becomes unresponsive within a few seconds. The mouse freezes, the screen freezes, but the system appears not be not frozen completely (hard drive access for background services). Usually I get to the gdm login screen and can produce the crash by logging in or switching vtt a few times.

However! If I load the i915 module earlier in the boot process (before X starts) the problem goes away! I encourage everyone commenting to try this and see if it changes things.
Comment 10 Randall Leeds 2009-05-08 00:46:40 UTC
Sorry, my last comment should say GM965 (supported by the i915 kernel module... too many 9xx numbers...)
Comment 11 Jesse Barnes 2009-06-09 18:19:12 UTC
tino, your original report said that KMS was enabled, but it looks like your driver failed to notice that based on your X log.  Can you update your 2D driver and try again?

As for loading i915 first, yes it's generally important.  Recent 2D driver bits (from git) will try to load the i915 driver, but it's best to just do it at boot time.
Comment 12 Gordon Jin 2009-07-18 20:09:54 UTC
Tino, I'm closing this one. As Jesse said, the log shows KMS is not enabled.

Michal, you may encounter another problem. Please try the new xf86-video-intel driver (>=2.7) and kernel (2.6.30). Don't use intelfb. 

If you still have problem, please file a separate bug according to http://intellinuxgraphics.org/how_to_report_bug.html.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.