Bug 20864 - Laptop partially frozen (screen and keys) when activating KDE4 effects
Summary: Laptop partially frozen (screen and keys) when activating KDE4 effects
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: (7.0 RC2)
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Gordon Jin
QA Contact: Xorg Project Team
Keywords: NEEDINFO
Depends on:
Reported: 2009-03-25 10:22 UTC by V P
Modified: 2009-05-19 20:12 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:

xorg.0.log (21.64 KB, text/plain)
2009-03-27 04:21 UTC, V P
no flags Details
dmesg (39.33 KB, text/plain)
2009-03-27 04:24 UTC, V P
no flags Details
xorg.conf (2.03 KB, text/plain)
2009-03-27 04:25 UTC, V P
no flags Details
Xorg.0.log (21.11 KB, text/plain)
2009-04-04 16:01 UTC, V P
no flags Details
xorg.conf (2.00 KB, text/plain)
2009-04-04 16:03 UTC, V P
no flags Details
Xorg.0.log (20.38 KB, text/plain)
2009-04-15 03:04 UTC, V P
no flags Details
dmesg (39.28 KB, application/octet-stream)
2009-04-15 03:04 UTC, V P
no flags Details

Description V P 2009-03-25 10:22:04 UTC
I'm running Mandriva cooker and it's been spotted by two users with two different Intel cards : if you activate KDE4 desktop effects for too long, the laptop freezes.

You can still use the network to log into it and the linux kernel still seems to run fine, as well as your mouse cursor which is moving. But you can click anywhere, the screen image is fixed and you can't switch to another VT.

If you try to kill X (through a network connection), you end up with a "weird" screen with blue lines.

The only way to get out of this state is by using the Magic Linux SysReq keys combinations (for instance, SysReq + R).
Comment 1 Gordon Jin 2009-03-25 19:22:04 UTC
Please refer to http://intellinuxgraphics.org/how_to_report_bug.html to provide more info, like Xorg.0.log and dmesg.
Please specify the driver version and kernel version, since I don't have a concrete concept for what version used by Mandriva.
And which two Intel cards?
Comment 2 V P 2009-03-26 04:13:14 UTC
Ok, sorry for not having provided enough information at first time.

This problem affects both i915 and i965 chipsets. Without further investigation, I'm unable to select the right product/component.

For the other kind of information (my hardware) :

- Chipsets :
Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller

- Architecture :

- Versions :
X.Org X Server 1.6.0 (x11-server-xorg-1.6.0-8mdv2009.1)
Intel module 2.6.99 (x11-driver-video-intel-
libdrm 2.4.5 (libdrm_intel1-2.4.5-4mdv2009.1)
Mesa 7.3

- Kernel :

- Linux distro :
Mandriva Cooker

- Machine :
Laptop HP Compaq nc6320

- To reproduce, activate all KDE4 desktop effects, then work as usual. The system should get slower and slower and at some point (within a few minutes) the system will freeze.

This problem as also been reported two other times, one of these users has a Mobile GM965/GL960 Integrated
Comment 3 Gordon Jin 2009-03-26 18:24:25 UTC
Does Mandriva use EXA or UXA for intel driver? If UXA, could you check if it's caused by memory leak, as bug#20704 and bug#20766?

Xorg.0.log and dmesg info are still required.
Comment 4 V P 2009-03-27 04:21:19 UTC
Created attachment 24313 [details]
Comment 5 V P 2009-03-27 04:24:36 UTC
Created attachment 24316 [details]
Comment 6 V P 2009-03-27 04:25:53 UTC
Created attachment 24317 [details]
Comment 7 V P 2009-03-27 04:27:22 UTC
Not 100% sure it's Mandriva default, but in my xorg.conf, I've forced EXA, so this doesn't seem to be related to the bug reports you mention.
Comment 8 Jesse Barnes 2009-03-31 18:08:40 UTC
Your log indicates that DRI is getting disabled at startup.  That will cause all sorts of bad things to happen.  Can you figure out why that's happening?  Are you missing the i915 driver from your kernel config?
Comment 9 Jesse Barnes 2009-03-31 18:11:02 UTC
Also, with 2.6+ drivers you should be using UXA if possible...
Comment 10 V P 2009-04-04 16:01:23 UTC
Created attachment 24569 [details]

After an update of my system, DRI seems to load fine now (see new attached xorg.0.log) but after a few seconds of KDE4 effects, my laptop still freezes.

I have not tried UXA yet, though.
Comment 11 V P 2009-04-04 16:03:06 UTC
Created attachment 24570 [details]

My config file has changed a bit too (I do not force EXA anymore, but it seems EXA is chosen by default anyway).
Comment 12 Gordon Jin 2009-04-15 01:39:49 UTC
(In reply to comment #10)
> Created an attachment (id=24569) [details]
> Xorg.0.log
> After an update of my system, DRI seems to load fine now (see new attached
> xorg.0.log) but after a few seconds of KDE4 effects, my laptop still freezes.

The log shows DRI still fail:
(EE) [drm] drmOpen failed.
(EE) intel(0): [dri] DRIScreenInit failed. Disabling DRI.
Comment 13 V P 2009-04-15 03:03:13 UTC
Sorry, I've probably attached the wrong ones. I now attach the latest ones. I've updated my system (kernel and kde 4, mostly) and the problem appears less frequently, but is still here (now happens after 1/2 hour of play with KDE4 effects).

I've also tried UXA without KDE4 effect and I get too many glitches for it to be usable. Most of the time, the screen doesn't refresh at all and appears as a static image (although everything works correctly and the cursor moves). I have to hit Ctrl+Alt+F1, then Ctrl+Alt+F7 to have something back to normal (happens every 2 mins, approx.)

Comment 14 V P 2009-04-15 03:04:04 UTC
Created attachment 24817 [details]
Comment 15 V P 2009-04-15 03:04:30 UTC
Created attachment 24818 [details]
Comment 16 Gordon Jin 2009-05-19 00:20:46 UTC
We won't continue developing on EXA -- EXA has been removed in the latest driver (2.8).

We are only interested in UXA. So please file separate bugs for the problems you meet with UXA. There are various fixes for UXA recently, so if you could try the newer code, the quality is likely to improve much.

I'm closing this one. Thanks.
Comment 17 Colin Guthrie 2009-05-19 04:31:46 UTC
It's a great shame this wont be looked at further as there are a number of users affected by this on the stable distro we (Mandriva) ship and need to support. While I totally appreciate the focus on UXA, the recent maintenance release of 2.7.1 which does still support EXA has greatly reduced the occurrence of this problem for us. That said it *does* still happen and it would be very beneficial to at least be able to look at the problem in more depth, but without guidance from you guys upstream we're fairly lost.

If there is anything you can do to aid debugging this issue in the 2.7.x series (where x < 99!) then please ask for as much info as possible and we will provide it.

I'm quietly hoping the problem is still present in UXA and that it is in some code that is shared with EXA implementation so that it can be backported to a future 2.7.x release :)

While I'll try and get packages made for the latest post-purge driver into our Cooker distro soon for testing, the folks using the stable distro will still suffer, so like I say anything we can provide that allows you to give any insights (even if you don't fix anything) would be greatly appreciated.

All the best and here's to a bright future without all the permutations of driver options that are currently plaguing you :)
Comment 18 Gordon Jin 2009-05-19 20:12:55 UTC
Colin, thanks for your comments. Sorry I didn't make it clear that we still support EXA (in some range) on 2.7.x. But for compositing we really recommend UXA.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.