Bug 20683 - [865] UXA hangs X upon startup.
Summary: [865] UXA hangs X upon startup.
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium critical
Assignee: Eric Anholt
QA Contact: Xorg Project Team
Keywords: NEEDINFO
Depends on:
Reported: 2009-03-16 05:08 UTC by Scott H
Modified: 2009-12-10 11:24 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:

Xorg.log of hung X (52.76 KB, text/plain)
2009-03-16 05:08 UTC, Scott H
no flags Details

Description Scott H 2009-03-16 05:08:04 UTC
Created attachment 23909 [details]
Xorg.log of hung X

GPU: 00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)
OS: Gentoo linux
x-server: 1.6
Kernel: 2.6.29-rc8-git

Have tried various combinations and permutations of suggestions that I've found, both on freedesktop and on gentoos bugzilla, but so far nothing has worked. (kernels, KMS/FB on/off, AGP aperture, tiling, legacy3d, and more)
Thus far I have been unable to get a working X with UXA enabled, only with XAA.

Symptom: at some stage (usually just as desktop appears, but before icons are displayed), the display hangs, keyboard input is disabled, and the only movement on screen comes from mouse. Do not believe HAL is culprit, as works fine with XAA enabled.

Cannot change to a different tty. 
Can ssh in, sysrq keys do work.

No error messages appear in logs that appear relevant... although occasionally xfce4-mixer-plugin will segfault. As this also intermittently occurs when using XAA, I'm confident it is unrelated.

Have attached Xorg.0.log, but have not found anything that appears to point to a solution as yet. Am happy to post anything else that may be required.
Comment 1 Scott H 2009-03-25 05:15:51 UTC
Bug appears on its way to being solved in mesa-7.4_rc1. I can log into Xorg if I set depth to 15, and have a usable system for about ~4 minutes. Then the keyboard locks up. There is still no data in log/messages nor log/Xorg.0.log to indicate fault.
If depth is set to anything higher than 16, the previous symptoms appear.
Comment 2 Eric Anholt 2009-05-26 20:32:51 UTC
Could you try with the following kernel commit in for-review or posted to intel-gfx@lists.freedesktop.org

commit cfa16a0de5392c54db553ec2233a7110e4b4da7a
Author: Eric Anholt <eric@anholt.net>
Date:   Tue May 26 18:46:16 2009 -0700

    drm/i915: Apply a big hammer to 865 GEM object CPU cache flushing.
Comment 3 Eric Anholt 2009-07-15 13:48:39 UTC
Also, please attach intel_gpu_dump output.  You might be hitting another bug that I've got a good dump for.
Comment 4 Scott H 2009-07-23 05:31:50 UTC
Ah. One slight problem is that I can no longer log in to my system via ssh when it hangs - I get the password prompt, and nothing after that, leading me to suspect that there is more than just gpu corruption happening here.

I am currently running gentoos 2.6.31_rc3-r6 kernel, which appears to contain your 'big hammer' patch - apologies for the late response, have been trying different things in a vain attempt to make it work.
Comment 5 Eric Anholt 2009-09-21 14:23:41 UTC
Please retest with the following kernel patch:

commit e517a5e97080bbe52857bd0d7df9b66602d53c4d
Author: Eric Anholt <eric@anholt.net>
Date:   Thu Sep 10 17:48:48 2009 -0700

    agp/intel: Fix the pre-9xx chipset flush.

(present in my drm-intel-next tree)
Comment 6 Eric Anholt 2009-12-10 11:24:38 UTC
Closing on the assumption that it's fixed (like many other 865 bugs like this).  If your problem continues, please reopen.  If similar problems continue but the exact symptoms have changed, please open a new bug.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.