Bug 19955 - With KMS enabled, X sets wrong resolution and causes kernel oops when restarted
Summary: With KMS enabled, X sets wrong resolution and causes kernel oops when restarted
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Jesse Barnes
QA Contact:
Keywords: NEEDINFO
Depends on:
Reported: 2009-02-04 12:05 UTC by Michał Pecio
Modified: 2017-07-24 23:10 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:

Xorg log from 1st run (15.80 KB, text/plain)
2009-02-04 12:05 UTC, Michał Pecio
no flags Details
Xorg log from 2nd run (13.75 KB, text/plain)
2009-02-04 12:06 UTC, Michał Pecio
no flags Details
dmesg after 2nd run (37.12 KB, text/plain)
2009-02-04 12:07 UTC, Michał Pecio
no flags Details
kernel .config (61.85 KB, text/plain)
2009-02-04 12:09 UTC, Michał Pecio
no flags Details
lspci -vvv (19.12 KB, text/plain)
2009-02-04 12:09 UTC, Michał Pecio
no flags Details
dmesg oops (2.66 KB, text/plain)
2009-02-10 08:34 UTC, Damjan Georgievski
no flags Details

Description Michał Pecio 2009-02-04 12:05:29 UTC
Created attachment 22588 [details]
Xorg log from 1st run

Acer Aspire 3690
Celeron Yonah 1.6
Intel 945GM w/ integrated graphics
Source Mage GNU/Linux
Linux 2.6.29-rc3-git5 (also 2.6.29-rc3), only with enabled KMS
libdrm 2.4.4
mesa 7.3
xorg-server 1.5.3 (also
xf86-video-intel 2.6.1

The first time I run Xorg, it works with following glitches:

1. Xorg sets screen to 1280x800 (native resolution of my LCD), but for some reason it changes LVDS mode to 1024x768, displaying only upper-left part of the desktop. Xrandr knows about this mismatch and it is possible to switch LVDS back to 1280x800. VT switching works in both modes and in 1280x800 it is much faster than it used to be, so I assume that KMS works fine.

2. 3D rendering performs very poorly. glxgears gives ~0.928 fps and prints this message:
do_wait: drmWaitVBlank returned -1, IRQs don't seem to be working correctly.
Try adjusting the vblank_mode configuration parameter.

When I exit X and try to start it again, I get a black screen and an oops in dmesg.
Comment 1 Michał Pecio 2009-02-04 12:06:44 UTC
Created attachment 22589 [details]
Xorg log from 2nd run
Comment 2 Michał Pecio 2009-02-04 12:07:56 UTC
Created attachment 22590 [details]
dmesg after 2nd run
Comment 3 Michał Pecio 2009-02-04 12:09:03 UTC
Created attachment 22591 [details]
kernel .config
Comment 4 Michał Pecio 2009-02-04 12:09:45 UTC
Created attachment 22592 [details]
lspci -vvv
Comment 5 Damjan Georgievski 2009-02-10 08:33:08 UTC
I can confirm this, with Linux kernel 2.6.29-rc4-git (HEAD is 4c098bcd55fad34dcf224bf8343db6a9ac58fc68).

I'm attaching my dmesg output with the Oops.

xorg-server 1.5.3
xf86-video-intel 2.6.1
libdrm 2.4.4
945GM (X60s Thinkpad) chipset
Comment 6 Damjan Georgievski 2009-02-10 08:34:17 UTC
Created attachment 22757 [details]
dmesg oops
Comment 7 Damjan Georgievski 2009-02-16 19:24:28 UTC
this still happens with 2.6.29-rc5 and latest drm-fixes (commit:eaaffe54249d4444bb4de3631b9d968456bb0458)
Comment 8 Frederik Nosi 2009-02-18 01:56:20 UTC
I have the same issue on my acer extensa 5620 with an Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03).
Last kernel tried is 2.6.29-rc5 which im using right now, libdrm 2.4.4, mesa 7.3 and xorg server 1.5.3.
Just ask if you need more info.
Comment 9 Jesse Barnes 2009-03-12 16:38:53 UTC
Can you try again with -rc7 and 2D driver 2.6.3?  We've fixed a ton of bugs between when this was reported and today.  Also it looks like you're only getting DRI1 for some reason; we mainly test KMS with DRI2 so you should probably figure out why you're not getting that.
Comment 10 Damjan Georgievski 2009-03-12 16:56:21 UTC
Doesn't happen for me with kernel 2.6.29-rc7, xf86-video-intel-2.6.3 and xorg-server 1.6.0, using KMS.

There are other problems (on which I couldn't gather data-points) but this exact bug seems to be solved.
Comment 11 Jesse Barnes 2009-03-12 18:05:24 UTC
Great, thanks for testing.
Comment 12 Michał Pecio 2009-03-13 10:46:10 UTC
I've just checked it on my box. With rc7 and driver 1.6.3 the oops is gone.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.