Bug 19699 - [Q45 KMS] There is a black screen with kernel 2.6.29-rc2
Summary: [Q45 KMS] There is a black screen with kernel 2.6.29-rc2
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other Linux (All)
: medium normal
Assignee: Jesse Barnes
QA Contact:
Keywords: NEEDINFO
Depends on:
Reported: 2009-01-23 04:13 UTC by zhao jian
Modified: 2017-10-06 14:55 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

xorg.conf (3.77 KB, text/plain)
2009-01-23 04:13 UTC, zhao jian
no flags Details
xorg.0.log (51.61 KB, text/plain)
2009-01-23 04:13 UTC, zhao jian
no flags Details
blurred screen (344.52 KB, image/jpeg)
2009-01-23 04:14 UTC, zhao jian
no flags Details
dmsg of booting system with KMS (53.09 KB, text/plain)
2009-01-24 01:24 UTC, zhao jian
no flags Details
xorg.0.log (28.10 KB, text/plain)
2009-02-13 01:56 UTC, zhao jian
no flags Details

Description zhao jian 2009-01-23 04:13:16 UTC
Created attachment 22171 [details]

Host:           q45
Arch:           x86_64
OSD:            Fedora release 9 (Sulphur)
Kernel:         2.6.29-rc2
Libdrm:         (master)           27fae006853647ad0087067adc4eaa8d4ed4594a
Mesa:           (master)           65118a51b609cbcfdd6698a8e22c18e98152f362
Xorg:           7.2
Xserver:                (master)   0d3c3dad21857ef502fe0d0235620a1228248e13
Xf86_video_intel:   (master)       b6f3ce32e295929f461a7bc37e61f126fb51e4aa
Kernel:   (drm-intel-next)         f2515ef1ce257b842b19e5b5f5c077dcdbf0f22c

Bug Description:
I built kenel in drm-intel-next branch, and added kernel mode setting in it. Then after it passes grub, it will soon be black screen. But I can still log in it from remote side. When start X, the screen will have output there as normal, then I start Gnome, it can enter into the desktop environment, but with the fonts and icons blurred. You can see it in attachment. I have tried to disable kernel mode setting in grub but it takes no effect. And on gm45 and g43 I also made such kernel but has no such issue.  

Reproduce Steps:
1. add a line of CONFIG_DRM_I915_KMS=y, and build kernel
2. just boot the OS. (afer the grub it will become black screen soon)
Comment 1 zhao jian 2009-01-23 04:13:40 UTC
Created attachment 22172 [details]
Comment 2 zhao jian 2009-01-23 04:14:32 UTC
Created attachment 22173 [details]
blurred screen
Comment 3 Eric Anholt 2009-01-23 16:27:10 UTC
When reporting kernel issues, dmesg is required.  (It's a good idea regardless)
Comment 4 zhao jian 2009-01-24 01:24:50 UTC
Created attachment 22201 [details]
dmsg of booting system with KMS
Comment 5 Jesse Barnes 2009-01-28 13:52:09 UTC
The blank screen could be due to a missing fbcon driver.  Did you load it or build it in before loading the i915 driver with 'modeset=1'?  The screen corruption looks like a separate issue.
Comment 6 Gordon Jin 2009-02-03 19:24:50 UTC
Jian, let's focus on "black screen before X" in this bug tracker. And leave "corruption screen after X" as a separate issue (and note UXA is required).
Comment 7 andy lopez 2009-02-04 01:25:27 UTC
just a "me too" : black screen if i enable modesetting. No console, no X, nothing in the display.

I had similar dmesg warnings as the reporter with -rc2, with -rc3 the 
"drm_mode_object_get called w/o mode_config lock" 
warnings went all away but still no output at all in the display.
I thought there maybe was a kernel/userspace mismatch ( or any other related problem) and i tried pulling everything from current master with the same result.

Hardware is eeepc901 - gem/uxa are enabled and working according to logs.
What bugs me is that inteldrmfb device / panic notifier are created at startup and if i ssh to the laptop everything is working apparently fine ...
Comment5 suggests a missing fbcon driver, all i have (FB related) in my kernel config is CONFIG_FB=y and CONFIG_FRAMEBUFFER_CONSOLE=y IIRC, am i missing sth. here ?

I have limited access to this laptop right now, sorry, but i can provide more info later.

thanks for your time !
Comment 8 Gordon Jin 2009-02-12 22:40:44 UTC
(In reply to comment #5)
> The blank screen could be due to a missing fbcon driver.  Did you load it or
> build it in before loading the i915 driver with 'modeset=1'? 

Yes, it's working now (probably caused by missing fbcon), so I'm closing this.

Andy, you might file a separate bug for your issue. Thanks.
Comment 9 zhao jian 2009-02-13 01:56:13 UTC
Hi Jesse, I built with 2.6.29-rc2 again and boot without i915.modeset=1, it now can boot up. But it has no resolution change compared with former ones. But the only difference is in xorg.0.log all the output has been added a number in suffix, is it to say kernel mode setting is OK? (as following shows)
(II) intel(0): Output VGA1 connected
(II) intel(0): Output DVI1 disconnected
(II) intel(0): Output DVI2 connected
(II) intel(0): Using exact sizes for initial modes
(II) intel(0): Output VGA1 using initial mode 1024x768
(II) intel(0): Output DVI2 using initial mode 1024x768
Comment 10 zhao jian 2009-02-13 01:56:53 UTC
Created attachment 22893 [details]
Comment 11 Elizabeth 2017-10-06 14:55:35 UTC
Closing old verified.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.