Bug 19628 - [KMS] [855GM] Computer freezes with garbled screen, regression of 2.6.29-rc1->rc2
Summary: [KMS] [855GM] Computer freezes with garbled screen, regression of 2.6.29-rc1-...
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: Jesse Barnes
QA Contact: Xorg Project Team
Keywords: NEEDINFO
Depends on:
Reported: 2009-01-17 08:27 UTC by un_aimed
Modified: 2017-07-24 23:11 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:

xorg configuration (376 bytes, text/plain)
2009-01-17 08:31 UTC, un_aimed
no flags Details
Screenshot of failing X (113.10 KB, image/jpeg)
2009-01-17 08:40 UTC, un_aimed
no flags Details
xorg log file of failing X (7.56 KB, text/plain)
2009-01-31 06:40 UTC, un_aimed
no flags Details
xorg configuration (277 bytes, text/plain)
2009-01-31 06:42 UTC, un_aimed
no flags Details
dmesg with i915.modeset=1 (2.6.29-rc3) (19.63 KB, text/plain)
2009-01-31 06:45 UTC, un_aimed
no flags Details
Xorg log 2.6.29-rc4 (6.84 KB, text/plain)
2009-02-10 09:50 UTC, un_aimed
no flags Details

Description un_aimed 2009-01-17 08:27:48 UTC
When starting X the computer locks up with a garbled screen. I will attach a picture of it. The screen also "flashes" at a high frequenzy. I cannot get the computer to respond in anyway other than shutting it off with the button (holding for a few seconds). 

This only happens when booting the kernel i915.modeset=1. Without KMS everything works as expected.

Hardware is a IBM Thinkpad R51 with 855GM.
00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)
00:02.1 Display controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)


With kernel version 2.6.29-rc1 this does not happen (there are other problems but i could still start X).
Comment 1 un_aimed 2009-01-17 08:31:56 UTC
Created attachment 22048 [details]
xorg configuration
Comment 2 un_aimed 2009-01-17 08:40:36 UTC
Created attachment 22049 [details]
Screenshot of failing X
Comment 3 Jesse Barnes 2009-01-28 13:24:35 UTC
Can you attach your X log?  Or is the machine totally dead (i.e. you can't even login to it from the network)?  Also, does -rc3 work?
Comment 4 un_aimed 2009-01-30 08:36:45 UTC
The machine is totally dead i'm afraid. I tried removing the xorg log file before starting X but it wasn't there after a restart.

This issue is still happening with:

A note: I think one of the drm fixes between rc1 and rc2 involved some pointer fixes. In rc1 i had a corrupt cursor, it was a 64x64 (my perception of it's size) square with lots of bright pixels some transparent.
Comment 5 un_aimed 2009-01-31 06:38:50 UTC
I managed to get my system to save the Xorg.0.log file by mounting root with mount option sync. I will attach it.

Since this bug was registrered I have updated my xorg.conf file but it still has the same problem. I will replace the attached xorg.conf if possible, otherwise i will create a new one.

I will also attach dmesg.
Comment 6 un_aimed 2009-01-31 06:40:34 UTC
Created attachment 22416 [details]
xorg log file of failing X
Comment 7 un_aimed 2009-01-31 06:42:56 UTC
Created attachment 22417 [details]
xorg configuration
Comment 8 un_aimed 2009-01-31 06:45:47 UTC
Created attachment 22418 [details]
dmesg with i915.modeset=1 (2.6.29-rc3)
Comment 9 un_aimed 2009-01-31 07:01:09 UTC
Another thing came to mind: With 2.6.29-rc1 and kernel modesetting xrandr reported 1024x1024 as the only available resolution. 

Sorry for the "spamming".
Comment 10 un_aimed 2009-02-10 09:49:14 UTC
I get the same error with 2.6.29-rc4, with two exceptions. The machine doesn't hardlock, i can ssh to it and shut it down in a correct way. The log file is also missing a few lines from the end if you compare it to the previous ones.
Comment 11 un_aimed 2009-02-10 09:50:29 UTC
Created attachment 22765 [details]
Xorg log 2.6.29-rc4
Comment 12 Jesse Barnes 2009-02-13 14:42:14 UTC
Steve fixed some memory corruption, can you give this patch a try?

Comment 13 un_aimed 2009-02-14 10:13:40 UTC
Applying the patch makes the screen corruption go away, i can now enter X. I still have the other problems i had in rc1 (wrong resolution, hangs when changing vt/closing x) export for pointer corruption. I will file separate bugs for these unless they already exist.
Comment 14 Damjan Georgievski 2009-03-12 19:35:54 UTC
I'm getting something very similar to this but after X would work for a while - so yes it's awful, since the laptop freezes in the middle of work.

Kernel: 2.6.29-rc7 (i915.modeset=1)
xf86-video-intel: 2.6.3
xorg-server: 1.6.0
libdrm: 2.4.5
Hardware: 945gm (Thinkpad X60s)

I don't use compoziting nor 3D (I use awesome).

So the problem is, the computer freezes and I get very strange patterns on the screen... not random noise, but still nothing eligible.

Disableing KMS seems to prevent the lockup ... except, if it only postpones it for much later, dunno.
Comment 15 Jesse Barnes 2009-04-03 12:00:40 UTC
Latest kernel should have a fix for this, can you confirm?
Comment 16 Jesse Barnes 2009-04-23 18:44:44 UTC
Have you had a chance to test yet?
Comment 17 un_aimed 2009-04-24 12:15:22 UTC
Hmm, i though i replied, oh well.

This does not happen for me anymore, it works as it should in 2.6.29. I do have another problem preventing me from using KMS reliably (which i haven't reported yet, due to my laziness).

Comment 18 Jesse Barnes 2009-04-24 12:17:20 UTC
Yeah seems to be working for me as well.  Closing.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.