Bug 19281 - 2.4.3: No mode found for Hitachi CM753U monitor
Summary: 2.4.3: No mode found for Hitachi CM753U monitor
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: 7.4 (2008.09)
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: MaLing
QA Contact: Xorg Project Team
Keywords: regression
Depends on:
Reported: 2008-12-24 18:40 UTC by Paul
Modified: 2009-06-13 07:08 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:

contains xorg.conf and Xorg.0.log for Hitachi CM753U monitor / intel driver (96.04 KB, application/octet-stream)
2008-12-24 18:40 UTC, Paul
no flags Details
xorg.conf (2.66 KB, text/plain)
2008-12-25 15:15 UTC, Paul
no flags Details
Xorg.0.log for Slackware 12.0 (58.41 KB, text/plain)
2008-12-25 15:16 UTC, Paul
no flags Details
Xorg.0.log for Slackware 12.2 (34.56 KB, text/plain)
2008-12-25 15:17 UTC, Paul
no flags Details

Description Paul 2008-12-24 18:40:37 UTC
Created attachment 21472 [details]
contains xorg.conf and Xorg.0.log for Hitachi CM753U monitor / intel driver

I have an older Hitachi CM753U CRT monitor.  I have used it for several years; 
I am the original owner.
I have the original owners manual, and the horizontal sync range is 31-107 kHz,
and vertical sync rate is 50-160 Hz.  Those are the values I have used over
the years in my xorg.conf file.  I have a Gigabyte GA-945GM motherboard that
has imbedded intel 945G graphics.  I'm been running Slackware for many years,
and currently am running Slackware 12.0 with no problem.  I actually did
test Slackware 12.1 beta 3 successfully, but for the final Slackware 12.1 
release, a last minute change to the intel driver was made and I could never
install Slackware 12.1.  I tried a little debugging unsucessfully, and hoped
the problem would fix itself with Slackware 12.2.  It has not: when I tried
a new install of Slackware 12.2 on a new partition, I can't start up X using
my monitor and the intel video driver.   My screen just freezes up blank, and
I can't do anything except "reset".  I can't figure out how to add more than
1 attachment with bugzilla, so I have combined 3 files into 1 so I can have
just have 1 attachment.  This file contains 1. my xorg.conf file, that has
ModeDebug set to true  2. the logfile from my Slackware 12.0 partition
using this xorg.conf file (that works fine), and 3. the logfile from my
Slackware 12.2 partition (that freezes up my monitor).
Comment 1 Gordon Jin 2008-12-24 19:35:31 UTC
Please attach one by one (Now you've seen "Add an attachment" link), instead of one tarball. Thanks.
Comment 2 Paul 2008-12-25 15:15:02 UTC
Created attachment 21478 [details]
Comment 3 Paul 2008-12-25 15:16:14 UTC
Created attachment 21479 [details]
Xorg.0.log for Slackware 12.0
Comment 4 Paul 2008-12-25 15:17:17 UTC
Created attachment 21480 [details]
Xorg.0.log for Slackware 12.2
Comment 5 Michael Fu 2008-12-25 18:09:36 UTC
what if you don't use the xorg.conf or comment out the Monitor section, and just let X decide by itself?
Comment 6 Paul 2008-12-28 07:41:38 UTC
Per a suggestion from Gordon Jin, I have commented out the
following lines from my xorg.conf file:

        HorizSync    31.0 - 107.0
        VertRefresh  50.0 - 160.0
        Option "XAANoOffscreenPixmaps"
        Option "AllowGLXWithComposite" "true"
        Option "EnablePageFlip" "true"

When I did that, I still observed the same problem: the X server 
just freezes up; I have to restart my PC to get it back.

However, I also did learn that if I uncomment this line (in addition to the
5 above lines):

        Option "PreferredMode" "1600x1200"

the X server will start, but it's "wrong";   the page that comes up is 
wider than my screen (it rolls off he left side by a couple of inches), 
I have big black borders on the top, bottom, and right side of my screen, 
the colors are completely off, and I have a rainbow like effect
running from left to right across the top part of the screen.  At least
now I can kill the server and get back to the console; I still can't use X.

I have been running Slackware for many years, and made it up to 
Slackware 12.0.  Almost a year ago, my motherboard died and I replaced it 
with a new one, which has the intel 945G imbedded graphics chipset.  
Previously I had an older video card.  When I swapped out the motherboard, 
I found that in order to get X to work with the intel driver in Slackware 
12,0 on the new motherboard, I had to set

        Option "PreferredMode" "1600x1200"

or I would get the exact same problem I am not seeing with Slackware 12.2 
and PreferredMode not set.

In summary,

    Slackware 12.0, PreferredMode set, works fine
    Slackware 12.0, no PreferredMode, display is way off as described above
    Slackware 12.2, no PreferredMode, display is way off (same as Slack 12.0)
    Slackware 12.2, PreferredMode set, X server will not start/freezes up.

I don't know if any of that helps at all, or just makes it more confusing.

If there are additional scenarios I should try, please let me know.  I cannot
fix this problem myself and I will gladly provide as much help as I can to
those of you who are able to fix it.

Comment 7 Paul 2008-12-28 07:58:29 UTC
Per suggestion in Comment 5, I did try commenting out the entire Monitor Section, and 
this line: 

Monitor    "Monitor0"

in the Screen section.  This had no effect: the display still comes up "wrong" as described above.
Comment 8 Wang Zhenyu 2008-12-28 23:06:04 UTC
Paul, how about stick this mode line in xorg.conf? And make PreferredMode use it.

Modeline "1600x1200_85.0"  229.50  1600 1664 1856 2160  1200 1201 1204 1250 +hsync +vsync

Option "PreferredMode" "1600x1200_85.0"
Comment 9 Paul 2008-12-29 07:29:28 UTC
I did try adding the Modeline and PreferredMode lines as suggested in Comment 8.
This DOES work for me; I am very, very grateful.  I kind of consider this a workaround
because I still can't run LiveCDs of other distributions.  However, I understand I may be
the only person on the planet still using this monitor, and working on the driver may not
be appropriate since the additional 2 lines do provide me with a way to start and use X.
If however you want additional information from me, I will gladly provide it.  
If I didn't say thank you enough to all of you, here it is again: thank you all very much.

In short, if you want to close this bug report, it's fine with me.  If you want to keep working
on it so that a user doesn't need to manually add the Modeline and PreferredMode lines,
I will gladly try to provide any additional information you required.  

thanks thanks thanks .....
Comment 10 Eric Anholt 2008-12-29 13:28:47 UTC
The problem is the server is rejecting the detailed mode that your monitor tells it is the correct mode for your monitor.

(II) intel(0): Supported additional Video Mode:
(II) intel(0): clock: 229.5 MHz   Image Size:  360 x 270 mm
(II) intel(0): h_active: 1600  h_sync: 1664  h_sync_end 1856 h_blank_end 2160 h_border: 0
(II) intel(0): v_active: 1200  v_sync: 1201  v_sync_end 1204 v_blanking: 1250 v_border: 0
(II) intel(0): Ranges: V min: 50  V max: 160 Hz, H min: 31  H max: 107 kHz,

(II) intel(0): Modeline "1600x1200"x0.0  229.50  1600 1664 1856 2160  1200 1201 1204 1250 +hsync +vsync (106.2 kHz)

(II) intel(0): Not using mode "1600x1200" (hsync out of range)

This would be a general bug in the EDID and mode handling of the server, not a driver problem.
Comment 11 MaLing 2009-06-13 07:08:16 UTC
Yes, this is not driver bug, and we have found work around, so close it.

Ma Ling

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.