Bug 19070 - Problems with colors in the SiS driver
Summary: Problems with colors in the SiS driver
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/SiS (show other bugs)
Version: 7.4 (2008.09)
Hardware: All Linux (All)
: high critical
Assignee: Thomas Winischhofer
QA Contact: Xorg Project Team
Keywords: regression
: 19104 (view as bug list)
Depends on:
Reported: 2008-12-13 02:45 UTC by Przemek K.
Modified: 2010-03-19 05:13 UTC (History)
5 users (show)

See Also:
i915 platform:
i915 features:

xorg.conf for intrepid with vesa driver, configured for 1280x800 resolution (1.30 KB, text/plain)
2009-01-14 06:20 UTC, Michał Gołębiowski
no flags Details

Description Przemek K. 2008-12-13 02:45:55 UTC
I'm having problems with colors when using the SiS driver with XOrg 7.4. Before the update everything worked fine. More info with the screenshots is here:
Right now I'm using a VESA driver, but it has smaller resolution. Besides, there's a problem with VESA: when I log out of X and then press Alt-F7 the system hangs.
Comment 1 Przemek K. 2008-12-23 08:13:09 UTC
I didn't get an answer so far... Could someone fix this problem? It is quite annoying.
Comment 2 Michał Gołębiowski 2009-01-14 05:59:00 UTC
*** Bug 19104 has been marked as a duplicate of this bug. ***
Comment 3 Michał Gołębiowski 2009-01-14 06:08:54 UTC
OK, You opened this bug 2 days before I did it, so I marked my instance as a
duplicate. ;)

Just to keep order - bug report in launchpad, widely commented, is here:

Please, comment if You have any significant remark.
Comment 4 Michał Gołębiowski 2009-01-14 06:20:00 UTC
The problem with logging out is not general, I didn't have it with vesa - I think You should fill another bug and this one should be only about not working sis driver.

As for the vesa resolution - although, unfortunately, 1280x800 is impossible to get with vesa, 1280x768 is available if You put it explicite in Your xorg.conf, so it's "quite" ok. Performance is not very good, though.

That is why I keep to Hardy 8.04 LTS edition that sticks to X.org 7.3 and that will be supported till 2011. At least until 2011 I can use sis driver...

I'll attach my intrepid's xorg.conf with proper vesa entries, maybe it'll help.

One remark - those "Modeline" entries can be obtained by using the command:
gtf <h-resolution> <v-resolution> <refresh rate>
(see man gtf)
Comment 5 Michał Gołębiowski 2009-01-14 06:20:57 UTC
Created attachment 21977 [details]
xorg.conf for intrepid with vesa driver, configured for 1280x800 resolution
Comment 6 Michał Gołębiowski 2009-01-14 06:23:15 UTC
> configured for 1280x800 resolution
Pardon, I meant 1280x768. Although those 1280x800 entries exist in the attached xorg.conf, they were not used and X server was automatically switching to 1280x768. So 1280x800 can be ommited (but You have to put 1280x768 in the first place in "Modes" line)
Comment 7 Thomas Wouters 2009-01-14 06:39:13 UTC
I'm using openSUSE-11.1 and have the same issue.

I made the system load sisfb module on boot and put Option "UseFBDev" "true" in the Device section in xorg.conf which seems to be a successful (1280x800) workaround. I had to reboot though, doing modprobe sisfb and restarting xorg didn't work.
Comment 8 Michał Gołębiowski 2009-01-14 06:52:23 UTC
> I'm using openSUSE-11.1 and have the same issue.
I tried openSUSE-11.1 LiveCD and I can confirm these problems.

> I made the system load sisfb module on boot and put Option "UseFBDev" "true" in
> the Device section in xorg.conf which seems to be a successful (1280x800)
> workaround.
I'm pretty sure I tried it and it didn't help. It seems, though, that it helped some people, so it can depend on some specific issues. It's always worth to try, though...

I prefer to stick to Hardy as long as I can.
Comment 9 Przemek K. 2009-01-14 07:11:57 UTC
I've changed my computer recently and now I've GeForce card so I won't be able to report on this problem anymore.
Comment 10 Michał Gołębiowski 2009-01-24 19:40:36 UTC
Fernando Pereira proposed a configured version of xorg.conf which works for me
perfectly in Ubuntu Intrepid (with sisfb module loaded). Here is a permalink:
Comment 11 Michał Gołębiowski 2009-01-24 21:15:15 UTC
It seems that for me adding sisfb to /etc/modules works (after a reboot).

NOTE: sisfb module *MUST* be loaded at start. It means that it's not enough to load it using 'modprobe sisfb' and restarting X server. It *MUST* be added to /etc/modules, after a reboot it starts to work.
Comment 12 Michał Gołębiowski 2009-01-24 21:18:42 UTC
One more: for me adding "UseFBDev" option to xorg.conf wasn't necessary. I must have omitted something when I was trying the solution last time as it works perfectly now...
Comment 13 Olivier Taibi 2009-01-25 06:11:44 UTC
I experience the same problem with a sis 760 (GM or GX i think, lspci doesn't give much information), under fedora 10.
Problem is, sisfb is not included in this distribution (so i cannot use your trick), and i cannot get the old version of the sis driver (9.4) to compile (seems to be because of changes in the xorg api).
10.0 and 10.1 do compile, but they both produce odd colors (after "startx" it's not that weird, but it gets worse with the time).
Is there an easy way to convert the old driver to the new api?
Comment 14 Olivier Taibi 2009-01-25 06:45:39 UTC
Btw, it seems Thomas Winischhofer has stopped working on this driver since 2005, so maybe we should reassign the bug, but i don't know who to reassign it to.
According to http://cgit.freedesktop.org/xorg/driver/xf86-video-sis/ , Dave Airlie, Adam Jackson or Julien Cristau are active, but i don't know their email.
Comment 15 Michał Gołębiowski 2009-01-25 11:11:40 UTC
I'm a little noob here, but isn't xf86-video-sis team working at XFree86 version of the driver, not the X.org one?
Comment 16 Michał Gołębiowski 2009-10-18 03:39:37 UTC
It has already been fixed in Gentoo:
Comment 17 Michał Gołębiowski 2009-10-19 21:29:46 UTC
The latest fix from kendatsuba, provided at launchpad, solves the problem for me. See comments:

Could this fix be applied upstream?
Comment 18 Michał Gołębiowski 2009-11-03 13:36:29 UTC
I believe it's been fixed:
Comment 19 herve_02 2010-03-19 05:13:35 UTC
for me, debian sid with SIS 661 i resolved the problem using the patch found above adding case SIS_661 to the list- still using sis driver and adding sisfb to /etc/modules

this patch is not applied in xserver-xorg-video-sis 1:0.10.2-1

for using dual head i just use this xorg.conf file :

Section "Device"
Identifier "SIS 661"
Driver "sis"
        BusID           "PCI:1:00:0"
        Option          "MergedFBAuto" "on"
        Option          "UseSSE" "yes"

======================== patch found ===============================

 src/sis_driver.c |    2 ++
 1 files changed, 2 insertions(+), 0 deletions(-)

diff --git a/src/sis_driver.c b/src/sis_driver.c
index 994b02d..b19e7a9 100644
--- a/src/sis_driver.c
+++ b/src/sis_driver.c
@@ -4099,6 +4099,8 @@ SISPreInit(ScrnInfoPtr pScrn, int flags)
             case SIS_315H:
             case SIS_330:
             case SIS_340:
+            case SIS_650:
+            case SIS_760:
             case XGI_40:     readpci = TRUE;
             case XGI_20:     readpci = TRUE;

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.