Bug 18690 - crysyalspace can freeze the X server (965GM) on opensuse 11.1
Summary: crysyalspace can freeze the X server (965GM) on opensuse 11.1
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: haihao
QA Contact:
Keywords: NEEDINFO
Depends on:
Reported: 2008-11-24 13:40 UTC by Philip Ashmore
Modified: 2009-01-23 22:50 UTC (History)
6 users (show)

See Also:
i915 platform:
i915 features:

/var/log/Xorg.0.log (41.85 KB, text/plain)
2008-11-26 06:53 UTC, Philip Ashmore

Description Philip Ashmore 2008-11-24 13:40:29 UTC
I reported this to OpenSuse 11
and am reporting it here as requested.

Basically running /usr/bin/csbench from the crystalspace-utils package freezes
machine, forcing a reboot.
Comment 1 Gordon Jin 2008-11-25 23:12:56 UTC
maybe dup with bug#18433 -- the same reporter.

Please always attach Xorg.0.log, as requested by http://intellinuxgraphics.org/how_to_report_bug.html.
Comment 2 Philip Ashmore 2008-11-26 06:53:21 UTC
Created attachment 20610 [details]
Comment 3 Philip Ashmore 2008-11-26 06:58:56 UTC
As I said in
the X server doesn't crash - the machine hangs.

I've supplied the /var/log/Xorg.0.log anyway as requested.

None of the Caps lock, Num lock, Ctrl-Alt-Fn keys repond and the mouse is frozen in place.

Holding down the power off button for 5 seconds is needed to force a power off.
Comment 4 Jesse Barnes 2008-12-18 14:02:13 UTC
Looks like a 3D bug...
Comment 5 Gordon Jin 2008-12-18 19:32:33 UTC
Philip, are you able to try with newer driver? like OpenSuSE 11.1, and/or better with 2.6.28 kernel? It will be best if you are comfortable to use git driver, as recommended as 2008Q4 pre-release at http://intellinuxgraphics.org/download.html (this is the code Shuang has verified that clutter works without the similar problem as this bug).
Comment 6 Philip Ashmore 2008-12-20 05:21:19 UTC
Sorry - I'm not comfortable using pre-release packages/repositories unless there is a Yast2 way of rolling back the changes (restore point?).

Curiously, the clutter problems seem to have gone away in 11.1.

Even more curiously, the crystalspace-utils / csbench program seemed to work after some package updates on 11.0 and after upgrading to 11.1 it hangs the X server.

It appears that upstream are making changes that alternately expose and hide / solve two different bugs.

Wouldn't it be better to give upstream a nudge about this bug / these bugs, rather than an end user such as myself trying it and seeing if it "works for me"?
Comment 7 qwang13 2008-12-30 23:55:52 UTC
Please use opensuse11.1 gold master. And try again. I am doubt it is the same as 18433.

Also, if failed, try ExaNoComposite to check if it can solve the problems.

As I tried clutter, it will cost much more resources, close compiz, desktop effect.
Comment 8 Philip Ashmore 2008-12-31 01:46:05 UTC
I've set "ExaNoComposite" to "true" in the "Device" section for the "intel" driver in xorg.conf.

At least it no longer crashes, but does this setting adversely affect performance?

Should this fix be classified as a "workaround"?

Here's the output of csbench

  Opening GLX2D
  Creating Context
ATTENTION: default value of option force_s3tc_enable overridden by environment.
  Video driver GL/X version (direct renderer)
  Visual ID: 0x0000000000000021, 24bit TrueColor
  level 0, double buffered

  OpenGL renderer: Mesa DRI Intel(R) 965GM 20080716 (vendor: Tungsten
  Graphics, Inc) version 1.4 Mesa 7.2
  Using windowed mode at resolution 640x480.
  Pixel format: Color: 24 Alpha: 8 Depth: 24 Stencil: 8 AccumColor: 0
  AccumAlpha: 0 MultiSamples: 0
  Multisample: disabled

  Using VBO with 64 MB of VBO memory

  Recalculation of lightmaps forced.
  Initializing lighting (105 meshes).
  Shining lights (6 lights).
  Time taken: 0.4290 seconds.

  Crystal Space compiled in release mode.
  Compiler 'GCC', platform 'Unix', processor 'x86'
  Big object in test has 50562 triangles.
  Small object in test has 512 triangles. We use 100 of them.
  Benchmark stencilclip_single (Stencil clipping, single object)...
  PERF:stencilclip_single:193:3:64.3333: (193 frames in 3 seconds: 64.3333 fps)
  Benchmark stencilclip_multi (Stencil clipping, multiple objects)...
  PERF:stencilclip_multi:193:3:64.3333: (193 frames in 3 seconds: 64.3333 fps)
  Benchmark planeclip_single (glClipPlane, single object)...
  PERF:planeclip_single:231:3:77: (231 frames in 3 seconds: 77 fps)
  Benchmark planeclip_multi (glClipPlane, multiple objects)...
  PERF:planeclip_multi:160:3:53.3333: (160 frames in 3 seconds: 53.3333 fps)
  Benchmark light_bumpmap_50 (Shader light_bumpmap with priority 50)...

  Multitexture units: whopping 8

  PERF:light_bumpmap_50:32:3:10.6667: (32 frames in 3 seconds: 10.6667 fps)
  Benchmark light_bumpmap_100 (Shader light_bumpmap with priority 100)...
  PERF:light_bumpmap_100:34:3:11.3333: (34 frames in 3 seconds: 11.3333 fps)
  Benchmark light_bumpmap_150 (Shader light_bumpmap with priority 150)...
  PERF:light_bumpmap_150:28:3:9.33333: (28 frames in 3 seconds: 9.33333 fps)
  Benchmark light_bumpmap_200 (Shader light_bumpmap with priority 200)...
  PERF:light_bumpmap_200:37:3:12.3333: (37 frames in 3 seconds: 12.3333 fps)
  Benchmark light_bumpmap_220 (Shader light_bumpmap with priority 220)...
  PERF:light_bumpmap_220:27:3:9: (27 frames in 3 seconds: 9 fps)
  Benchmark light_bumpmap_250 (Shader light_bumpmap with priority 250)...
  PERF:light_bumpmap_250:27:3:9: (27 frames in 3 seconds: 9 fps)
  Benchmark light_bumpmap_300 (Shader light_bumpmap with priority 300)...
  PERF:light_bumpmap_300:34:3:11.3333: (34 frames in 3 seconds: 11.3333 fps)
  Benchmark light_bumpmap_350 (Shader light_bumpmap with priority 350)...
  PERF:light_bumpmap_350:49:3:16.3333: (49 frames in 3 seconds: 16.3333 fps)

I don't know what "opensuse-11.1 gold master" is - I'm using opensuse release

I'm not using compiz - it's not even installed.

Are you using the same machine as I am?
Comment 9 qwang13 2009-01-01 04:49:23 UTC
(In reply to comment #8)
> I've set "ExaNoComposite" to "true" in the "Device" section for the "intel"
> driver in xorg.conf.
> At least it no longer crashes, but does this setting adversely affect
> performance?
> Should this fix be classified as a "workaround"?

We do the testing for performance of intel Q3 release. It is not good. You can check bug 18389. 

For ExaNoComposite and Exa, after testing of performance, maybe ExaNoComposite will be better than Exa. However I just use x11perf to do the testing. If you can provide more data, it will be preferred. I don't make sure if you accept this your work around. If this affect your work, it will be. 

The latest of intel upstream source code has more better performance which including GEM in kernel. We have done the testing. It raise the performance more reasonable. you can have a try this.

However based on the plan of SLE11, I think Novell just accept intel Q3 release as their official intel graphics driver. They have no way to change it because of the kernel release. 

Thanks for your understanding. Better service is our goal for you and customer. 
Comment 10 Gordon Jin 2009-01-03 21:54:24 UTC
(In reply to comment #6)
> Wouldn't it be better to give upstream a nudge about this bug / these bugs,
> rather than an end user such as myself trying it and seeing if it "works for
> me"?

I tried with the upstream driver (Intel 2008Q4 pre-release), and both crystalspace and clutter works fine.
Comment 11 qwang13 2009-01-13 20:37:18 UTC
Please got the patch from 19242, and try to build Mesa with it. Try again. The patch is based on Intel-Q3 release (2008) which it is used also by openSUSE11.1 and SLED11-RC1.

Don't need to set ExaNoComposite
Comment 12 Stefan Dirsch 2009-01-17 06:19:43 UTC
Philip, could you try Mesa package


Install/update also Mesa-32bit package if you're running x86_64 and use 32bit applications like GoogleEarth.
Comment 13 Philip Ashmore 2009-01-17 10:38:00 UTC
I tried http://download.opensuse.org/repositories/X11:/XOrg/openSUSE_11.1/

I also removed ExaNoComposite in xorg.conf
I'm not using Compiz - not installed.

test-perspective is still displaying just a white screen.
This may be due to a lack of hardware capabilities in my graphics card.

test-perspective  [FAIL]

test-shader displays a window with a grey-purple colour...
    applying shaders[0] named 'brightness-contrast'
...and does nothing
Ctrl-C quits.
This may be due to a lack of hardware capabilities in my graphics card.

test-shader       [FAIL]

test-textures takes about two minutes to complete and uses lots of memory.
System responsiveness is affected, but it gets all the way through (5003x5003).

test-textures     [OK]

Google Earth also works but I'm seeing white triangles when I get REALLY close.
They disappear when I zoom out.

Google Earth      [OK]

I'm looking forward to the Intel Q4 drivers - I hope they improve performance, otherwise I think this bug is resolved.
Comment 14 Stefan Dirsch 2009-01-23 22:50:04 UTC
According to latest comment closing as fixed.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.