Bug 18321 - xserver 1.5.2 fails to start with more than one display card
Summary: xserver 1.5.2 fails to start with more than one display card
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
: 18839 20225 20878 (view as bug list)
Depends on:
Blocks: xorg-7.5 xserver-1.6.1 20816 xserver-1.7
  Show dependency treegraph
Reported: 2008-10-31 00:32 UTC by Timo Aaltonen
Modified: 2009-08-31 17:40 UTC (History)
15 users (show)

See Also:
i915 platform:
i915 features:


Description Timo Aaltonen 2008-10-31 00:32:15 UTC
Forwarded from launchpad:


Basically what happens is that the server fails with:

(EE) No device detected.

when there are more than one display device on the system. Some logfiles:


Setting the BusID allows it to work. I've requested the people to try without an xorg.conf to see if the different autoconfig-paths have something to do with this..
Comment 1 Timo Aaltonen 2008-10-31 01:14:25 UTC
I've noticed that on x86 things seem to work just fine:


and all the non-working logs are from x86_64-systems.

So, is this another example of 64bit-unsafeness?
Comment 2 Timo Aaltonen 2008-10-31 05:13:26 UTC
bah, no.. this is a log from a normal i686 installation:

Comment 3 Timo Aaltonen 2008-12-30 14:52:31 UTC
*** Bug 18839 has been marked as a duplicate of this bug. ***
Comment 4 pgnet 2009-01-15 14:33:35 UTC
I'm seeing the same "(EE) No device detected" error on an x86_64 with 2 NVIDIA cards -- one on mobo, one on pci.

I'm using a source-built 'nvidia' driver (v180.22).

In my case, setting the BusID, apparently, DOES NOT work.

I've previously posted the details, including logs, on nvnews (nvidia) forum @


Comment 5 Bryce Harrington 2009-02-24 13:18:44 UTC
*** Bug 20225 has been marked as a duplicate of this bug. ***
Comment 6 Timo Aaltonen 2009-03-24 08:28:22 UTC
Fedora has a patch which might help here.
Comment 7 Timo Aaltonen 2009-03-24 08:28:51 UTC
sigh, let's put the url here instead:

Comment 8 Alan Coopersmith 2009-03-24 21:46:23 UTC
When I suggested the Fedora patch to our PCI/driver guys, they responded that
they'd tried similar things before in the kernel and found that they didn't work
on some platforms.   The code they ended up with instead is:

Comment 9 Julien Cristau 2009-03-24 21:57:54 UTC
let's also mention Dave's patches:

then i suppose X can use pci_device_is_boot_vga() to look for its "primary" device?
Comment 10 Julien Cristau 2009-03-26 10:46:28 UTC
*** Bug 20878 has been marked as a duplicate of this bug. ***
Comment 11 Oli Wade 2009-05-13 01:13:57 UTC
This is now also fixed in Ubuntu 9.04 (using the redhat/fedora patch) and working for me on x86_64 (xserver-xorg-core: 1.6.0-0ubuntu14) with 2 x nVidia NV43 [GeForce 6600 GT].
Comment 12 freedesktop 2009-06-06 01:12:49 UTC
I just tested in in Ubuntu 9.04 with the latest patched installed and it is still not working. I have two cards (AGP and PCI)

00:08.0 VGA compatible controller: nVidia Corporation NV11DDR [GeForce2 MX200] (rev b2)
01:00.0 VGA compatible controller: nVidia Corporation NV11DDR [GeForce2 MX200] (rev b2)

and I am using NVidia card. The system fails to start with with the output in the log that no primary card found until I went to xorg.conf and manually added to the device section 

BusID "PCI:0:8:0"
Comment 13 Daniel Stone 2009-08-31 17:25:25 UTC
dave, this all got merged to master, yeah? if so, can we close it at least for 1.7?
Comment 14 Dave Airlie 2009-08-31 17:40:32 UTC
yup should all be in master now + libpciaccess 0.10.8 for Linux.

if this keep happening with a 1.7 server please re-open.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.