Bug 18288 - [845G] X session fails after session logout, with underrun error
Summary: [845G] X session fails after session logout, with underrun error
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.4 (2008.09)
Hardware: x86 (IA32) Linux (All)
: medium critical
Assignee: Jesse Barnes
QA Contact: Xorg Project Team
URL: https://bugs.launchpad.net/ubuntu/+so...
Keywords: NEEDINFO
Depends on:
Reported: 2008-10-29 03:52 UTC by P. P. Rasanen
Modified: 2009-07-09 09:46 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

Xorg.log from a relevant session (Xorg.20.log) (54.60 KB, text/x-log)
2008-10-29 12:13 UTC, P. P. Rasanen
no flags Details
Xorg.0.log from the present session, without the underrun error (32.90 KB, text/x-log)
2008-10-29 12:23 UTC, P. P. Rasanen
no flags Details
I reproduced the issue in order to get a relevant Xorg.0.log, PFA (33.99 KB, text/plain)
2009-03-22 09:43 UTC, P. P. Rasanen
no flags Details
GDM log files showing errors (270.00 KB, application/x-tar)
2009-05-05 02:50 UTC, P. P. Rasanen
no flags Details
Xorg.0.log (21.60 KB, text/plain)
2009-07-08 23:53 UTC, P. P. Rasanen
no flags Details
dmesg ending with "[drm:i915_getparam] *ERROR* Unknown parameter 6" (36.40 KB, text/plain)
2009-07-08 23:55 UTC, P. P. Rasanen
no flags Details

Description P. P. Rasanen 2008-10-29 03:52:20 UTC
I upgraded to Ubuntu Intrepid beta from Hardy some time ago. My Compaq Evo D510 (external HDD install) has an Intel 845 graphics card. Compiz no longer works after the upgrade from Hardy to Intrepid (see my Launchpad reports ## 283056 and 284461), so I removed Compiz for the time being. Most of the time I can log in to the Gnome session without problems. But when I (or any other user of the machine, for that matter) log out from the Gnome session or try to change user, I get just a black screen, hearing the default Ubuntu GDM login sound but seeing no login screen, just a black screen. In order to continue (to poweroff or reboot or to do anything), I must drop into a VT (Ctrl+Alt+F1). In both /var/log/gdm/0:log.1 and Xorg.0.log.old you can see the error "(EE) intel(0): underrun on pipe A!" filling up the file.

Intermittently, but rarely, the user-change (FUSA) or logout and new login succeeds, but most often they don't.

Current xorg: 1:7.4ubuntu3
xserver-xorg-video-intel: 2:24.4.1-1ubuntu10
Comment 1 Gordon Jin 2008-10-29 05:30:39 UTC
Please provide Xorg.0.log, according to http://www.intellinuxgraphics.org/how_to_report_bug.html
Comment 2 P. P. Rasanen 2008-10-29 12:13:31 UTC
Created attachment 19944 [details]
Xorg.log from a relevant session (Xorg.20.log)

Sorry, I had to leave the computer for a while and forgot to attach the Xorg.log file. Thanks for paying attention!
Comment 3 P. P. Rasanen 2008-10-29 12:23:50 UTC
Created attachment 19945 [details]
Xorg.0.log from the present session, without the underrun error

I suppose you do not need this one, because Xorg.20.log is from a previous session in which the problem occurred. I have not logged out from the present session yet...

BTW, I tried adding the line 

Option 		"ForceEnablePipeB" 	"true"

to the "Device" section of my xorg.conf, but it did not help. Or actually the behaviour changed a bit, because I could log out twice and end up at the graphical GDM screen, but when I then tried to switch user (FUSA), the black screen was again reproduced.
Comment 4 Jesse Barnes 2008-12-18 13:28:22 UTC
We fixed some underrun issues after 2.4.1 was released, do more recent versions still have this problem?
Comment 5 P. P. Rasanen 2008-12-18 16:18:04 UTC
My current version of xserver-xorg-video-intel is 2:2.4.1-1ubuntu10.

I confirm that the underrun problem has been fixed, at least as far as I can see.

I can only speak for myself, though — it appears that others are still encountering problems:


Thank you very much for your work on the problem and for your attention to my request. Happy holidays & new year!
Comment 6 Jesse Barnes 2008-12-18 17:22:34 UTC
Thanks for following up.
Comment 7 P. P. Rasanen 2009-03-22 09:30:20 UTC
Unfortunately I have to return to this issue. 

Oddly enough, after I installed CrunchBang 8.10.02 on another external HDD partition of the same desktop machine (Compaq Evo D 510 SFF with an Intel 845 graphics card), I have been encountering exactly the same logout issue as formerly with the "standard" Ubuntu 8.10. Logging out, I get just a black screen and the GDM login prompt sound; I can login to the graphical OpenBox session "blindfolded" but the screen remains black. So, all I can do is Alt+F3 and reboot to have the graphical GDM and OpenBox back. The "standard" version of Ubuntu has not had this problem since I reported that it was fixed, in Dec. 2008 (see my previous submissions).

My xserver-xorg-video-intel version: 2:2.4.1-1ubuntu10.3
Comment 8 P. P. Rasanen 2009-03-22 09:43:43 UTC
Created attachment 24129 [details]
I reproduced the issue in order to get a relevant Xorg.0.log, PFA
Comment 9 P. P. Rasanen 2009-05-05 02:50:49 UTC
Created attachment 25456 [details]
GDM log files showing errors

The logout -> blackout issue happens surprisingly only with CrunchBang and never with Ubuntu on the same machine. I have TWO different CrunchBang Linux 8.10 installations on the same Compaq Evo (intel i845) AND one partition dedicated to Ubuntu (now 9.04, recently still 8.10), one of CBs on the internal HDD partition and the other on an external HDD. The problem occurs in BOTH CrunchBang installations but not in the "regular" Ubuntu (GDM, Gnome). I'm wondering if this could be actually a GDM bug?

I remember only ONE occasion of being able to logout from an X session without the resultant blackout, so the issue is pretty constant.
Comment 10 P. P. Rasanen 2009-05-05 02:54:07 UTC
Cf. also this: http://crunchbanglinux.org/forums/post/17737/#p17737
Comment 11 Jesse Barnes 2009-05-05 09:42:26 UTC
What version of the xf86-video-intel driver are you using with Crunchbang Linux?  The logs don't seem to say (unless the one from comment #8 is Crunchbang, in which case you're on a pretty old version).  Maybe you could install the packages from Jaunty?
Comment 12 P. P. Rasanen 2009-05-05 10:06:16 UTC
Oh yes, thanks for asking – very silly of me not to think of checking this out: 


So it is indeed still the same version as in comment # 8. I will obtain a newer version and try if I can still reproduce the issue (I guess that's improbable). If everything works after upgrading, I won't bother you anymore about this.
Comment 13 P. P. Rasanen 2009-05-06 12:47:10 UTC
There seems to be no easy way to upgrade xserver-xorg-video-intel with a higher version than 2:2.4.1-1ubuntu10.4. in Intrepid. Trying to upgrade to a Jaunty package returns quite a few unmet dependencies (I tried to fix these by upgrading Xserver-xorg, xserver-xorg-core, etc. etc., but the list seemed endless and I gave up). 

The Jaunty package I tried was Bryce Harrington's pipe underrun debug patch version from his PPA, version 2:2.6.3-0ubuntu10~bug311895~1 (https://launchpad.net/~bryceharrington/+archive/green).


piraja@crashboombang:~$ sudo apt-get update && sudo apt-get install xserver-xorg-video-intel
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
  xserver-xorg-video-intel: Depends: xserver-xorg-core (>= 2: but 2:1.5.2-2ubuntu3.1 is to be installed
E: Broken packages


I also tried xorg-edgers' PPA, but to no avail (I tried that already previously, some weeks ago). Xorg could not be initiated, X froze already before the GDM login screen would have appeared.

So maybe I will just wait until Crunchbang's 9.04 release (well, >=9.05 seems more accurate).

Oh, by the way, I guess ending my previous comment by the sentence "If everything works after upgrading, I won't bother you anymore about this" was a bit stupid – of course I should tell you if the issue can be closed.
Comment 14 Jesse Barnes 2009-05-11 11:21:37 UTC
Adjusting severity: crashes & hangs should be marked critical.
Comment 15 P. P. Rasanen 2009-05-14 23:29:38 UTC
I guess I omitted the significant fact that CrunchBang Linux 8.10 keeps back the kernel 2.6.27-9-generic.
Comment 16 Jesse Barnes 2009-06-23 16:58:45 UTC
Any update on this one, P.P.?
Comment 17 P. P. Rasanen 2009-06-23 23:24:40 UTC
Thanks for asking, Jesse. Nothing new, I'm sorry to say, the problem persists with the kernel 2.6.27-9-generic.
Comment 18 P. P. Rasanen 2009-07-08 23:52:57 UTC
CrunchBang Linux 9.04 was finally released yesterday and I upgraded, the kernel is 2.6.28-13 and the xserver-xorg-video-intel version is 2:2.6.3-0ubuntu9.3. Now the logout issue seems to be fixed, I haven't been able to reproduce it any longer.

Nevertheless, another problem persists. Intermittently (rather often) the boot-up ends with a freeze, X failing to come up, no GDM screen and the keyboard is dead. I have to raise skinny elephants in order to reboot. Sometimes even that does not work, so I just have to hard-reset.

Xorg.0.log does not show an underrun error, but dmesg ends with the following, repeated line:

[   36.430316] [drm:i915_getparam] *ERROR* Unknown parameter 6

PFA the log files which I thought would be relevant. Thanks for your attention!
Comment 19 P. P. Rasanen 2009-07-08 23:53:49 UTC
Created attachment 27510 [details]
Comment 20 P. P. Rasanen 2009-07-08 23:55:10 UTC
Created attachment 27511 [details]
dmesg ending with "[drm:i915_getparam] *ERROR* Unknown parameter 6"
Comment 21 Jesse Barnes 2009-07-09 09:46:56 UTC
(In reply to comment #20)
> Created an attachment (id=27511) [details]
> dmesg ending with "[drm:i915_getparam] *ERROR* Unknown parameter 6"

Those messages just mean your 2D driver is newer than your kernel.  At startup, the 2D driver and DRI clients will check what features the kernel supports; if the kernel doesn't support a given feature (in this case to handle tiled rendering), you'll see errors like that in your log.

Your logs don't seem to have any clues about the freeze unfortunately.  Maybe something in the CrunchBang startup scripts is hanging?  If you narrow it down to a graphics related bug, please open a new one, so we don't end up confusing this particular report.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.