Bug 18249 - [855GM] X crashes with glx backtrace
Summary: [855GM] X crashes with glx backtrace
Alias: None
Product: DRI
Classification: Unclassified
Component: General (show other bugs)
Version: DRI git
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: Jesse Barnes
QA Contact: Xorg Project Team
Keywords: NEEDINFO
Depends on:
Reported: 2008-10-27 12:37 UTC by squid0
Modified: 2008-12-18 15:06 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:

Xorg.0.log showing startup and crash (58.08 KB, text/plain)
2008-10-27 12:37 UTC, squid0
no flags Details

Description squid0 2008-10-27 12:37:43 UTC
Created attachment 19884 [details]
Xorg.0.log showing startup and crash

I'm using Kubuntu 8.10 (KDE 4) Release Candidate
System: Dell D400, Intel 82852/855GM Graphics card.
Using only the laptop screen; no monitors or LCD devices attached.

X crashes suddenly and unpredictably. Not related at all to what I'm doing; there is no pattern (that I can see) in when the crashes occur. I specifically have not been doing any video, including flash. 
X logs show numerous issues, from "(WW) intel(0): Bad V_BIOS checksum", issues with memory on the intel driver, and errors to do with pipes and planes:

intel(0):   Display plane A is now enabled and connected to pipe A.
intel(0):   Hardware claims pipe A is on while software believes it is off
intel(0): Chosen PLL clock of 66.5 Mhz more than 2% away from desired 65.0 M

Then, on a pretty regular basis (a few times a minute), the following lines appear, again and again:
intel(0): tried to update DSPARB with both planes enabled!
intel(0): EDID vendor "IDT", prod id 8902
intel(0): Printing DDC gathered Modelines:
intel(0): Modeline "1024x768"x0.0   65.00  1024 1048 1184 1320  768 771 777 803 -hsync -vsync (49.2 kHz)
intel(0): EDID vendor "IDT", prod id 8902

Also, after at least about 20 minutes of X uptime (on the times where it doesn't crash before that), I get a KDE pop-up window announcing that a new monitor device has been connected, and offering me to configure it, when I have not connected any monitors at all.
Comment 1 squid0 2008-10-27 12:56:39 UTC
I must also add that after X crashes, I see a message on open TTY terminals giving an error message from ipw2200 (the Intel wireless card driver), saying that it can't send SYSTEM_CONFIG, because it's sending a command, or something to that effect. This gets repeated a few times, and visually interrupts anything I might be typing... I'm not sure if this is related to the X crash or not.
Comment 2 squid0 2008-10-28 09:36:52 UTC
Is there any workaround I can do? 
At the moment I don't have a working system at all. 
Something to change in xorg.conf ?
Comment 3 squid0 2008-10-28 13:12:27 UTC
This page helped me a lot: http://bugs.gentoo.org/show_bug.cgi?id=238634
While I haven't been able to stop the regular error messages about "(EE) intel(0): tried to update DSPARB with both planes enabled!" , by disabling compositing (Desktop effects) in KDE4, X seems to be much more stable, and has not crashed so far. 
Comment 4 Jesse Barnes 2008-11-04 17:17:09 UTC
Ah interesting, this actually looks like a GL related bug, since you're seeing glx calls in the crash...
Comment 5 Jesse Barnes 2008-11-04 17:20:37 UTC
Any ideas Haihao?  Could be an incompatible X server & Mesa build...
Comment 6 haihao 2008-11-04 17:59:49 UTC
Are you using mesa7.2? Can you reproduce this issue again? if possible, a full backtrace will help to identify the root cause. 
Comment 7 squid0 2008-11-05 12:41:31 UTC
How do I generate a full backtrace? (Other than producing the crash again)
And what packages do I need installed for that? I'm using Ubuntu. 
I presume xserver-xorg-video-intel-dbg , and also xserver-xorg-core-dbg ?
Comment 8 haihao 2008-11-05 18:22:57 UTC
See http://www.x.org/wiki/Development/Documentation/ServerDebugging for how to use gdb for X crash
Comment 9 Jesse Barnes 2008-12-18 13:29:52 UTC
Ping squid0.  Any additional information?  Or maybe recent versions fixed the crash for you?
Comment 10 squid0 2008-12-18 14:46:08 UTC
Hi Jesse and others.
Sorry for the delay. I am happy to say that with updates (I'm not sure exactly which), video is now playing fine on (k)ubuntu. I did find at one stage that mplayer in particular was problematic, so I'm avoiding using it. However, vlc and dragon player play video just fine! :)
Comment 11 Jesse Barnes 2008-12-18 15:06:26 UTC
Great, thanks for confirming.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.