Bug 17506 - [G45] Cannot switch virtual terminals or return to console on X exit/crash
Summary: [G45] Cannot switch virtual terminals or return to console on X exit/crash
Status: RESOLVED DUPLICATE of bug 16515
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Gordon Jin
QA Contact: Xorg Project Team
Keywords: NEEDINFO
Depends on:
Reported: 2008-09-09 21:52 UTC by Will Saxon
Modified: 2008-09-11 01:28 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:

logfile for session where VT switch or exit from X does not restore proper video to the console (21.08 KB, text/x-log)
2008-09-10 17:08 UTC, Will Saxon
no flags Details

Description Will Saxon 2008-09-09 21:52:08 UTC
I am using xorg-server 1.5, libdrm 2.3.1, mesa 7.1, intel driver 2.4.2 and kernel 2.6.26 on Gentoo linux. I don't know if this is 'officially' xorg 7.4 or not, which is why I left version as unspecified.

I have also tried xorg-server 1.4, mesa 6.5.2, intel drivers 2.4.0 and 2.4.1, libdrm 2.3.0, etc. It doesn't seem to matter.

The problem is that if I am able to get X started at all, I cannot get back to a working console if I exit X, try to switch virtual terminals or if X crashes. Sometimes the video will remain 'frozen' in the last working state, sometimes instead the screen will go black and I will get an error message about the video mode being out of range. 

This is not something I can work around - it happens every time I try to use X. I expect that attempting to use X on any hardware/software configuration similar to my own would reproduce this issue.
Comment 1 Gordon Jin 2008-09-09 23:36:28 UTC
Listing the specific component version (as you did) is fine, thanks.

Please attach Xorg.0.log, and tell which output ports (VGA, DVI, HDMI) available on your G45 and which output ports you are connecting.

I guess this is dup with bug#16515. This only exists on G45.
Comment 2 Will Saxon 2008-09-10 06:20:08 UTC
I have HDMI and DVI onboard, and am trying to use DVI. I have not tried HDMI yet at all, although I intended to once I got my machine set up and working.

Have attached a recent Xorg.0.log.
Comment 3 Will Saxon 2008-09-10 06:22:10 UTC
I guess actually the Xorg.0.log I have right now is not from a session where I try to switch terminals. I will try and get one this afternoon when I get home from work. 
Comment 4 Andrew McNabb 2008-09-10 14:39:59 UTC
I have had the same problem with two motherboards, a Gigabyte GA-EG45M-DS2H and a Gigabyte GA-EG43M-S2H.  One is a G45 and the other is a G43.  In both cases, I have been using DVI output.

Unlike bug 16515, I never seem to be able to get normal text output once X has started.
Comment 5 Will Saxon 2008-09-10 17:08:51 UTC
Created attachment 18813 [details]
logfile for session where VT switch or exit from X does not restore proper video to the console

My .xinitrc just starts an xterm. I started X, moved the mouse around a bit, typed in the xterm a little then hit CTRL-ALT-F1 to try and switch to tty1. Instead of seeing a console on tty1, the screen went black and after a few seconds I received a 'signal out of range' error on my monitor. Hitting ALT-F7 brought me back into X, where I was able to continue moving the mouse, typing, etc. 

I then hit CTRL-ALT-BACKSPACE to exit from X. Instead of seeing a console the screen went black again and after a few seconds I received another 'signal out of range' error.

This is using the DVI port on an Intel DG45ID board.
Comment 6 Gordon Jin 2008-09-11 01:28:47 UTC
I think it's dup with bug#16515.

Andrew, your issue should be different. Please open a new bug according to http://www.intellinuxgraphics.org/how_to_report_bug.html. Thanks.

*** This bug has been marked as a duplicate of bug 16515 ***

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.