Bug 1724 - [ATI/radeon] M9 with DVI out doesn't work in 1600x1200 mode
Summary: [ATI/radeon] M9 with DVI out doesn't work in 1600x1200 mode
Status: RESOLVED DUPLICATE of bug 1129
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: 6.8.0
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Xorg Project Team
QA Contact:
Depends on:
Reported: 2004-10-27 12:09 UTC by Chris S Jones
Modified: 2005-10-06 16:11 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

Xorg.conf (6.76 KB, text/plain)
2004-10-27 12:11 UTC, Chris S Jones
no flags Details
Log file from Xorg (38.76 KB, text/x-log)
2004-10-27 12:12 UTC, Chris S Jones
no flags Details

Description Chris S Jones 2004-10-27 12:09:52 UTC
I have a Dell Inspiron 600m with ATI Radeon Mobility M9 video chip trying to 
drive a Dell 2001FP monitor at 1600x1200 (it's native resolution) over DVI. 
History: 1600x1200 over DVI mode works fine in XFree86 4.3.0.  After switching 
to Xorg 6.8.0, this mode no longer works.  I switched back to XFree to verify 
that it still works OK there on the exact same hardware and cables. 
Some other modes (e.g. 1400x1050, 1280x1024) seem to work fine over DVI.  I can 
Ctrl-Alt-+ to switch between modes to get to one that works. 
When trying to display 1600x1200 over DVI, the panel will intermittently "lock 
on" to the signal and display a desktop for a second or two before blanking 
again.  During the brief time it is displayed, many "snowy" artifacts are 
covering the image, but the desktop is recognizable.  Accessing the 
configuration menu on the monitor indicates that it is trying to interpret the 
signal at a resolution of 1406x1200 (the first number varies randomly between 
1404 and 1426).  For what it's worth, the display does better at locking onto 
the signal when the desktop is blank (i.e. a solid color).  When there are 
multiple windows open, it rarely, if ever, is able to display anything at al. 
After starting up Xorg in this mode, if I then plug in a VGA connector and 
display to the same monitor, the desktop is fine and the system is usable.  It 
seems that the VGA connector is getting a well formed signal but the DVI one is 
not.  I'm not even sure if the VGA connector is supposed to be getting a signal 
since I start X without anything connected to it, but there it is. 
I tried using 'radeontool' to dump some registers out, but the only one that 
was different between Xfree and Xorg was the CRT2_DDC register (a.k.a. MONIDB) 
which has a value of 0x30000 in XFree and a value of 0x300 in Xorg.  This may 
be a red herring since I've been messing with my xorg.conf file for two days 
trying to get this working and I may have changed the config slightly since I 
copied the basic stuff from my XF86Config-4 file. 
I applied a patch that I found on this site which was related to monitor 
detection, but it didn't seem to affect anything. 
For reference, I've included a link to another description of the problem: 
I'll attach my xorg.conf and Xorg.0.log files.
Comment 1 Chris S Jones 2004-10-27 12:11:30 UTC
Created attachment 1185 [details]

I've tried various flavors of IgnoreEDID and HorizSync/VertRefresh with no
Comment 2 Chris S Jones 2004-10-27 12:12:24 UTC
Created attachment 1186 [details]
Log file from Xorg

This log may include additional informational messages which I inserted into
the driver while debugging.
Comment 3 T. Hood 2005-09-23 08:29:13 UTC
I wonder why DDC does not succeed for your monitor.
Comment 4 T. Hood 2005-09-23 10:13:35 UTC

*** This bug has been marked as a duplicate of 1129 ***
Comment 5 T. Hood 2005-10-07 09:11:22 UTC



Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.