Bug 17059 - [945GM/Mac] server upgrade causes VT switch hang
Summary: [945GM/Mac] server upgrade causes VT switch hang
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Jesse Barnes
QA Contact: Xorg Project Team
Keywords: NEEDINFO
Depends on:
Reported: 2008-08-10 09:46 UTC by Felix Möller
Modified: 2008-09-10 11:57 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Description Felix Möller 2008-08-10 09:46:26 UTC
I am using a MacBook of early 2006. 

It has the following graphics card:
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)
00:02.1 Display controller [0380]: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller [8086:27a6] (rev 03)

The system runs solid with openSUSE 11.0 which has intel driver 2.3.1 and X.org

It does crash every time with current X.org (i.e. on switching to tty1.

I tried to debug this issue with Stefan at https://bugzilla.novell.com/show_bug.cgi?id=414189

The Crash does not seem to be influenced by the intel version. I tried 2.2.0, 2.3.1, 2.3.2, 2.4.0 and git and all crashed with

With X.org version my system does not crash.

I can reproduce the crash as follows:
1. boot to kdm
2. switch to tty1
3. switch back to kdm
4. log into any desktop environment (I tried GNOME, KDE4 and TWM)
5. log out back to kdm
6. switch to tty1 *CRASH*

The report at novell has a screenshot of the crash. An Xorg.0.log, my xorg.conf and a log with Option "ModeDebug" set.
Comment 1 Jesse Barnes 2008-08-20 14:20:40 UTC
So this is really a server problem somehow, does Novell have newer X server packages for you to try?  Note that the driver might be incompatible with a given server version, so you may have to rebuild it against the currently installed X server's headers.
Comment 2 Felix Möller 2008-09-10 11:57:17 UTC
I think this is fixed for me with newest versions. It did not happen for a week now.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.