Bug 16928 - [830M] Garbage and incorrect redraws
Summary: [830M] Garbage and incorrect redraws
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.3 (2007.09)
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Carl Worth
QA Contact: Xorg Project Team
Keywords: NEEDINFO
Depends on:
Reported: 2008-07-31 14:18 UTC by monnier
Modified: 2009-09-17 11:24 UTC (History)
6 users (show)

See Also:
i915 platform:
i915 features:

Garbage in KDE with EXA on 855GM (140.15 KB, image/jpeg)
2008-12-19 01:35 UTC, Lukasz Jernas
no flags Details
xorg config (7.41 KB, text/plain)
2008-12-19 01:44 UTC, Lukasz Jernas
no flags Details
Xorg log from 855GM (68.42 KB, text/plain)
2008-12-19 01:45 UTC, Lukasz Jernas
no flags Details
xorg.log (32.53 KB, text/x-log)
2009-03-19 04:52 UTC, Ben. E. Hard
no flags Details
Xorg log, Intel 82865G Integrated Graphics Controller (98.33 KB, text/plain)
2009-03-25 13:47 UTC, William Hanlon
no flags Details

Description monnier 2008-07-31 14:18:39 UTC
I recently started to use my venerable Thinkpad X30 (graphic chipset recognized as i830M by the `intel' driver) as a desktop machine, connected to a 1600x1200 display.

It mostly works fine except for 2 problems:
1 - Very minor: the VGA output can only go through pipe 0, but at startup, if the external monitor is not connected, Xorg chooses pipe 0 for LVDS, so that `xrandr --auto' complains that it can't find a crtc for the VGA.  I can work around it via "xrandr --output LVDS --crtc 1" followed by "xrandr --auto", but ideally `xrandr' should be able to figure that out on its own.

2 - Some of the redraws are mixed up.  I mostly notice it in Firefox where everytime it receives/loses focus (i.e. often with my focus-follows-mouse window-manager), some text gets redrawn but elsewhere, so I have patches of blanks where some text is supposed to be displayed (a few words or a complete line might be missing), and I also have text written at incorrect places.  Also probably related, some pixmaps gets garbled everyone in a while, afterwhich they tend to stay garbled (forcing a redisplay doesn't help).  Those pixmaps may be things like firefox background images, or my window manager's tiled background, or buttons in xpdf, ... presumably pixmaps stored in the Xserver's video memory.

I cannot correlate those problems with any particular change, because I hadn't used this machine in a fairly long while.  The only thing that comes to my mind is that I added "Virtual 2048 2048" to my xorg.conf's display subsection in order to accomodate the external display.

Here's the hopefully relevant part of my Xorg.log:

~-0# egrep -C9 'EE|WW' /var/log/Xorg.0.log
Build Operating System: Linux Debian (xorg-server 2:1.4.2-2)
Current Operating System: Linux alfajor 2.6.25-2-686 #1 SMP Fri Jul 18 17:46:56 UTC 2008 i686
Build Date: 18 July 2008  11:09:10AM
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Jul 31 15:01:22 2008
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Default Screen" (0)
(**) |   |-->Monitor "Internal"
(**) |   |-->Device "Intel Corporation 82830 CGC [Chipset Graphics Controller]"
(**) |-->Input Device "Generic Keyboard"
(**) |-->Input Device "Configured Mouse"
(**) |-->Input Device "Synaptics Touchpad"
(==) Automatically adding devices
(==) Automatically enabling devices
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
        Entry deleted from font path.
(==) FontPath set to:
(II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
        compiled for 1.4.2, module version = 1.0.0
        Module class: X.Org Server Extension
        ABI class: X.Org Server Extension, version 0.3
(II) Loading extension SHAPE
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) intel(0): [drm] Using the DRM lock SAREA also for drawables.
(II) intel(0): [drm] framebuffer mapped by ddx driver
(II) intel(0): [drm] added 1 reserved context for kernel
(II) intel(0): X context handle = 0x1
(II) intel(0): [drm] installed DRM signal handler
(**) intel(0): Framebuffer compression disabled
(**) intel(0): Tiling enabled
(==) intel(0): VideoRam: 131072 KB
(II) intel(0): Attempting memory allocation with tiled buffers.
(WW) intel(0): xf86AllocateGARTMemory: allocation of 10 pages failed
        (Cannot allocate memory)
(WW) intel(0): Failed to allocate texture space.
(II) intel(0): Tiled allocation failed.
(II) intel(0): Attempting memory allocation with untiled buffers.
(WW) intel(0): xf86AllocateGARTMemory: allocation of 10 pages failed
        (Cannot allocate memory)
(WW) intel(0): Failed to allocate texture space.
(II) intel(0): Untiled allocation failed.
(II) intel(0): Couldn't allocate 3D memory, disabling DRI.
(II) intel(0): Attempting memory allocation with untiled buffers.
(WW) intel(0): xf86AllocateGARTMemory: allocation of 10 pages failed
        (Cannot allocate memory)
(II) intel(0): Untiled allocation successful.
(II) intel(0): Page Flipping disabled
(==) intel(0): Write-combining range (0xe0000000,0x8000000)
(II) intel(0): vgaHWGetIOBase: hwp->IOBase is 0x03d0, hwp->PIOOffset is 0x0000
(II) EXA(0): Offscreen pixmap area of 50331648 bytes
(II) EXA(0): Driver registered support for the following operations:
(II)         Solid
(II)         Copy
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 10, (OK)
drmOpenByBusid: Searching for BusID pci:0000:00:02.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 10, (OK)
drmOpenByBusid: drmOpenMinor returns 10
drmOpenByBusid: drmGetBusid reports pci:0000:00:02.0
(EE) AIGLX error: drmMap of framebuffer failed (Invalid argument)(EE) AIGLX: reverting to software rendering
(II) Loading sub module "GLcore"
(II) LoadModule: "GLcore"
(II) Loading /usr/lib/xorg/modules/extensions//libGLcore.so
(II) Module GLcore: vendor="X.Org Foundation"
        compiled for 1.4.2, module version = 1.0.0
        ABI class: X.Org Server Extension, version 0.3
(II) GLX: Initialized MESA-PROXY GL provider for screen 0
(II) intel(0): Setting screen physical size to 432 x 324
(**) Option "CoreKeyboard"
(==) Configured Mouse: Emulate3Buttons, Emulate3Timeout: 50
(**) Configured Mouse: ZAxisMapping: buttons 4 and 5
(**) Configured Mouse: Buttons: 9
(**) Configured Mouse: Sensitivity: 1
(II) Synaptics touchpad driver version 0.14.6 (1406)
Synaptics Touchpad no synaptics event device found
(**) Option "Device" "/dev/psaux"
(**) Option "HorizScrollDelta" "0"
Query no Synaptics: 6003C8
(EE) Synaptics Touchpad no synaptics touchpad detected and no repeater device
(EE) Synaptics Touchpad Unable to query/initialize Synaptics hardware.
(EE) PreInit failed for input device "Synaptics Touchpad"
(II) UnloadModule: "synaptics"
(II) evaluating device (Generic Keyboard)
(II) XINPUT: Adding extended input device "Generic Keyboard" (type: KEYBOARD)
(II) evaluating device (Configured Mouse)
(II) XINPUT: Adding extended input device "Configured Mouse" (type: MOUSE)
(II) Configured Mouse: ps2EnableDataReporting: succeeded
SetClientVersion: 0 9
(II) 3rd Button detected: disabling emulate3Button
(II) intel(0): EDID vendor "SAM", prod id 463
(II) intel(0): 0x007e4000-0x007e4fff: Core cursor (4 kB, 0x000000002965d000 physical
(II) intel(0): 0x007e5000-0x007e8fff: ARGB cursor (16 kB, 0x000000001ae64000 physical
(II) intel(0): 0x007e9000-0x007e9fff: overlay registers (4 kB, 0x0000000029658000 physical
(II) intel(0): 0x007f0000-0x017effff: front buffer (16384 kB)
(II) intel(0): 0x017f0000-0x047effff: exa offscreen (49152 kB)
(II) intel(0): 0x08000000:            end of aperture
(WW) intel(0): ESR is 0x00000010, page table error
(WW) intel(0): PGTBL_ER is 0xf0286052
(WW) intel(0): Existing errors found in hardware state.
(II) intel(0): Output configuration:
(II) intel(0):   Pipe A is on
(II) intel(0):   Display plane A is now enabled and connected to pipe A.
(II) intel(0):   Pipe B is off
(II) intel(0):   Display plane B is now disabled and connected to pipe B.
(II) intel(0):   Output VGA is connected to pipe A
(II) intel(0):   Output LVDS is connected to pipe none
(II) Configured Mouse: ps2EnableDataReporting: succeeded
SetGrabKeysState - enabled
Comment 1 Gordon Jin 2008-07-31 21:33:16 UTC
Please file a separate bug for the first problem.
Please attach xorg.conf and Xorg.0.log, according to http://www.intellinuxgraphics.org/how_to_report_bug.html.
Comment 2 Gordon Jin 2008-08-05 18:19:25 UTC
Let's track the second problem (Some of the redraws are mixed up) here. cworth will take this.
Comment 3 LCID Fire 2008-11-08 10:20:00 UTC
I have the same on a HP Omnibook XE3 using i830M.
Formerly I used the i810 driver which worked fine - but since upgrading to Ubuntu Intrepid the intel driver is used which has these nasty screen corruptions.
Comment 4 LCID Fire 2008-11-08 11:18:59 UTC
BTW: I have also an external monitor in use.
Comment 5 Lukasz Jernas 2008-12-19 01:35:26 UTC
Garbage with redrawing also happens on 855GM with EXA enabled and See attachement for example
Comment 6 Lukasz Jernas 2008-12-19 01:35:59 UTC
Created attachment 21296 [details]
Garbage in KDE with EXA on 855GM
Comment 7 Lukasz Jernas 2008-12-19 01:44:46 UTC
Created attachment 21305 [details]
xorg config
Comment 8 Lukasz Jernas 2008-12-19 01:45:17 UTC
Created attachment 21306 [details]
Xorg log from 855GM
Comment 9 Ben. E. Hard 2009-03-19 04:50:43 UTC
Same here, disappears with "Option" "AccelMethod" "XAA".
Comment 10 Ben. E. Hard 2009-03-19 04:52:12 UTC
Created attachment 24043 [details]
Comment 11 Gordon Schumacher 2009-03-23 10:50:49 UTC
I can additionally confirm this bug on a Thinkpad X30 under the Kubuntu Jaunty Jackalope alpha.

I also seem to remember that long ago when I installed SuSE 10.something on this same machine, I had to manually force it to use the "i810" driver instead of the "intel" driver, otherwise Something Bad Happened (but it's been long enough that I don't recall what).

For me, this occurs even without an xorg.conf file - that is, using the default options.  Additionally, I am also seeing something very much like bug #18319 on this system, with the note that I don't know that I'm seeing the "static" they describe.

As yet I have not managed to find anything at all that looks noteworthy in a log file, so I'm not quite sure what additional information I can post.
Comment 12 William Hanlon 2009-03-25 13:47:47 UTC
Created attachment 24241 [details]
Xorg log, Intel 82865G Integrated Graphics Controller

I have this problem as well and it makes Firefox nearly unusable. It happened when I upgraded from Fedora 9 to Fedora 10. I'm using 82865G Integrated Graphics Controller.
Comment 13 William Hanlon 2009-03-27 09:47:59 UTC
(In reply to comment #9)
> Same here, disappears with "Option" "AccelMethod" "XAA".

I can confirm that setting this option also cures the problem for me using the 82865G. Thanks.
Comment 14 Vlad 2009-06-12 02:24:33 UTC
A lot of with EXA and UXA with i830 graphics.

2.7 driver version, 2.6.29 kernel.

Draws nornmal with XXA, but it's imposible to use it with KMS. 
Comment 15 Vlad 2009-07-30 19:25:16 UTC
As i know XAA and EXA was droped from 2.8 driver, so it's imossible to use this driver wirth i830 video. Is there any progress in solving this problem?
Comment 16 Carl Worth 2009-07-31 09:11:49 UTC
The original reporter of the bug is monnier@iro.umontreal.ca, so my first comment is directed there:

Which version of the driver were you originally using when you saw this bug? And have you tried any newer version since then? If so, is the bug still present?

I'll wait to hear more information from you, and if we don't hear back we'll close this bug report assuming things were fixed.

For everyone else that has commented on this bug, (LCID Fire, Lukasz Jernas, Ben. E. Hard, Gordon Schumacher, William Hanlon, and Vlad):

I very much want to help resolve your bugs, but we're going to have to do that in separate bug reports. The nature of our graphics chips and drivers is such that the various chipsets discussed here, (i830, i865, i945) all have very different hardware and different software. So even when bugs seem the same from the description, they often have different causes so we need to track and resolve the bugs independently.

If each of you that are still having problems with version 2.8 of the driver could please open your own bug report for that with a description of the chipset you've got, the buggy behavior you're seeing, and how to reproduce it. Then I will greatly appreciate that.

I am sorry for the extra bit of work this causes, but this is really the best way to ensure we can get everybody's bugs resolved.


Comment 17 Vlad 2009-07-31 22:16:44 UTC
As i was writing, i had 2.6.29 kernel and 2.7 intel driver. It drawed garbage in EXA or UXA acceleration modes. So, only XAA was workable for me. Today i have 2.6.31-rc4 kernel and 2.7 driver and it has garbage even in XAA, but maybe it doesn't work(i will check it later) and now i'm using vesa driver. 
I will try to compile 2.8 driver later and write results. Do u need any additional information?
Comment 18 Vlad 2009-08-05 12:25:14 UTC
I have updated my Fedora to rawhide, so i could test latest software. And there is a good news for me- garbage has gone! Picture is clear. UXA works. But there are new bugs:
1. When X-server starts without KMS enabled the monitor is black, this is like it is witout power at all, but computer works! I can shutdown it normaly.
2. With KMS monitor is OK, but there is a some bug in picture- it seems to be some cycling shifted to the right. For example: last par of my clock(that located in booton left corner) appears in right bootom corner.
 It can be fixed by switching to tty1(shft+ctrl+f1) and back! After this image on monitor is perfect!
3. Also i think, that xv doesn't work. "[VO_XV] It seems there is no Xvideo support for your video card available." - mplayer sad.

This is versions of software, that i used:
kernel 2.6.31-0.125.rc5.git2.fc12
xorg-x11-drv-intel 2.8.0-3.fc12
xorg-x11-server-Xorg 1.6.99-27.20090804.fc12
Comment 19 Vlad 2009-08-20 12:58:32 UTC
#2 has gone with last update.
Comment 20 Carl Worth 2009-09-17 11:24:46 UTC
(In reply to comment #18)
> I have updated my Fedora to rawhide, so i could test latest software. And there
> is a good news for me- garbage has gone! Picture is clear. UXA works. But there
> are new bugs:

Hi Vlad,

I'm glad things are working better for you now.

I'm closing this bug report now. And please see my comment #16 with regard
to opening new bug reports for new issues, (and one issue per report

Thanks again for all your input,


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.