Bug 16344 (lordcoder) - [GM965] resolution change freezes system
Summary: [GM965] resolution change freezes system
Alias: lordcoder
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Gordon Jin
QA Contact: Xorg Project Team
Keywords: NEEDINFO
Depends on:
Reported: 2008-06-13 14:20 UTC by Bouazza
Modified: 2008-08-16 00:23 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Description Bouazza 2008-06-13 14:20:09 UTC

I've recently installed Ubuntu Hardy Heron ( 8.04 ) on my Acer Aspire 2920Z laptop , with a T2330 Dual-core processor, 2GB DDR2 memory, 160GB HDD and an Intel (R) Graphics Media Accelerator X3100 .

With Ubuntu's default drivers, I can run games and other apps with no problems, but they run too slow with either EXA or XAA ( around 17 FPS with 3DMark 2001, and 798.524 FPS with glxgears ), so I've downloaded the latest Intel drivers from the git repository ( Mesa 7.0branch, xf86-video-intel 2.2.0 and the drm module ), and no performance improvements :-/

Installing the Intel drivers from git gived me another bug ; when I use 3D apps/games which use the fullscreen mode, they totally freeze my laptop ( even CTRL+ALT+BKSPACE doesn't work ), so now, only the Window mode works .

On Windows XP/Vista, all the games I tested ran faster ( and I'm not the only one who thinks that it's the case ) .

My glxinfo output : http://paste.ubuntu.com/19982/ .
My xorg.conf : http://paste.ubuntu.com/19983/ .
My Xorg.0.log : http://paste.ubuntu.com/19985/ .

Please let me know if I need to give you more infos .
Comment 1 Bouazza 2008-06-14 02:32:03 UTC
Here are additional informations about my driconf configuration :
* http://img511.imageshack.us/img511/8276/driconf1fi6.png .
* http://img71.imageshack.us/img71/8195/driconf2xv8.png .
Comment 2 Bouazza 2008-06-14 04:20:26 UTC
Please note also that during the freezes, the mouse ( Synaptics Touchpad in my case ) works, but the events ( clicks etc... ) have no effects, and the keyboard doesn't work .
Comment 3 Gordon Jin 2008-06-15 19:06:40 UTC
Let's focus on the freezing issue with git driver in this bug.

UT2004 (full screen mode) runs fine on my GM965, with the same driver with you (mesa 7_0_branch, xf86-video-intel master branch, drm master branch). Could you give a list for which apps/games have this problem on your side?

For the performance issue, I'm not sure how to define it. Do you mean it's regression? What's the baseline when you say it's "slow"?
Comment 4 Bouazza 2008-06-16 09:17:16 UTC

Thanks for your response .

I discovered that this bug does not come from the full-screen mode, but rather from screen resolution change .

Indeed, I just try to change the screen resolution from 1280x800 to 1280x768, and it worked, then I tried a change from 1280x768 to 1024x768, it has failed and caused a freeze, so I restarted the PC, then tried to return to 1280x800 but without success (freeze too), so I'm blocked here with this ugly 1280x768 ...

For the performance issues, I can just say that all the OpenGL games I can play on Windows are all unplayable under Linux, and it doesn't come from Wine, because I tested also opensource OpenGL games for Windows under Windows Vista, and all they ran fast, but the same games ported to Linux run too slow ( e.g : PlaneShift, Mupen64 with "Super Smash Bros." in the battle versus the Yoshi team because there are too many figures, etc... ), I really don't know how to describe this more, but mouse events are received after 3~5 seconds ( which is really bad on turn based MMORPG games ... ), the mouse moves are too slow, the sounds are also affected by theses lags ( especially when there are too many figures moving ), and there are too many frameskips I think .

Let me know if you need more details .

Thanks .
Comment 5 Wang Zhenyu 2008-06-17 18:16:23 UTC
Which game are you running into this issue?
Comment 6 Gordon Jin 2008-06-17 19:18:46 UTC
change the title to reflect it's caused by resolution change, not full screen.

Please attach xorg.conf and Xorg.0.log (with ModeDebug turned on). You may refer to http://intellinuxgraphics.org/how_to_report_bug.html.

For performance issue, you might open separate bug per app.
Comment 7 Bouazza 2008-06-19 06:20:04 UTC

here's my xorg.0.log : http://paste.ubuntu.com/21395/ ( I can't reproduce the bug with this VESA mode because I have only one resolution with xrandr : 1280x800 ) .
And here's my xorg.conf : http://paste.ubuntu.com/21396/ .
Comment 8 Gordon Jin 2008-06-28 22:06:31 UTC
(In reply to comment #7)
> Hello,
> here's my xorg.0.log : http://paste.ubuntu.com/21395/ ( I can't reproduce the
> bug with this VESA mode because I have only one resolution with xrandr :
> 1280x800 ) .

This log appears to be using VESA driver. We need the log using intel driver.
Comment 9 Michael Fu 2008-07-10 02:01:07 UTC
ping for response, Bouazza.
Comment 10 Gordon Jin 2008-08-16 00:23:16 UTC
Time out so I'm closing. Please reopen it if you could provide the requested info.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.