Bug 16254 - [GM965] Blender rendering freezes system
Summary: [GM965] Blender rendering freezes system
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.3 (2007.09)
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: haihao
QA Contact: Xorg Project Team
Keywords: NEEDINFO
Depends on:
Reported: 2008-06-06 05:26 UTC by Mateusz Kaduk
Modified: 2008-06-20 03:09 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

Xorg log (38.43 KB, text/plain)
2008-06-06 05:26 UTC, Mateusz Kaduk
no flags Details
Xorg.conf that I use (2.85 KB, application/octet-stream)
2008-06-10 21:43 UTC, Mateusz Kaduk
no flags Details
glxinfo command output (4.99 KB, text/plain)
2008-06-10 21:46 UTC, Mateusz Kaduk
no flags Details

Description Mateusz Kaduk 2008-06-06 05:26:09 UTC
Created attachment 16963 [details]
Xorg log

When i run blender 2.46 and try to render fur with particles and probably by closing rendering window during rendering - system crashes.
LCD changes colors to negative, system is not responding and after about 30s it restarts.
I suspected CPU temperature but its not even half of the critical and crashes are reproducable with low temp and full speed fan.
Comment 1 Eric Anholt 2008-06-10 10:53:57 UTC
Blender was working on my systems last I tested.  Could you attach a file you use to reproduce the problem, and instructions on what you do to reproduce?
Comment 2 Mateusz Kaduk 2008-06-10 11:03:43 UTC
Also playing movie in gmplayer casued that I got set gl2 in gmplayer settings.
I cant tell more about it, as system is not responding and restart is needed.
Comment 3 Gordon Jin 2008-06-10 18:38:11 UTC
Reassign to Haihao, as this looks similar to bug#11847, which we can't reproduce either.
Comment 4 Mateusz Kaduk 2008-06-10 21:43:37 UTC
Created attachment 17044 [details]
Xorg.conf that I use
Comment 5 Mateusz Kaduk 2008-06-10 21:46:18 UTC
Created attachment 17045 [details]
glxinfo command output
Comment 6 Mateusz Kaduk 2008-06-10 21:49:18 UTC
Please note, this is not only Xorg crash, but the whole system freezes, colors
go mad. Nothing works, mouse neither. The only difference between that bug
is that screen does not flash between black etc.. Most colors are the same, but
some are changed to bright purple like in negative.

I attached my xorg.conf and output of glxinfo.
This happens 1 on 5-6 times as far with opengl applications.

My laptop is Lenovo Thinkpad T61 with
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960
Integrated Graphics Controller (rev 0c)
Comment 7 haihao 2008-06-10 21:59:01 UTC
You are using mesa7.0.3. Could you try the latest mesa_7_0_branch?
Comment 8 Mateusz Kaduk 2008-06-20 03:09:51 UTC
(In reply to comment #7)
> You are using mesa7.0.3. Could you try the latest mesa_7_0_branch?

I tried git's mesa7.0branch and latest libdrm, but then new mesa 7.0.4 appeared in Debian, after upgrading and using drm/linux-core i915.ko and drm.ko modules I can't reproduce this bug.

Everything now seems to work just fine. I hope it will stay that way and it's not just a lucky case.

Happy blending! :)

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.