Bug 15563 - [945GM] SDL rendering glitches on intel
Summary: [945GM] SDL rendering glitches on intel
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Wang Zhenyu
QA Contact: Xorg Project Team
Keywords: regression
Depends on:
Reported: 2008-04-17 06:13 UTC by Daniel Gryniewicz
Modified: 2008-04-28 08:01 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:

xorg.conf (2.23 KB, text/plain)
2008-04-18 07:04 UTC, Daniel Gryniewicz
no flags Details
log file (37.26 KB, text/plain)
2008-04-18 07:05 UTC, Daniel Gryniewicz
no flags Details

Description Daniel Gryniewicz 2008-04-17 06:13:03 UTC
I have xf86-video-intel-, and I get rendering glitches when running full screen SDL apps (specifically dosbox).  This did not happen with 901, but did happen with 902.

I'm running metacity with the compositor on, so some form of compositing window manager may be necessary to reproduce.

X.Org version:
metacity 2.23.2
Comment 1 Wang Zhenyu 2008-04-17 19:22:10 UTC
Pls provide your xorg.conf and X log.
Comment 2 Wang Zhenyu 2008-04-17 19:27:07 UTC
Does git master have your problem too?
Comment 3 Daniel Gryniewicz 2008-04-18 07:04:35 UTC
Created attachment 16009 [details]
Comment 4 Daniel Gryniewicz 2008-04-18 07:05:29 UTC
Created attachment 16010 [details]
log file

Here's the xorg.conf and log file.  I'll try to test git master as soon as I can, but it probably won't be before the weekend.
Comment 5 Wang Zhenyu 2008-04-20 07:20:08 UTC
Could you describe what's the failure rendering result? I'm running metacity with composite on and dosbox in fullscreen which looks fine at least with simple commands running (like 'intro', etc.).

And what's your mesa version? Is it same for 901 and 903 build tests?
Comment 6 Daniel Gryniewicz 2008-04-20 07:48:59 UTC

If I run dosbox full-screen, I get short, blinking, horizontal white lines around the edges and down the middle of the screen.  I don't have to run any commands in dosbox; merely making it full screen is enough.

If I run a game in dosbox (Master of Orion 2 is what I'm plyaing right now), then the lines are in different parts of the screen depending on what screen I'm displaying, but they're never gone entirely.  Some screens are almost entirely covered by them.  The effect does seem to depend somewhat on what other windows I have open (although, oddly enough, not necessarily on which windows are on the same desktop as the dosbox window).

I'm running mesa 7.0.2, and it's the only version I've had this install.

I have libsdl 1.2.13 with opengl and xv support enabled.

I have dosbox 0.72.

I've put a picture here:

I can attach it if  you'd prefer, but it's fairly big.  The glitch is really not bad at the moment, but you can see the line down the middle.
Comment 7 Wang Zhenyu 2008-04-22 01:27:26 UTC
I can't produce on 915G here too. 

Is this issue gone with and how about 903? Better to try mesa 7.0.3 also.
Comment 8 Daniel Gryniewicz 2008-04-22 06:11:30 UTC
That picture was with 903.  It also happens with 902, but not with 901.  I'll try mesa 7.0.3
Comment 9 Wang Zhenyu 2008-04-22 08:18:24 UTC
Although still can't produce on another hp nx6310 945GM, could you try to revert this commit between 901 and 902 which might be relate to this and test again?

commit 78d260fe9af068ed0445d28f8458850020bc2a8f
Author: Keith Packard <keithp@keithp.com>
Date:   Fri Mar 21 03:08:24 2008 -0700

    Transformed coord computed using floats. Don't move bilinear composite dst.
Comment 10 Daniel Gryniewicz 2008-04-22 09:13:40 UTC
Reverting that commit fixes the problem for me.

I'm more than willing to test any patches you want me to test.
Comment 11 Wang Zhenyu 2008-04-22 19:42:45 UTC
Better to try split that commit into two parts, for is_nearest and float matrix compute. You can split that patch and try to apply one by one and see which one is actually causing your problem.
Comment 12 Daniel Gryniewicz 2008-04-23 06:56:58 UTC
Okay, false positive, sorry.  I accidentally picked up another patch that fixed my problem.  It's called xf86-video-i810-, and Remi can probably explain which one it is.

Sorry for following the wrong track...
Comment 13 Rémi Cardona 2008-04-28 01:10:17 UTC

Could you try bumping locally to 2.3.0 without any patches? (I'll push it to portage when I get the chance). That patch I made for .903 is a backport of 4 or 5 patches that sit in between .903 and 2.3.0.

Comment 14 Daniel Gryniewicz 2008-04-28 08:01:28 UTC
2.3.0 is fine.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.