Bug 15225 - Colorspace corruption on pixmaps
Summary: Colorspace corruption on pixmaps
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: 7.3 (2007.09)
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: xf86-video-ati maintainers
QA Contact: Xorg Project Team
Keywords: NEEDINFO
Depends on:
Reported: 2008-03-27 06:30 UTC by Nate Weibley
Modified: 2009-05-20 04:42 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

screenshot (454.15 KB, image/png)
2008-03-27 06:31 UTC, Nate Weibley
no flags Details
xorg log (72.78 KB, text/plain)
2008-03-27 08:53 UTC, Nate Weibley
no flags Details
fresh xorg log (69.46 KB, text/plain)
2008-03-27 09:00 UTC, Nate Weibley
no flags Details
xorg conf (7.04 KB, text/plain)
2008-03-27 09:00 UTC, Nate Weibley
no flags Details

Description Nate Weibley 2008-03-27 06:30:22 UTC
This randomly occurred while using my desktop casually (browsing the internet) with seemingly no impact on stability. 

Nothing out of the ordinary was reported to the system log, Xorg.0.log, or .xsession-errors. Initially it started when loading a page in firefox and a few pixmaps on the page as well as icons on my panel were corrupted. Then I tried reloading compiz and most of the pixmaps were affected. I tried restarting X but the problem persisted. I also restarted xdm (/etc/init.d/xdm restart) but still everything had this green tinge.

Rebooting fixed the problem and I haven't experienced it again. 

A little background on my system:
I'm using the 2.6.24-gentoo-r1 kernel, git radeon driver (built 2 days ago), git mesa, git mesa/drm, git compiz, and masked branches on the gentoo portage tree (~amd64). I'm running a Gigabyte X800 XT PE and using EXA acceleration (very successfully, I might add)

Attached is a screenshot of the problem as it got worse.
Comment 1 Nate Weibley 2008-03-27 06:31:02 UTC
Created attachment 15503 [details]
Comment 2 Michel Dänzer 2008-03-27 08:38:23 UTC
It'll be hard to do anything about this without a way to reproduce... at the very least though, attach the full xorg.conf and Xorg.0.log before reopening.
Comment 3 Nate Weibley 2008-03-27 08:53:49 UTC
Created attachment 15508 [details]
xorg log
Comment 4 Nate Weibley 2008-03-27 09:00:13 UTC
Created attachment 15509 [details]
fresh xorg log
Comment 5 Nate Weibley 2008-03-27 09:00:33 UTC
Created attachment 15510 [details]
xorg conf
Comment 6 Nate Weibley 2008-03-27 09:06:44 UTC
I will work on trying to find a reliable way to reproduce this bug.
Comment 7 Michel Dänzer 2008-03-27 09:12:01 UTC
If you can reproduce again, please try without Options "AGPMode", "AGPFastWrite" and "AccelDFS".
Comment 8 Nate Weibley 2008-04-07 00:14:58 UTC
A user in the #radeon IRC channel has reported a strikingly similar issue. 
He is using a Lenovo T60p (type 8714-J3G)

Screenshots, his Xorg log, and xorg.conf can be found here:
Comment 9 Michel Dänzer 2008-04-07 02:38:14 UTC
(In reply to comment #8)
> http://yamato.hyte.de/tmp/xorg/

He's using depth 16, does he get the same problem at 24?
Comment 10 Jerome Glisse 2009-05-20 04:42:39 UTC
Closing for inactivity, please reopen if you still have this issue with recent xf86-video-ati driver.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.