Bug 14521 - [855GM] ThinkPad X40 needs ForceEnablePipeA specified, otherwise unstable.
Summary: [855GM] ThinkPad X40 needs ForceEnablePipeA specified, otherwise unstable.
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Jesse Barnes
QA Contact: Xorg Project Team
Keywords: NEEDINFO
Depends on:
Blocks: 13493
  Show dependency treegraph
Reported: 2008-02-16 04:11 UTC by Soenke
Modified: 2008-02-21 08:44 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:

Output of lspci -v (6.31 KB, text/plain)
2008-02-16 04:11 UTC, Soenke
no flags Details
Output of lspci -vn (4.97 KB, text/plain)
2008-02-16 04:13 UTC, Soenke
no flags Details
xorg.conf (3.66 KB, application/octet-stream)
2008-02-16 04:14 UTC, Soenke
no flags Details
xorg log with ForcePipeAEnabled set to true (196.94 KB, application/octet-stream)
2008-02-18 09:03 UTC, Soenke
no flags Details
xorg log with ForcePipeAEnabled set to false (81.99 KB, text/plain)
2008-02-18 09:04 UTC, Soenke
no flags Details
Logfile from a crashed server (72.28 KB, text/plain)
2008-02-18 09:26 UTC, Soenke
no flags Details
Picture of crashed display (589.54 KB, image/png)
2008-02-18 09:38 UTC, Soenke
no flags Details
Add pipe a force enable quirk for x40 (451 bytes, patch)
2008-02-20 11:56 UTC, Jesse Barnes
no flags Details | Splinter Review
xorg log with patch added (149.89 KB, text/plain)
2008-02-21 01:16 UTC, Soenke
no flags Details

Description Soenke 2008-02-16 04:11:28 UTC
Created attachment 14350 [details]
Output of lspci -v

Hi there,

after many crashes while switching displays on my X40, I tried setting

Option "ForceEnablePipA" "true"

in xorg.conf. Et voila, works like a charm!
The man page for the intel driver stated that I should file a bug report about this, so here it is.
Output from lspci -v[n] is attached as requested. So is my xorg.conf.




- debian testing/unstable, kernel 2.6.22-3-686
- xorg 7.3
- xserver from debian unstable
- intel driver from debian unstable, 
also tested git master branch from 20080215
Comment 1 Soenke 2008-02-16 04:13:58 UTC
Created attachment 14351 [details]
Output of lspci -vn
Comment 2 Soenke 2008-02-16 04:14:26 UTC
Created attachment 14352 [details]
Comment 3 Gordon Jin 2008-02-17 02:22:11 UTC
Please attach Xorg.0.log with and without ForceEnablePipeA setting.

Has the old driver ever worked for this machine without ForceEnablePipeA?
Comment 4 Michael Fu 2008-02-17 21:13:47 UTC
Besides, Is this a regression or the X40 never worked well? 

Please refer to http://www.intellinuxgraphics.org/how_to_report_bug.html for required info that could help us to fix this issue. thanks.
Comment 5 Daniel Stone 2008-02-18 00:16:24 UTC
FWIW (can't provide logs as that particular laptop was stolen), the X40 has worked fine for as long as the 855GM code has, both in 1.x and modesetting, so yes, this is a regression.
Comment 6 Soenke 2008-02-18 09:03:20 UTC
Created attachment 14385 [details]
xorg log with ForcePipeAEnabled set to true
Comment 7 Soenke 2008-02-18 09:04:10 UTC
Created attachment 14386 [details]
xorg log with ForcePipeAEnabled set to false
Comment 8 Soenke 2008-02-18 09:24:57 UTC
Sorry, I was a bit in a rush when first reporting this bug. 
So here is some more info.

As far as I can remember, I never had probems with the old (i810 1.7.2) driver. Ever since using intel 2.x, I had stability issues. The latest is that when I switched displays with xrandr, the system would sometimes freeze. At first I thought it was related to OpenGL (see the bug I filed in debian bug tracker: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=464793 ), but it turned out to happen also when I did not use any OpenGL apps.

Steps to reproduce:

1. Connect external monitor
2. Use xrandr to switch to external monitor
3. Use xrandr to turn external monitor of
4. Repeat 2. and 3. until crash

Sometimes switching to a VT (using Ctrl+Alt+F1) after step 3. caused the crash, leaving me with a black screen and totally unresponsive system. No VT switching, no Alt+Sysrq, no ssh connection.

If it crashed without VT switch, I got a garbled screen (I will attach some images of it) that faded to black, faded back to light and back to black. This left the system in an equivalent state to the one described above.

This behaviour could be observed with the current debian unstable version of the driver ( as well as the git master and xf86-video-intel-2.2-branch versions.

Adding the ForceEnablePipeA seems to fix this problem. I will also attach a xorg log file of a crashed server.

Hope that helps,


Comment 9 Soenke 2008-02-18 09:26:25 UTC
Created attachment 14387 [details]
Logfile from a crashed server
Comment 10 Soenke 2008-02-18 09:38:19 UTC
Created attachment 14388 [details]
Picture of crashed display
Comment 11 Jesse Barnes 2008-02-19 17:32:59 UTC
Ok, we'll add the quirk for your laptop.  Thanks for taking the time to file a report.
Comment 12 Jesse Barnes 2008-02-20 11:56:25 UTC
Created attachment 14460 [details] [review]
Add pipe a force enable quirk for x40

Soenke, can you give this patch a try?  It should keep you from having to use the xorg.conf option by making the driver do it automatically.
Comment 13 Soenke 2008-02-21 01:16:04 UTC
Created attachment 14478 [details]
xorg log with patch added

Tested the patch (against te 2.2-branch),  seems to work fine and have the same effect as the config option.
Also, I have not had any more crashes.

Thanks for the help and the quick fix!


Comment 14 Jesse Barnes 2008-02-21 08:44:46 UTC
Great, thanks for testing.  Fixed in 33802b6ee3c298bae4d2b6f464ee5cc730a58506.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.