Bug 14366 - [945GM] horizontal stripes while scrolling on external monitor, if disable tiling
Summary: [945GM] horizontal stripes while scrolling on external monitor, if disable ti...
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.3 (2007.09)
Hardware: Other All
: medium normal
Assignee: Wang Zhenyu
QA Contact: Xorg Project Team
Keywords: NEEDINFO
Depends on:
Blocks: 15000
  Show dependency treegraph
Reported: 2008-02-04 02:32 UTC by Maximilian Mehnert
Modified: 2008-03-18 22:59 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:

screenshot of the horizontal stripes (95.35 KB, image/jpeg)
2008-02-04 02:32 UTC, Maximilian Mehnert
no flags Details

Description Maximilian Mehnert 2008-02-04 02:32:08 UTC
Created attachment 14134 [details]
screenshot of the horizontal stripes


1280x1024 above of 1280*800 with xrandr.
Depth: 24

Only Option in xorg.conf Device section:
Option          "AccelMethod"   "XAA"
(But changing that to EXA does nothing regarding the problem.)

Both monitors at 60Hz:
1280x1024      60.0*+   74.9     75.0     71.9     59.9 
1280x800       60.0 +   60.0 

Problem: When I scroll a window's content that is wider than 3/4 of the screen width, odd horizontal stripes (1px height) appear in the right and left quarter of the screen.

They go away when another window is moved over the region where they appear or when another window is opened and appears at a totally different place not necessarily overlapping that region (when redrawing is happening).

Also, the inter-stripe distance is proportional to scrolling speed. 
It's like there is one stripe in the left lower corner and one at the right 1/4 from the bottom before scrolling and when the window content get's scrolled, they move up/down while a new stripe appears left and right (feels like one for every refreshing cycle of the screen).

Also, the color of the stripe on the right side matches the region where stripes appear on the left side and vice versa. 

Screenshot of the effect is attached.

Fetched the intel driver from the git repository today, but I'm not sure whether it's a problem of the driver.

Comment 1 Maximilian Mehnert 2008-02-04 07:11:54 UTC
Apparently for some unknown reason, I had
Option     "Tiling" "false" in there.
Don't know how I overlooked that. 
Removing it solved the problem.
Comment 2 Wang Zhenyu 2008-02-04 19:42:21 UTC
How about only disable fbc by turning on tiling be default?

Option "FramebufferCompression" "false"
Comment 3 Maximilian Mehnert 2008-02-07 05:10:31 UTC
Well, with 

	Option     "FramebufferCompression" "false"
	Option     "Tiling" "true"


	Option     "FramebufferCompression" "false"
	#Option     "Tiling" "true"

or just an empty section just with

        Identifier      "Intel945GM/GMS
        Driver          "intel"
        BusID           "PCI:0:2:0"

everything is just fine - if you meant that :-)

The stripes appear with explicitly setting tiling to false - I just overlooked the "Tiling" line since I had commented out everything in that section (stuff that was still there from older and different setups, even from before it became
Driver          "intel"
) but overlooked the <Option     "Tiling" "false> line

Comment 4 Wang Zhenyu 2008-02-11 08:19:19 UTC
yeah, I mean default setting should work fine (tiling + fbc), and from your first config test, only disable fbc caused problem you saw. Have you tried with current version?
Comment 5 Wang Zhenyu 2008-02-11 20:36:29 UTC
oh, my last comment was wrong, disable tiling could trigger your problem...
Comment 6 Maximilian Mehnert 2008-02-13 09:17:17 UTC
Hmm. No for me it looks as if turning on FramebufferCompression triggers the problem. 
With FramebufferCompression off it's ok.
Comment 7 Gordon Jin 2008-02-19 00:12:50 UTC
(In reply to comment #6)
> Hmm. No for me it looks as if turning on FramebufferCompression triggers the
> problem. 

Mm? Your comment #1 shows it's triggered by turning off tiling, not FramebufferCompression (default on). Right?

Comment 8 Wang Zhenyu 2008-02-25 06:37:07 UTC
I can't see the issue on 945GM here, either with tiling or fbc off.

Is this still valid? Or if you still see the problem, could you paste your used xorg.conf and X log?
Comment 9 Michael Fu 2008-02-29 16:46:30 UTC
ping response from Maximilian. It looks not a bug to me as the default setting actually works.. 

Anyway, Maximilian, your comment in comment# 6 looks confusing. please clarify.
Comment 10 Michael Fu 2008-03-12 00:07:24 UTC
ping Maximilian...
Comment 11 Wang Zhenyu 2008-03-18 22:59:30 UTC
I'll close this one. pls reopen if this's still a bug.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.