Bug 13380 - Intel driver lockup after execution of mu-cade or wine/open-gl with pixel shader
Summary: Intel driver lockup after execution of mu-cade or wine/open-gl with pixel shader
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.3 (2007.09)
Hardware: Other All
: medium normal
Assignee: haihao
QA Contact: Xorg Project Team
URL: http://bugs.debian.org/cgi-bin/bugrep...
Keywords: NEEDINFO
Depends on:
Reported: 2007-11-24 05:36 UTC by Brice Goglin
Modified: 2008-03-10 15:12 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Description Brice Goglin 2007-11-24 05:36:59 UTC
Reported by Marco Nenciarini on the Debian BTS 2 months ago. Occurs at least with intel 2.1 and 2.2. He says:
"After executing mu-cade (entered today in sid) my X server died, then X server refuse to start (sometime locking the video hardware) until next reboot."

and recently:
"Version 2:2.2.0-1 havbe the same problem with mu-cade and additionally crash in the same maneer when I run any wine emulated opengl games using pixel shader (wine 0.9.47~winehq0~debian~4.0-1 from winehq.org)"

The log of the lockup is available at http://bugs.debian.org/cgi-bin/bugreport.cgi?msg=5;filename=Xorg.0.log.crash;att=1;bug=442235

FWIW, he can reproduce the problem easily.
Comment 1 haihao 2007-12-02 18:34:23 UTC
Hi, Gordon
 Could you help to try it with the lates components?
Comment 2 haihao 2008-03-04 23:49:29 UTC
Hi, Brice
    Does this occur on git master?

Comment 3 Brice Goglin 2008-03-10 15:12:52 UTC
Marco said a couple days ago on the Debian BTS:
"ATM I'm using git tip of drm and mesa and the problem seem to be solved."

So I guess we can close this.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.