Bug 12428 - ftp://ftp.x.org/pub/X11R7.3/src/everything/ contains incorrect versions of some packages
Summary: ftp://ftp.x.org/pub/X11R7.3/src/everything/ contains incorrect versions of so...
Alias: None
Product: xorg
Classification: Unclassified
Component: Release (show other bugs)
Version: unspecified
Hardware: All All
: highest major
Assignee: Alan Coopersmith
QA Contact: Xorg Project Team
Whiteboard: 2011BRB_Reviewed
Depends on:
Reported: 2007-09-14 13:05 UTC by Serge van den Boom
Modified: 2012-03-13 21:57 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Description Serge van den Boom 2007-09-14 13:05:23 UTC
The packages in ftp://ftp.x.org/pub/X11R7.3/src/everything/ don't work together. It appears that some of the driver packages are old versions. This is the case for at least the following packages: xf86-input-evdev, xf86-input-vmmouse, xf86-input-void. And there may be more (I only compile the ones I need).
Also, there are two versions of damageproto in that dir.

Note: I had to specify the version as "unspecified" in the bug tracker, as there is no 7.3 option.
Comment 1 Daniel Stone 2009-08-31 17:56:18 UTC
quite clearly not a 7.5 issue.
Comment 2 Serge van den Boom 2009-08-31 23:50:50 UTC
Actually, 7.4 had the same problem.
Comment 3 Jeremy Huddleston Sequoia 2011-09-24 22:09:00 UTC
Alan, is this valid?
Comment 4 Alan Coopersmith 2011-09-25 09:10:59 UTC
As far as I know we always had the right versions of the maintained drivers
in those directories, and all the drivers mentioned in the description are
well maintained.   Many of the older, unmaintained input drivers may not
have worked - but we've mostly solved that by dropping them completely.

X11R7.3/src/everything/ only has damageproto-1.1.0, not two versions.

As I can't see any problems, I'm closing - if you still see issues, then
please reopen and provide details of what was wrong with the included
versions and what you expect the included versions to be.
Comment 5 Serge van den Boom 2011-09-25 09:41:31 UTC
I don't recall the exact problem, and I doubt that anyone still cares.
I do remember that there were issues with multiple packages.

And there still are two versions of damageproto, damageproto-1.0.3 and damageproto-1.1.0.
Direct links:
Comment 6 Alan Coopersmith 2011-09-25 09:52:03 UTC
Strange, the ftp & http versions are out of sync - they should be the same,
I guess the mirroring isn't quite a full sync.

I was checking the master copy at:

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.