Bug 10784 - Intel driver 2.0 only does not detect 1680x1050
Summary: Intel driver 2.0 only does not detect 1680x1050
Status: RESOLVED DUPLICATE of bug 12262
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.2 (2007.02)
Hardware: Other All
: high normal
Assignee: Hong Liu
QA Contact: Xorg Project Team
URL: http://bugs.debian.org/cgi-bin/bugrep...
: 10844 (view as bug list)
Depends on:
Blocks: 13027
  Show dependency treegraph
Reported: 2007-04-27 15:44 UTC by Brice Goglin
Modified: 2007-11-07 22:10 UTC (History)
5 users (show)

See Also:
i915 platform:
i915 features:

xorg.conf with DDC disabled (2.99 KB, application/octet-stream)
2007-04-27 15:45 UTC, Brice Goglin
no flags Details
Xorg.0.log with DDC disabled (36.41 KB, text/plain)
2007-04-27 15:45 UTC, Brice Goglin
no flags Details
Xorg.0.log with DDC (72.69 KB, application/octet-stream)
2007-04-27 15:45 UTC, Brice Goglin
no flags Details
xrandr --verbose output (1.61 KB, application/octet-stream)
2007-04-27 15:46 UTC, Brice Goglin
no flags Details
log with Option "DDC" "off" (69.63 KB, text/plain)
2007-09-06 02:40 UTC, Tino Keitel
no flags Details
log with Option "DDC" "on" (78.41 KB, text/plain)
2007-09-06 02:42 UTC, Tino Keitel
no flags Details
working config with a proper modeline (2.93 KB, text/plain)
2007-09-12 04:14 UTC, Tino Keitel
no flags Details

Description Brice Goglin 2007-04-27 15:44:48 UTC
This bug has been reported on the Debian BTS by Tino Keitel 2 days ago. He's using a i945 board with an external TFT monitor on the DVI output. He was getting 1680x1050 with the old driver (and 915resolution). With driver 2.0, the server starts with 1280x1024 (I actually wonder whether it's 1280x1024 or 1280x800...) and xrandr does not propose 1680x1050 at all. The log says that 1680x1050 is out of sync.

He mentions that the TFT reports 115 kHz for HorizSync and 57 Hz for VertRefresh, whereas Xorg reports other numbers for this mode (119 kHz and 59,9 Hz). The TFT also has no problem with resolutions below or above 60 Hz. He already used it on an Amiga computer with scandoubled PAL resolution, which is 50 Hz.

He initially had DDC disabled because otherwise he was getting a out-of-sync screen. I will attach the corresponding config and log below, and then I'll attach the log with DDC enabled.
Comment 1 Brice Goglin 2007-04-27 15:45:13 UTC
Created attachment 9758 [details]
xorg.conf with DDC disabled
Comment 2 Brice Goglin 2007-04-27 15:45:32 UTC
Created attachment 9759 [details]
Xorg.0.log with DDC disabled
Comment 3 Brice Goglin 2007-04-27 15:45:51 UTC
Created attachment 9760 [details]
Xorg.0.log with DDC
Comment 4 Brice Goglin 2007-04-27 15:46:12 UTC
Created attachment 9761 [details]
xrandr --verbose output
Comment 5 Johannes Engel 2007-05-03 03:11:50 UTC
*** Bug 10844 has been marked as a duplicate of this bug. ***
Comment 6 Tino Keitel 2007-07-23 13:25:59 UTC

this bug is still present in version 2.1.0 of the Intel driver. Do you need further information to fix it?
Comment 7 Tino Keitel 2007-07-25 05:47:12 UTC

maybe I should mention that this computer is a Mac mini, not a laptop. So the DVI-out is the only video out available, and doesn't work for me as of 2.0.0. My concern is that the old driver that I have to use won't work anymore with upcoming versions of the Xorg server.
Comment 8 Jason Martens 2007-08-13 19:10:56 UTC
I also reported this bug to the debian BTS. After upgrading to the 2.1 intel driver, 1366x768 stopped working (used to use i810 and 915resolution).  xrandr reports 1024x768 as the max resolution.  Log file and xconfig are at http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=435621. 

Has there been any progress on this?  My wife is getting tired of using her laptop at 1024x768. ;-)

Comment 9 Tino Keitel 2007-09-06 02:40:22 UTC
Created attachment 11445 [details]
log with Option "DDC" "off"

This log was created with Option "DDC" "off". I got only 1280x768, not 1680x1050, despite the ModeLine for 1680x1050 that was in the config file.
Comment 10 Tino Keitel 2007-09-06 02:42:16 UTC
Created attachment 11446 [details]
log with Option "DDC" "on"

This log was created with Option "DDC" "on". I got a black screen and my TFT says "57 Hz". Obviously, Xorg calculates wrong timings.
Comment 11 Tino Keitel 2007-09-06 02:47:02 UTC

the above logfiles are created with a GIT version from 2007-09-05. I'd be glad if someone can give me a hint what else I could try to get a useable configuration with the Intel driver, or at least what further information is needed.

Currently, I can't get a usable screen at the native TFT resolution (1680x1050) at all. Note that this is not a laptop, but a desktop computer, so the TFT is the only way to get video output to work with.
Comment 12 Tino Keitel 2007-09-06 02:55:10 UTC
Forgot to mention: The logfiles are now created with ModeDebug set to "yes".
Comment 13 Keith Packard 2007-09-06 18:48:01 UTC
This looks like the sync polarities are backwards; we had a bug in the X server (not the driver) that would flip the polarities. You should try a custom mode line using +hsync -vsync as cvt -r 1680 1050 shows. Many LCD monitors get very confused when you use the wrong polarity...
Comment 14 Tino Keitel 2007-09-10 03:19:48 UTC
I tried with this modeline with and without DDC enabled. The result is the same. 

Actually, I didn't even see the supplied modeline mentioned in the log files. Could it be that the intel driver completely ignores modelines supplied by the user?
Comment 15 Tino Keitel 2007-09-12 04:14:38 UTC
Created attachment 11527 [details]
working config with a proper modeline

The attached config works gives me a working 1680x1050 mode.

However, when I tried quake3, it switched to a lower resolution, that also used non working parameters. I'll try again with more strict values for HorizSync when I have some spare time.
Comment 16 Michael Fu 2007-11-05 18:04:34 UTC
What is your monitor's model name? A quirk may be needed for this monitor... see bug# 12439.
Comment 17 Hong Liu 2007-11-07 22:10:13 UTC
this seems to be the same problem with bug 12262.

From the log:
(II) intel(0): Modeline "1680x1050"x59.9  119.00  1680 1728 1760 1840  1050 1053 1059 1080 -hsync +vsync (64.7 kHz)
chosen: dotclock 115200 vco 2304000 ((m 120, m1 20, m2 8), n 3, (p 20, p1 2, p2 10))
the mode probled requires 119MHz dotclock while our driver can only find 115.2MHz which leads to the incorrect display you experienced.

Change to use the configured mode you specified exceeds the capability of your monitor (not sure whether it will damage your monitor).
(II) intel(0): Ranges: V min: 59  V max: 61 Hz, H min: 31  H max: 65 kHz, PixClock max 120 MHz

We are working on fixing the dotclock programming issue now, hoping all the mode display issue will be fixed then :)

*** This bug has been marked as a duplicate of bug 12262 ***

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.